Leap 15.4 - xorgxrdp problem with make

I am trying to make xorgxrdp (https://github.com/neutrinolabs/xorgxrdp) version 0.2.17 from github (Please don’t say that I’m not using a package from the official repositories. I have my reasons for that.) on opensuse leap 15.4. I ran bootstrap first and everything went fine. Then I ran configure and everything was fine as well. I then entered the make command and I get these error messages:
make all-recursive
make[1]: Entering directory ‘/home/xrdp/xorgxrdp-0.2.17’
Making all in module
make[2]: Entering directory ‘/home/xrdp/xorgxrdp-0.2.17/module’
Making all in amd64
make[3]: Entering directory ‘/home/xrdp/xorgxrdp-0.2.17/module/amd64’
make[3]: Nothing to be done for ‘all’.
make[3]: Leaving directory ‘/home/xrdp/xorgxrdp-0.2.17/module/amd64’
make[3]: Entering directory ‘/home/xrdp/xorgxrdp-0.2.17/module’
CC rdpClientCon.lo
rdpClientCon.c: In function ‘rdpClientConProcessMsgClientInfo’:
rdpClientCon.c:974:31: error: ‘struct xrdp_client_info’ has no member named ‘monitorCount’
if (clientCon->client_info.monitorCount > 0)
rdpClientCon.c:977:84: error: ‘struct xrdp_client_info’ has no member named ‘monitorCount’
LLOGLN(0, (" client monitor data, monitorCount=%d", clientCon->client_info.monitorCount));
rdpClientCon.c:57:43: note: in definition of macro ‘LLOGLN’
do { if (_level < LOG_LEVEL) { ErrorF _args ; ErrorF("
"); } } while (0)
rdpClientCon.c:980:50: error: ‘struct xrdp_client_info’ has no member named ‘minfo’
memcpy(dev->minfo, clientCon->client_info.minfo, sizeof(dev->minfo));
rdpClientCon.c:981:51: error: ‘struct xrdp_client_info’ has no member named ‘monitorCount’
dev->monitorCount = clientCon->client_info.monitorCount;

make[3]: *** [Makefile:649: rdpClientCon.lo] Error 1
make[3]: Leaving directory ‘/home/xrdp/xorgxrdp-0.2.17/module’
make[2]: *** [Makefile:668: all-recursive] Error 1
make[2]: Leaving directory ‘/home/xrdp/xorgxrdp-0.2.17/module’
make[1]: *** [Makefile:433: all-recursive] Error 1
make[1]: Leaving directory ‘/home/xrdp/xorgxrdp-0.2.17’
make: *** [Makefile:365: all] Error 2
Please how to solve my problem? Thanks

I suggest to use the openSUSE Build Service to build for you instead of trying to build it yourself. It’s free.

I solved this problem. I had the old package xorgxrdp.
Thank you all for your reply.