Leap 15.4 kein Ausdruck aus Anwendungen nach update von util-linux

Mein Drucker ist ein Canon PIXMA G4511 und hat mit Turboprint bisher einwandfrei funktioniert.
Seit dem update von util-linux und util-linux-lang, bei dem vom System über 200 Dateien und über 100 alte Kernel gelöscht wurden, kann ich aus Anwendungen (Libreoffice, Firefox, Kate uvm.) nichts mehr ausdrucken.

In Yast - Hardware - Drucker wird der Drucker erkannt und ich kann auch eine Testseite ausdrucken. Das gleiche ist auch bei Turboprint Control, da kann ich auch die Testseite ausdrucken. Bei Turboprint Monitor wird der Drucker mit Status: bereit, nimmt Jobs an und der letzte Druckauftrag (Testseite) angezeigt.
Wenn ich z.B. aus Writer etwas drucken will, öffnet sich der Druckdialog und wenn ich auf “Drucken” klicke, kommt die Meldung:
Der Drucker konnte nicht gestartet werden.
Bitte überprüfen Sie Ihre Druckerkonfiguration.

In der Bash wird der Drucker mit “lsusb” auch angezeigt.
Bus 003 Device 003: ID 04a9:183d Canon, Inc. G4010 series

Ich habe schon Turboprint gelöscht und mit der aktuellen Version wieder installiert und auch bei Yast den Drucker neu erkennen und konfigurieren lassen. Alles hat nichts geholfen.
Wenn ich etwas aus dem Internet ausdrucken will öffnet sich auch der Druckdialog und wenn ich auf “Drucken” klicke, verschwindet der Dialog aber es passiert nicht, auch keine Meldung.

Hat jemand sowas schon mal erlebt und kann mir mit Tips weiter helfen?

Gruß Gindi

Es ist leider unklar um welchen openSUSE Version es sich hier handelt.

Auch ist unklar was du gemachst hat wenn du umschreibst “Seit dem update von util-linux und util-linux-lang”, welches Kommando oser sonst?

Hellsehend sind die Meisten hier nicht.

Ich verstehe die Frage nach der Version nicht. Im Titel steht doch Leap 15.4 oder ist das keine Version?

“Seit dem update von util-linux und util-linux-lang” meine ich damit, daß mir das wochenlang als neue Aktualisierung angezeigt wurde aber ich habe es nicht aktualisiert wegen der vielen Dateien und Kernel die gelöscht werden sollten.
Vor zwei Tagen habe ich der Aktualisierung doch zugestimmt und Yast hat 30 min lang aktualisiert und Dateien und alte Kernel gelöscht.
Mehr habe ich nicht gemacht und seitdem besteht das Problem mit dem Drucker.

Gruß Gindi

Du hast recht. Das 15.4 sollte klar sein. Entschuldige.

Aber das Update nicht. Benutzt du dazu YaST oder zyper up, oder …

Wen du lange nicht aktualisiert hast und jetzt das auf einmahl nachgeholt hast, wird es schwierig sein hearauzufinden welche Paketerneurung das war. Möglicherweise ist das von Andern schon lange her gemacht worden :frowning:

So viele Kernel kann das aber nicht gelöscht haben…

Denn lt. zypp.conf werden per default nur 2 Kernel behalten…
grep multiversion /etc/zypp/zypp.conf

Poste mal:
zypper se -si kernel

J, ich mache alles mit Yast.
Eine detailierte Erklärung zur Paketerneuerung und den Kernels ist in meinem Post vom Dezember 2022 Problem bei update Leap 15.3 zu Leap 15.4

Gruß Gindi

Hier der gewünschte Ausdruck:

herbert@linux-hhj1:~> zypper se -si kernel
Repository-Daten werden geladen…
Installierte Pakete werden gelesen…

S | Name | Type | Version | Arch | Repository
—±----------------------------±------±-----------------------±-------±------------------------------------------------------------
i+ | kernel-default | Paket | 5.14.21-150400.24.41.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-default | Paket | 5.14.21-150400.24.38.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-default | Paket | 5.14.21-150400.24.33.2 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-extra | Paket | 5.14.21-150400.24.41.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-extra | Paket | 5.14.21-150400.24.38.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-extra | Paket | 5.14.21-150400.24.33.2 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-optional | Paket | 5.14.21-150400.24.41.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-optional | Paket | 5.14.21-150400.24.38.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-default-optional | Paket | 5.14.21-150400.24.33.2 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-docs | Paket | 5.14.21-150400.24.41.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-all | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-amdgpu | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-ath10k | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-ath11k | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-atheros | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-bluetooth | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-bnx2 | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-brcm | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-chelsio | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-dpaa2 | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-i915 | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-intel | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-iwlwifi | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-liquidio | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-marvell | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-media | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-mediatek | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-mellanox | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-mwifiex | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-network | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-nfp | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-nvidia | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-platform | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-prestera | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-qcom | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-qlogic | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-radeon | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | kernel-firmware-realtek | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-serial | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-sound | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-ti | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-ueagle | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | kernel-firmware-usb-network | Paket | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | purge-kernels-service | Paket | 0-8.3.1 | noarch | Haupt-Repository

Gruß Gindi

Der Unterschied zwischen kernel-default und kernel-firmware Paketen sollte klar sein. Das heißt es ist extrem unwahrscheinlich das dein System jemals “hunderte” Kernel installiert hatte (was gar nicht möglich wäre, erstens weil Leap 15.4 gar nicht so lange existiert und zweitens aus Speicherplatzgründen bezüglich boot/EFI Partition)

Da hattest du aber unter Leap 15.4 noch kernel aus Leap 15.2 installiert und die haben das Update gestört…
Also nichts besonderes…

Hast du mal den Drucker in turboprint gelöscht und neu eingerichtet?

Hast du mal Turboprint gelöscht und neu eingerichtet?

Was sagt als root:

systemctl status tpdaemon.service

Ich habe nicht geschrieben daß “hunderte” Kernel installiert sind/waren sondern die waren irgenwo gespeichert, und diese Einträge wurden bei der Aktualisierung gelöscht.

Gruß Gindi

Da hattest du aber unter Leap 15.4 noch kernel aus Leap 15.2 installiert und die haben das Update gestört…
Also nichts besonderes…

Das ist so nicht richtig. Installiert war der Kernel aus Leap 15.4, die anderen waren nur irgendwo gespeichert.

Ich hatte Turboprint deinstalliert und die aktuelle Version neu installiert, das hatte ich in meinem ersten Beitrag geschrieben.

Der Ausdruck von systenctl:

systemctl status tpdaemon.serviceherbert@linux-hhj1:~> systemctl status tpdaemon.service
● tpdaemon.service - Turboprint Monitor Daemon
Loaded: loaded (/etc/systemd/system/tpdaemon.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2023-01-28 07:37:32 CET; 6h ago
Process: 1075 ExecStart=/usr/lib/turboprint/tpdaemon start (code=exited, status=0/SUCCESS)
Main PID: 1168 (tprintdaemon)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/tpdaemon.service
└─ 1168 usr/bin/tprintdaemon 0

Gruß Gindi

Das ist so nicht richtig. Installiert war der Kernel aus Leap 15.4, die anderen waren nur irgendwo gespeichert.

Ne, auch installiert.
Und diese haben etwas andere Abhängigkeiten als neuere Kernel und haben somit das Update blockiert:

Als Konfliktlösung wird angeboten:
1: Deinstallation von util-linux-2.36.2-150300.4.28.1.x86_64
Deinstallation von util-linux-lang-2.36.2-150300.4.28.1.noarch
sowie deinstallation von weiteren 224 Paketen
ODER:
2: Deinstallation von kernel-default-5.3.18-lp152.75.1.x86_64
sowie deinstallation von weiteren 188 kernel einträgen.

Lösung 2 ist ein installierter Kernel aus Leap 15.2…
Denn bei eineim Upgrade von einer Leap Version zur anderen werden die installierten Kernel nicht gelöscht.

Das nur nebenbei und zur Erklärung…

Hast du mal den Drucker in turboprint gelöscht und neu eingerichtet?

Das hast du nicht beantwortet.

Danke für die Erklärung.

Ich habe den Drucker in Yast gelöscht und neu installiert und in Turboprint habe ich den Drucker auch gelöscht und neu installiert.
Hat beides nichts gebracht.
Ich konnte bei Yast und bei Turboprint in der Toolbox eine Testseite ausdrucken aber aus keiner Anwendung etwas drucken.

Gruß Gindi

Ich habe mal als root “journalctl -b | grep kernel” eingegeben und am Ende der langen Liste stand:
kernel: usb 3-2: USB disconnect, device number 3
kernel: usblp0: removed
kernel: usblp1: removed

Kann mir jemand einen Tip geben wie und wo ich das wieder rückgängig machen kann?

Gruß Gindi

Gem. SDB:Einen Drucker installieren - USB-Drucker bin ich wie folgt vorgegangen:

Wenn der Drucker an die USB-Schnittstelle angeschlossen und es der einzige Drucker an der USB-Schnittstelle ist, laden Sie das Kernel-Modul für den direkten USB-Druckerzugang (als Root) nach:
rmmod usblp
modprobe usblp

Sie können prüfen, ob der Drucker über die erste parallele Schnittstelle erreichbar ist /dev/lp0 durch Verwendung des folgenden Kommandos als Root:
echo -en “\rHello\r\f” >/dev/lp0

Bei /dev/lp0 steht Hello drin.
In /dev/usb ist lp0 eingetragen
in /proc/modules ist usblp vorhanden.

Testseiten funktionieren aber kein drucken aus Anwendungen, Fehlermeldung wie oben angezeigt.

Gruß Gindi

Ich habe jetzt in Yast - Drucker alles gelöscht und ebenso bei Turboprint Control den Drucker gelöscht.
Dann habe ich den PC runter gefahren und neu gestartet.
Danach habe ich rmmod usblp und modprobe usblp durchgeführt.
In Yast habe ich die automatische Druckererkennung durchgeführt.
Turboprint Control hat schon den Drucker aus Yast angezeigt.
Ich habe die Konfiguration angepasst und gespeichert.

Aus Writer konnte ich jetzt ein Dokument ausdrucken. Der Drucker druckt wieder.

Danke für Eure Unterstützung.

Gruß Gindi

Leider habe ich mich zu früh gefreut. Als ich heute etwas ausdrucken wollte, kam wieder die Meldung
Der Drucker konnte nicht gestartet werden.
Bitte überprüfen Sie Ihre Druckerkonfiguration.
Ich mußte in der Druckereinstellung vom Libre Office Writer bei “Eigenschaften - Gerät” den Druckertreiber von Automatisch: PDF in Ghostscript (Level des Treibers) ändern.

Immer wenn ich ein Dokument lade und ausdrucken will geht es nicht, weil der Druckertreiber wieder auf “Automatisch: PDF” steht und ich ihn ändern muß.

In Yast und bei Turboprint war ein Drucker “CUPS - PDF” eingerichtet, den ich aber zusammen mit dem Canon Drucker gelöscht habe. Jetzt ist nur noch der Canon Drucker installiert.
Wie kann ich erreichen, daß der Treiber “Automatisch- PDF” nicht mehr geladen wird?

Kann mir da jemand einen Weg aufzeigen?

Gruß Gindi

Hast du denn schon deine LibreOffice Einstellungen gecheckt und anstatt “In Datei Drucken”, “Drucker” als Standard ausgewählt?
Extras → Optionen → Benutzerdaten → Drucken

Ja, Drucker ist als Standart ausgewählt. Dabei habe ich aber gesehen, daß bei den Standards PDF als Standartdruckformat ausgewählt war. Ich habe den Haken in der Checkbox entfernt und hoffe, daß die Druckerei jetzt funktioniert.
Danke für den Hinweis.

Gruß Gindi