LEAP 15.4 Installation hangs at very early stage

Attempts to install Leap 15.4 on two different machines have hung at a very early stage - the 3 progress bars for “loading basic drivers” have reached the right hand side but the process does not proceed to the next stage. The machines involved are a new Acer with Intel Core i5 and Iris Xe graphics and a slightly older HP also with Intel Core i5 but with Intel UHD graphics - both currently have Windows 11 installed on them. I am using a USB flash drive for the installation - I have successfully used this same drive before, the iso has been verified with YaST Media Check and I have also just checked the drive again by starting an installation on a DELL AMD RYZEN5/RADEON machine which actually already has 15.4 (and Windows 10) on it - it proceeds without any problem beyond the point where the other two attempts have hung. Is it likely that there is something in the hardware of the Acer and the HP preventing the installation? Unfortunately, I have not seen any error messages when the installation hangs, so have no idea where to look for the problem. Any suggestions gratefully received.

You can try adding “nomodeset” to the kernel boot line.

If this is UEFI, then hit ‘e’ at the grub menu selection for install, and scroll down until you file a line that starts with “linux” or “linuxefi”. Then append " nomodeset" to the end of that line and hit CTRL-X to continue booting.

If this is not UEFI, then there is a place to enter kernel parameters on the boot screen.

This may result in inferior graphics, but it should get you booted into the installer. You can work on fixing the graphics later.

Thanks for the suggestion, for which I had high hopes. However, it didn’t change anything and the installation still hangs, apparently at or very near the end of “loading basic drivers”.

Try instead of or in addition to nomodeset appending plymouth=0 and/or intel_iommu=off. Disabling plymouth this way should put boot messages onscreen where you can see what last happens before the hang. You can read about iommu on https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt and in various support threads and bug reports.

I tried with “nomodeset plymouth=0 intel_iommu=off” and, while it initially seemed to be behaving as before, this time I waited much longer and after more than an hour it went from
“Loading basic drivers…” to “Loading basic drivers… ok”
The following steps in the installation setup shown on the text window were also incredibly slow but eventually, after almost 2 hours, I reached the normal graphical set up, which seemed fine.
I didn’t proceed to actual installation for now, as I have some outstanding backup of Windows to do but instead tried another installation setup with just “plymouth=0”. This behaved exactly as above, so the problem appears to be that the initial setup is painfully slow - something I have never experienced before in many years of installing Linux on laptops