Leap 15.4 - Firefox brakes keyboard switcher

I’ve upgraded to Leap 15.4 from 15.3. I am using KDE environment and 6 virtual screens. After on every screen where I have opened Firefox keyboard switching indicator disappear from toolbar. Keyboard switching capability is also broken. If I switch to screen where there is no Firefox running, keyboard indicator appears and fully functional. If I kill Firefox - switching indicator reappears and fully functional on all virtual screens. If I run Firefox again - switching indicator disappears immediately again. I am using OpenSuSE since 42.X and never had observed such issue till now.

Thanks to all, who can try to help me and fix that globally!

Kind regards and best wishes,

Do you mean a Widget in the Plasma System Tray? – <https://docs.kde.org/stable5/en/plasma-desktop/plasma-desktop/panel.html#panel-system-tray>

  • And, do you mean the Keyboard Layout Widget?

Have you checked the Plasma System Tray settings?

Yes, I have in mind both widget and related with it switching functionality. i didn’t checked these settings, because it was worked fine, once configured without any failures since OpenSuSE 42.0 till 15.3.

P.S. Don’t know whether Firefox is the issue or Plasma, but the fact is that it fails only at screens on which Firefox is present. if i start Firefox Window on screen with normally appearing widget it disappears immediatelly, and if i close the Firefox window, it appears immediatelly.

Update - for testing purposes i downgraded Firefox to version 92.X instead of current 106.X. With 92 keyboard applet working as expected. Returned to 106 and temporary removed profile and initialized it “on clear” and the problem exists. Something is totally fucked up with version 100+ :(((((

Where did you pull that Firefox version?

  • The version I’m running on Leap 15.4 is the standard version “102.6.0esr” …

My bad. It is 102.6 :slight_smile:

After so many time no answer, I’ve switched back to 15.3, where all works just fine. Most probably will not trust recent releases anymore…