LEAP 15.3, RTX graphic card problems

Hi, The whole system is running properly with video output from the motherboard. Yet for challenging games on a 4k monitor a graphical card is inavoidable. I decided for Asus RTX 2070, because my motherboard is from Asus too (progaming Z170) and I hoped this will work together fine. - No, it won’t. The card had some power supply problems, it was repaired and the service advised a better power supply. I choose Seasonic GX 850.

Still I cannot start X-Windows. The following message: “sddm: Failed to read display number from pipe, Display server failed to start” appears in /var/log/messages. In this hw-configuration I even cannot install a new system with a USB-stick using the video output from this card. At certain stage the system falls asleap.

I don’t know if it is still some hardware problem, or a software incompatibility.
Could somebody give me a piece of advice, please ?

Hi
At grub, press the ‘e’ key to edit and at the end of the line beginning linuxefi likely after quiet add nomodeset and press the F10 key to boot, graphics won’t be very good but should get to a GUI to further troubleshoot.

It won’t help. sorry

This card was in service, they tested it with Window and with two linux systems: Mint and another one. It works fine in service.
But, what makes me wonder: I can hardly start a new installation from a USB-stick. The graphical part beaks down. Where could i search for reason ?

The YaST installer can be made to use lower resolution modes instead of 4k (3840x2160). Try instead of modeset, appending XVideo=2560x1440 or XVideo 1920x1080 to the end of the linu line after striking the E key at the startup menu. Also or instead, try appending plymouth=0. These and other installation startup options can be found here.

It did not help.
But I found a log message about unsigned nvidia module:

nvidia: module verification failed: signature and/or required key missing - tained kernel

Could this be the cause ?

What was the previous card you were using before the replacement of the new card

Do you have secure boot enabled in your uefi bios? Then you maybe missed the mok enroll screen after rebooting. On my board it will stay there only for 10 seconds after reboot. So you have to be quick.
You can enroll the mok key for your Nvidia card afterwards without any problem:

Change the MOK-nvidia-…-default.der according to your Nvidia driver version:

sudo mokutil --import /var/lib/nvidia-pubkeys/MOK-nvidia-gfxG05-460.80-lp152.38.1-default.der

Then reboot and enroll the MOK key.

Further information: https://en.opensuse.org/SDB:NVIDIA_drivers#Secureboot

No, it won’t help:

  1. I have no /var/lib/nvidia-pubkeys/ directory in my system . Also no nvidia-pubkeys elsewhere
  2. I disabled mok with #mokutil --disable-validation and changed the state - XServer is still not starting with the same error message