Leap 15.3 ISO to USB Legacy

I could not find the way to write ISO image to USB with Legacy (MBR) that is not with EFI. Will it work if I delete the efi partition from the USB?



The ISO has both, legacy and UEFI.

The Installation decides on the Modus, if usind Legacy or UEFI.
On Legacy, you will see on the first desktop the F-keys in the lower Row, on UEFI you have to hit the e-key.

I am trying to write the image to the USB with MBR.


Use imagewriter or in terminal:


You can use this one to write it on USB:

I am sorry that I have not stated my problem in sufficient detail. Let me try again:

I have a PC with two SSDs one for Windows 10 and the other for Linux (Leap 15.2 at present). Both are Legacy (MBR) not EFI. So I have to instal Leap 15.3 in addition to existing Leap 15.2 in legacy mode. However when I write to downloaded file as ISO image to USB pen drive the drive is formatted for EFI. Though I have set up BIOS options to boot either EFI or Legacy, on pressing F12 the pen drive does not show up in boot options. I have tried all the options available (except setting up to boot from EFI only) but the pen drive just does not show up. I do not wish to mess up the existing installed systems.

I am hoping to write the ISO image to pendrive with Legacy MBR. Can it be done?


There is no “drive formatted to EFI”.

You can only “writre” an ISO with some special programms.

What not is working is copying the files.

You may find this web page useful as it has some background info too:


To make it more accessible: https://linoxide.com/create-bootable-usb-from-iso-using-linux-terminal/

The installer will use MBR or EFI to install depending on how it is booted. Boot installer in legacy mode and it installs the OS in legacy (MBR)

That is what I understand, But I have been unable to write to USB in Legacy mode!

I have still to try the “dd” method pointed out by JulianB and hcvv.

By the way when I first downloaded the file name ended with x86_64. When my first attempt failed I thought that I had made some mistake so I downloaded again. The new filename ends with x86_63-Current.
Is something wrong or there are two different files?



All the time we try to tell you that there isn’t something like “writing in Legacy mode”.
It is simlpy written, byte by byte from the file to the device.

That makes me thinking you may not even have the correct file at all.

Mostly files that are colloquial called “ISOs” have a name ending in .iso.

So please be more specific on what you downloaded from where.


BTW, I get the strong idea that you do not understand what (most) people mean when they talk loosely about “an ISO”. Do you know what it is and why it is called like that?

There is no way to “write to USB in Legacy mode”!

There are two mature components involved in the boot process of a PC

  1. the BIOS, on modern machines called UEFI
    a piece of firmware that decides how the boot process operates
  2. the media to boot from
    e.g. HDD, SSD, NVMe, DVD, USB, …

The UEFIs i know can handle two boot methods

  1. Compatibility Support Mode (CSM) also known as MBR- or BIOS-mode.
  2. UEFI-mode

Which boot mode an UEFI uses can be selected by the user in the UEFI setup menu.

The media to boot from (HDD, SSD, …) must be prepared for the selected boot mode. However the openSUSE installation or LIVE medias are prepared to handle both boot modes (CSM and UEFI).

No matter which boot mode (CSM-mode or UEFI-mode) you use the openSUSE media will boot. The only thing you have to be aware of is: If you boot the openSUSE installation media and do an installation the installed system will be setup for the same boot mode in which the installation media was booted. so

  • if you boot up the installation media in CSM mode your installed system will be setup to be bootable in CSM mode.
  • if you boot up the installation media in UEFI mode your installed system will be setup to be bootable in UEFI mode.

Nevertheless it is always possible to change the boot mode of an installed system.



When you write the ISO image to a pen drive, you do get Legacy MBR formatting. But there is also an EFI partition, so that the USB can be used either way. It is normally up to the BIOS interface to decide how to boot the USB (legacy or EFI).

You can tell which way you booted, by looking at the boot screen. With legacy booting, the installer boot screen has notations for various Fn keys along the bottom of the screen (it uses “syslinux” for booting). With EFI booting, you see a grub boot menu and no Fn notations along the bottom.

Note: in the past, the command “isohybrid” (run against the iso) would convert the iso to legacy only. I have not tried that recently, so I don’t know if that still works or whether it will break something (i.e. ruin the iso).

I wrote file name not the extension. The extension is .iso, OK. Please read …x86_64.iso and … x86_64-Current.iso. I am quite confident that I got the correct file the second time at least as I double checked it. The only possibility for difference, other than a new image being uploaded, is that OpenSuse site took me to a different mirror. But that should be impossible!

I will try the dd method tomorrow with a fresh mind. :slight_smile:



Thanks. One learns as one goes along. It is when one makes mistakes and runs into problems that the lessons are better absorbed! :slight_smile:


OK. But in Linux there isn’t such a thing as a (file name) extension (in the meaning that it has in MS-DOS). And it is always the best of course to post things complete to avoid confusion. I see no reason why you said " the file name ended with x86_64." and not simply posted the file name. Just copy/paste, very easy, no confusion on what the name is, nor about what the end of the name is.

Hmmm, …

In your post #5 you said that openSUSE Leap 15.2 is currently installed on your PC. I cannot remember any fundamental changes in the way the openSUSE installation medias work since years ???



Hi PrakashC,

While wondering if 15.3 really needs to be installed next to 15.2 rather than doing an upgrade, did you ever consider this page?
The basics didn’t change with 15.2 (or 15.3). (BTW, I always ever used imagewriter and never uefi boot.)

That is because I prefer to keep a working system available in case anything goes wrong! The early users installing Leap 15.3 did face problems. As you may have made out from my posts, I am not an expert with well any operating system or software for that matter. More of a lay user!

And regarding this thread, I may be barking up a wrong tree :embarrassed:. Very recently I had to change the motherboard, the refurbished one being Gigabyte GA-H61M-S1 (rev. 2.1). Everything else is working fine. Checked their site and found in FAQ only the suggestion to upgrade the BIOS to latest version. I doubt if it even referred to the model I have, but I started checking the BIOS versions for this board. I found that the version actually loaded (FC) was not listed at all for the model. Ver. FC is for Gigabyte GA-H61M-S1 (rev. 2.2)! So I think that the problem is due to wrong BIOS version. Will be upgrading the BIOS today and hope things work out.

BTW has anyone an idea or info re file names I mentioned in earlier posts.


Possibly will work too.

Provide full info, here - full names.