Leap 15.3 alpha

I decided that as I have a laptop which is not being used at present and is unlikely to be used for some months that I would play with Leap 15.3 Alpha. Now I full realise that this is likely to be flaky at best but I am puzzled as to where I report any errors I find or at least see if they are known? All I can see right now are two bugs in bugzilla. Is there anywhere on the forum this can be discussed? Right now I’m seeing several packages failing integrity checks mainly relating to oxygen or okteka while doing an upgrade from 15.2 (fully updated).


Hello and welcome.

I assume others, who have more feeling with the development side of openSUSE will tune in and show you the mailing lists, etc. where those people lure.

All I can say is that it is unlikely that “doing an upgrade to 15.3” is one of the first points that is going to be checked for problems in the development cycle. Thus you may be a bit premature in trying this out.

I realise this was an experiment but it was one which worked, the update completed OK apart from the issue with integrity checks failing because of a missing signature. As I said this laptop is not being used so if it crashes or neds a complete re-install it is not an issue. I just felt it was worth a go. I have subsequently update the install for all the latest fixes and that went OK as well and I have not (yet) found any issues with stuff not working but it’s early days.


Just a note about Leap 15.3 Alpha:

The repos are broken.

I installed from the DVD installer. It is working pretty well. But when I try:

zypper dup -D

it wants to downgrade 1550 packages. The repos are not in sync with the DVD installer. The repos are older than what is on the DVD.

I’m hoping that will be corrected with the next release. It is a limitation for now.

I did notice something strange when I went into YAST to add a package that many packages showed a new but downlevel update. I had not tried that zypper command so I’ll make sure for now I dont do that!

So far all programs I’ve tried have worked but there is still a lot to try out.


Same here, I installed 15.3 Plasma on a spare desktop (using the ISO as a clean install). At this stage it is more of an uptodate 15.2. All the programmes that I tried worked fine with the exception of Clementine which gave a segmentation error. All the packman rpm’s for 15.2 installed fine.

Because of the “-D” it is actually safe. It only does a dry run, and reports what would happen without that “-D”.

So far all programs I’ve tried have worked but there is still a lot to try out.

Yes, everything has worked here, too.

To test installer fresh installation is needed.

How users can add theirs suggestions for next Leap?