Leap 15.2 will not install on my new laptop


Received my new blank Ryzen 7 4800 (with Radeon graphics), Nvidia Geforce GTX graphics, 16 Gb. memory laptop.
Started the 15.2 install. Where the screen (only) says :

Starting yast…
Starting Installer
> pci.2: get sysfs pci data_

the install stops.
Tried both the net install en the DVD install : same result.
Tried to install MX-linux. It offers a choice of graphics to install. When you choose Radeon the install will complete OK.
When you choose Geforce the system will crash.
Tried a system rescue CD, crashes too reporting serious problems with the Xserver.
Can vagely remember a similar issue in the V10 era, where you had to enter a command during boot.

Any advice on how to proceed ?

Try to boot with the “nomodeset” option, you are likely experiencing graphics problems. Maybe that way you can complete the install, even if with reduced graphics performance.

Go to the “Install” line in the Grub menu
Press “E” to edit the boot line
add “nomodeset” (without quotes) to the line beginning with “linuxefi”
press F10 to boot.

After install and a first reboot you may be able to change or complete the graphics configuration and that might depend on the way the Nvidia GPU is seen by the system.
If you have an option on the firmware (BIOS) to disable the Nvidia chip and only use the integrated Vega, check that too as an alternative.

Hi, tried to add “nomodeset”,
During boot it returns :
error : can’t find command ‘nomodeset’
and ends up in the same situation reported above.

The bios has no option to disable the GPU.

The linuxefi line should read like:

linuxefi /boot/x86_64/loader/linux nomodeset splash=silent

I guess you added “nomodeset” just after “linuxefi”?

Found a better description of the use of the “nomodeset” parameter at :
This apparently works, I now can install. Thanks.

Update : Found some more help on this issue :


Followed these instructions and the system now works flawless (with Nvidia graphics).