Leap 15.2 macbook camera

Multimedia controller [0480]: Broadcom Inc. and subsidiaries 720p FaceTime HD Camera ]
Subsystem: Broadcom Inc. and subsidiaries 720p FaceTime HD Camera

Where can I get the driver? I’ve looked.

Macbook model a1502

Hi
You need to extract the isight.fw firmware from macOS (or get the AppleUSBVideoSupport file) and install in /lib/firmware


zypper in isight-firmware-tools

"Hi

You need to extract the isight.fw firmware from macOS (or get the AppleUSBVideoSupport file) and install in /lib/firmware

:     zypper in isight-firmware-tools

"


Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
  isight-firmware-tools libusb-0_1-4

2 new packages to install.
Overall download size: 59.5 KiB. Already cached: 0 B. After the operation,
additional 126.3 KiB will be used.
**Continue? [y/n/v/...? shows all options] (y): **y
Retrieving package libusb-0_1-4-0.1.13-lp152.3.5.x86_64
                                           (1/2),  32.8 KiB ( 68.1 KiB unpacked)
Retrieving: libusb-0_1-4-0.1.13-lp152.3.5.x86_64.rpm .....................[done]
Retrieving package isight-firmware-tools-1.6-lp152.3.5.x86_64
                                           (2/2),  26.8 KiB ( 58.1 KiB unpacked)
Retrieving: isight-firmware-tools-1.6-lp152.3.5.x86_64.rpm ...............[done]

Checking for file conflicts: .............................................[done]
(1/2) Installing: libusb-0_1-4-0.1.13-lp152.3.5.x86_64 ...................[done]
(2/2) Installing: isight-firmware-tools-1.6-lp152.3.5.x86_64 .............[done]
steve@localhost:~> 

Camera still doesn’t work.

Hi
You have to extract the firmware and copy it, see here for instruction on Ub* MactelSupportTeam/AppleiSight - Community Help Wiki I did it ages ago for my MacBook 2007, just made sure I kept a backup of the file to use in later installs.

I am noob, are there code equivalents from ubuntu to opensuse for example the zypper function is different for different distros, are the Ubuntu instructions similar enough or what are the idiosyncrasies?

Hi
Have you located the download for AppleUSBVideoSupport for your system? If so download and then use the tool you installed with zypper to extract.

Then switch to root user (your path to the download);


ift-extract -a /stuff/repositories/apple_firmware/AppleUSBVideoSupport 
** Message: 16:50:44.934: Found firmware signature at offset 0x29A8.
** Message: 16:50:44.934: Firmware extracted successfully in /lib/firmware/isight.fw
** Message: 16:50:44.934: Firmware version 2.38.83 (0x02.0x26.0x53)
** Message: 16:50:44.934: Apply patch 0 : Fix device descriptor
** Message: 16:50:44.934: Apply patch 1 : Fix interface assocation descriptor
** Message: 16:50:44.934: Apply patch 2 : Fix video interface collection
** Message: 16:50:44.934: Apply patch 3 : Fix video streaming device qualifier
** Message: 16:50:44.934: Apply patch 4 : Fix video control interface descriptor
** Message: 16:50:44.934: Apply patch 5 : Fix video streaming interface descriptor
** Message: 16:50:44.934: Firmware patched successfully

Like I said, then copy the isight.fw file to a location for backup…

I’m not sure what the instructions mean by the Mac OS that I’m running… I’m running leap 15.2, not a Mac Os so I don’t know what ‘for my system’. I found MacBook iSight Webcam Linux : Apple : Free Download, Borrow, and Streaming : Internet Archive and downloaded that.

Is that what I’m supposed to extract?

Picking up on the Mactelsupport page/ link that you sent regarding the process on Ubuntu…


steve@localhost:~> sudo zypper install isight-firmware-tools 
[sudo] password for root:  
Loading repository data... 
Reading installed packages... 
'isight-firmware-tools' is already installed. 
No update candidate for 'isight-firmware-tools-1.6-lp152.3.5.x86_64'. The highest available version is already installed. 
Resolving package dependencies... 
Nothing to do. 
steve@localhost:~> ls /lib/firmware/isight.fw 
ls: cannot access '/lib/firmware/isight.fw': No such file or directory 
steve@localhost:~> 

Hi
You need to find the file AppleUSBVideoSupport for your MacBook model, if you have osX installed as a dual boot from there, or from apple support downloads.

Then on linux you run the command I indicated as root user (which is what I run too, just have the file already).

Yeah I don’t know where to find the file, Apple downloads doesn’t seem to have anything and I don’t have OSX installed anymore.

I just ordered a usb webcam.

Your MacBook model A1502 isn’t a regular one but a Pro (either a Late 2013, Mid 2014 or Early 2015). Either of these models can run Mac OS X from 10.9 to the latest version as of today.

Download any Mac OS X of the above version range, mount the “InstallESD.dmg” file, grab the following driver and make a backup of it (on an USB key, network share, whatever):

/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport

Once you got that driver, follow malcolmlewis’s instructions.

PS. downloading Mac OS X installers from another systems is tricky. PM me if you need this driver and don’t want to download a ~5GB installer.