Leap 15.2 Locking Up During Shutdown & Startup / Kernel Change

Hi everyone - hope this is in the correct section of the forum.

I’m pretty new to Linux & even newer to openSuse. Am trying to move away from Windows and am triple booting with Leap 15.2 and Mint 20. I very much like Leap, but it seems to be fighting me every step of the way along my learning curve.

To come straight to my question - how do I download and then install specific kernel versions into Leap 15.2. I would like to use either kernel versions 5.1 or 5.4

Bit of a story as to why I want to do this, so I’ll try to explain.

My Linux journey started with Mint 19.3 and Leap 15.1 - both using kernel 4.12. When using either OS, I had the same issue with the PC hanging up either going into sleep and/or coming out of it and needing to be reset. I switched to kernel 5.1 on both Mint and Leap and the problems were solved - both OS’s working perfectly. Here is where I should’ve stopped . . . LOL

When Mint 20 and Leap 15.2 came out, I decided to be brave with my learning curve, start fresh and install them. Mint is working fine on kernel 5.4, but my old sleep hanging up problems are back with Leap 15.2 on kernel 5.3.18

I found a tutorial showing how to upgrade Leap 15.2 to the latest kernel which is 5.8 I think. Followed this and it worked and did seem to cure the sleep hang up problems - BUT it borked Firefox which wouldn’t run and just crash - even with a remove and re-install. Tried Chromium instead - same result with no internet connection through a browser. The system did updates, so PC does connect to web.

I’m now back to a fresh install of Leap 15.2 with kernel 5.3 and a PC that hangs up at sleep & has to be rest every time.

So based on my limited experience with Mint, I’m guessing that with my particular system, the kernel that works in Mint “should” work in Leap - but I have no idea where to get specific kernels from, then download, install and try them.

With many thanks


I don’t know where you can find a 5.4 kernel, except by compiling your own.

My suggestion: Add the stable-kernels repo


and try installing a kernel from there. It might be a 5.8 kernel. Usually that repo has very recent kernels that are built for openSUSE.

When I last tried kernel 5.8 and 5.7, it corrupted Firefox somehow and uninstall/reinstall didn’t cure it I’m sorry to say. Same happened when I tried Chromium

I have downloaded a tarball of kernel 5.4 from www.kernel.org, but don’t know where to start when it comes to compiling and then installing it. Too much for a Linux newbie perhaps - but am keen to learn . . .

I’ll post this as an update in case it’s of help to someone in the future perhaps . . .

Still having problems with the PC locking up when going into or out of sleep mode. I installed Tumbleweed instead as at this moment, it’s using kernel 5.7. Given my earlier theory with kernels thought it worth a try.

Installed it and had no lock up problems.

Started setting up in my usual way, but only made a few changes so I could easily backtrack if necessary . . . . and it was. The lock ups started happening again. The problem appears to have been caused by me modifying GRUB to prevent it counting down and booting into an OS I didn’t want to use. I’m triple booting and prefer to not have the countdown.
Using YaST Bootloader, I have been changing the countdown timer from 8 secs to -1 to prevent the time out. When I did this, the locks ups started again. However, putting the setting back to 8 secs didn’t cure the problem.

Decided to start over once again and not modify anything as this worked last time & keep it that way. Realise now that the bootloader can be set up during install, so I set the timer to -1 and let the install continue.

So far, so good. The countdown is disabled all seems OK - tho’ I’m no doubt tempting fate here big style . . .

I’m a Linux novice and this may not make any sense at all to those with far more experience. I don’t understand why that’s for sure, but I’ll take it!


I think you have shown that the kernel is not the problem.

I very much doubt that grub is the problem.

If you see the problem again, can you try (as root)

mkinitrd -A

and see if that helps. It creates a larger “initrd”. I think the installer does that for the first “initrd”. Maybe there’s a module that you actually need, but which isn’t being picked up in the “initrd”.

I’m not sure whether this is the problem. But it is worth a try.

Thank you for the info & explanation. I never knew what a ramdisk was until reading the above. It does make sense and I agree with your comments. Should the problem come back, I’ll be sure to try out your suggestion.

The PC is still behaving itself at the moment - in fact, going into & out of sleep is real fast - so I will stick with Tumbleweed. I have read in several places that Leap 15.2 would be more suitable for a novice like me, but on the surface, I can’t see any real difference between the two.
Would I be better off with Leap, or stick with Tumbleweed?