leap 15.2 doesnt boot after update and grub shows only 15.2

on my btuxedo infinity pro with tri boot system (15.1, 15.2, windows10) I updated 15.2 and at reboot (with new kernel) grub shows only leap 15.2 issue, not 15.1 not windows, after boot a grey screen with three dots appeared everything failed and emergency mode is requested.
during the gray screen I pressed esc and appeared this:
then after some time this was the screen:
sorry for the orientation but I didn’t succeed to rotate it.
noe I can boot only in windows, how can I solve or have at least leap 15.1 at the boot?
manythanks :slight_smile:

It booted. So “doesnt boot” is wrong.

But it booted to emergency mode. So something is messed up on your system.

Is this machine using UEFI booting or BIOS/MBR booting?

you are right, it uses uefi
the strange thing I see is that in grub there is only leap 15.2 not the others

Maybe you have a wrong resume command in your grub boot line?

For some reason 15.2 is not seeing the other OS’s Odd it does not 15.1 unless the other OS’s are using a different boot method (ie MBR)

In Yast got to boot loader be sue that scan for foreign OS box is checked. Touch something (ie change it change it back) then continue to force reinstall of grub. If still a problem you will have to see why the other OS’s can not be seen.

Is the package os-prober (properly) installed?

The only reason for emergency mode I am aware of is failure to mount non-optional (nofail) filesystem on boot.

goodmorninn to all, I can only boot in emergency mode so I cannot launch yast, I’m sure that the for foreign OS box was checked before the disaster, the 15.1 use efi boot method too, I don’t know about windows but it is windows 10 and a quite new laptop so I suppose it uses uefi

supposing tha part of the problem was grub and taking a cue from this thread
I reistalled grub following this procedure:
bootet with leap 15.2 live usb stick
open konsole and run su -
then this code

mount /dev/sda9 /mntmount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt
mount -a
grub2-mkconfig -o /boot/grub2/grub.cfg

it worked only for the part that now I can boot in leap 15.1 and windows from grub menu, but if I boot leap 15.2 it fails as before.

FYI you can run yast from command line. As root just type yast

It seems not, in emergency mode after introducing root password yast does’t works
I trtied to save /run/initramfs/rdsosreport.txt but didn’t succeed, where I’m wronging?

…sorry to see that nobody has a solution, this seems that I have to reinstall 15.2 :’(:’(

We don’t fully understand the problem, and that makes it harder to suggest a solution.

Are you installed on BTRFS (it’s the default)?
If you are, then you should be able to simply launch snapper and roll back to a snapshot before your problem update.
Problem solved.
Then, don’t forget to update again immediately which should be successful.

The second screenshot in your original post suggests that your system errors trying to load Plymouth which is approximately when the system loads the advanced video driver.

What GPU do you have, nVidia, AMD, Intel or something else?
If you’ve installed a proprietary driver, can you uninstall it and return to the open source driver?

If you are unable to fix this problem and about to re-install,
I’d recommend one other try first… Do a DVD “upgrade”
With any luck, whatever is the problem is would be over-written by the re-installation.
If that is successful, you should then be able to update again and should be successful.

As always, it’s highly recommended to make a backup before you make changes.
And, if you have any questions in your mind, better to post here first to clear up anything.


Hi, manythanks lol!

no, I’m in ext4

I have Intel and I suppose the driver is the one in the kernel
processor=Intel Core i7-8565U, RAM=32Gb, graphics card Model: Intel UHD Graphics 620 (Whiskey Lake)

ok, I’lltry first this

always a good remind

…maaaanythanks, upgrade workedrotfl! now I’m updating…