Leap 15.1 will not install successfully on a Gigabyte B365M-H mobo

This is a new PC, with no previous OS. The processor is an Intel 9400 2.9 ghx core i5.

The Leap 15.1 DVD installer fails spasmodically. Sometime it freezes, with a couple of dying mouse twitches. Sometimes it comes up with a red error notice, the options following this become bogged down and everything stops.

If it gets to the end and something has been installed, either it will fail before reaching the login, or it will declare the password invalid. On the command line I can do a root login with that password, but do not know what to try or to look for. ls shows: .bash_history, .cache, .gnupg, bin, inst-sys
cd … takes me to /, where there are what looks like the full set of directories.

When the installed Leap fails before the login, a number of lines are shown, such as:

ACPI BIOS Error (bug) Failure looking up [_\SB.PCIO.SAT0.PRT3._GTF.DSSP], AE_NOT_FOUND

[LEFT](20170303/PSARGS-330) \_SB.PCIO.SAT0.PRT3._GTF
 2.001111] ACPI Error: Method parse/execution failed AE_NOT_FOUND (20170303/PSARGS-516)

Welcome to openSUSE Leap 15.1 – Kernel 4.12.14-lp151.27-default (tty1)

linux-0rc6 login:

(I log in)

Login: write-lastlog failed: no space left on device

I have updated the BIOS to F4A, and tried a number of mods, disabling Fast Boot, disabling and enabling CSM, and disabling the Network Stack.

I found a post that suggested to me that disabling IOAPIC 24-119 Entries might work, but it didn’t.
Another post suggested that Tumbleweed might install, but it failed while trying, unsuccessfully, to find my WiFi. The Leap installer can find my WiFi, but the modem light never registers a connection.

I also tried installing Netrunner, which rapidly failed with pages of reports like:

 106.002720] pcieport 0000:00:1c.7: PCIe Bus Error: severity=Corrected. type=Physical Layer, (Receiver ID)

[LEFT] 106.002720] pcieport 0000:00:1c.7: device [8006:a297] error status/mask=0000000100002000[/LEFT]
 106.002720] pcieport 0000:00:1c.7:  0] RxErr (First)


Where do I go from here?

  1. Check openSUSE’s ISO image.
  2. Do you have Nvidia videocard? Tell more about your hardware.

I checked the Leap ISO and it was as it should be. The hardware is plain on-board, no separate video card or sound card, Samsung 860QVO 1 tb solid state drive, DVD-RW, TP-Link Wireless Adaptor PCIe.

New Hardware - Before I try any OS install I run 3 passes of memtest86. It is available in UEFI and non-UEFI downloads.

Flaky memory is the number 1 reason for OS install failures.

You can get it from here:


I did a quick Internet search “Gigabyte B365M-H linux kernel support” and returned practically nothing.
IMO you will need to create a list of each component on the motherboard and do a similar “linux kernel support” Internet search to verify whether support is available through the kernel, and if not then look for user-mode drivers which may be available for that specific component.

If you do that, you should be able to determine how “Linux ready” your board and everything on it may work with least amount of work, and if anything special needs to be done.

If you produce that list and search but can’t come up with answers or may not understand related documentation or instructions, go ahead and post what you’ve found.

BTW - It’s a bit worrisome that Gigabyte is making available <very recent> MSWindows drivers for this board at the following URL which suggests that this board may be so new that drivers just won’t be available (MSWindows makes many drivers available on its own similar to what Linux does by way of its kernel). You may have to contact Gigaybte directly for what they can provide.


Try a Tumbleweed live image.

Initially, assuming the mobo was faulty, I took the computer back to the shop and they successfully loaded Win 10 on it, so I doubt if memory is the problem.

Incompatibility did not occur to me, I should have checked. Thanks.

His CPU is from 4th quarter 2018, and his Coffee Lake chipset older. Support for them should be complete in 15.1. I’d boot to cmdline only, login as root, and do zypper up to get the latest firmware and kernel. If that wouldn’t fly, I’d try a net install so that all the installed packages, and the installer, would be update versions. ISTR vaguely that there may be a newer installer available via NET installation than using the DVD iso.

I did two Leap 15.1 net (!) installs some days ago and after first boot I did a

zypper up

and got some 200 updates, no joke. No idea what this net install really does…

After the same mass of messages that the Netrunner installer generated, Tumbleweed came up in a simplified form. I managed to take off pci.ids, which is long, and may be of some use, and and a log file related to a fail that it encountered while booting. I’ll have to put that on my ‘broken’ PC to unpack it.
There was no Internet connection.
It looks like the live Tumbleweed can work round some of the problems. Although the Leap installer could find my WiFi to configure it, nothing seems to be able get a connection.

I just tried that, but as I suspected to no avail, as there is no internet connection. The installers can’t get one, though the Leap installer can ‘see’ my WiFi, even if it can’t use it.

Logging in as root from the prompt that comes up instead of the login window, there is a message:

login: write lastlog failed: No space left on device

which can’t be good.

zypper up responds with several iterations of:

Repository {repository name} is invalid {string} valid metadata not found at specified URL

I assume this is due to the lack of Internet connection.

Is there some way of configuring either Ethernet or WiFi (I have both) from the command line?

Given the time I have spent, first trying to get the old PC to work properly, and now trying to install on the old one, plus the time it would take me to check everything on the board, I am thinking it might be more cost-effective to replace the motherboard with one that is known to work with Leap. Any suggestions in the same cost bracket? I have found the Hardware Compatibility List, but I suspect it is a bit old.

At Amazon.de the board is offered sind AUG-2019, i.e. appears to be quite new. I would try to find someting offered since 2018. What I ususally do: buy some used Dell hardware (not from ebay, there usually are resellers for leasing-returns, about 2-3 years old), good quality (my oldest ist from 2003, one of the last Precisions I bought from Dell directly) and due to used status: good prices!

On installation kernel cmdline use ifcfg.

I was planning to try the net install, but having just set up my Vista era laptop with Manjaro XFCE I gave that a spin. It installed, and it ran! So I have got round the problem rather than fixing it, now running Manjaro KDE.

Did you also installed from the DVD or from a USB stick? Just curious.

Up to that point all my installation attempts were on DVD. I had the netinstall ready on a USB, but as I assumed the actual installer would be the same, and Manjaro actually worked, I took it no further.