Leap 15.1 - unable to make DHCPD work


I am unable to make ISC DHCPDv4 work on Leap 15.1. I am migrating from old hardware and Opensuse 13.1 to a new hardware and Leap 15.1 so after setting up 80% of new server, I reinstalled all because I was thinking there is some “catch” in kernel itself. So after fresh install, I tried to configure DHCP first but the problem stays. What happens is that if I shut down dhcpd on old machine and then start on new, It doesn’t give any IP addresses. Network is connected to eth0, ip address is with /24 mask. wicked output:
eth0 up
link: #2, state up, mtu 1500
type: ethernet, hwaddr 5c:f3:fc:28:43:b5
config: compat:suse:/etc/sysconfig/network/ifcfg-eth0
leases: ipv4 static granted
addr: ipv4 [static]
route: ipv4 default via proto boot
route: ipv4 via proto boot

dhcpd was configured using yast and it looks like this:
option domain-name “loc”;
option domain-name-servers;
option routers;
option ntp-servers;
default-lease-time 14400;
ldap-dhcp-server-cn “linuxmakina”;
ddns-update-style none;
subnet netmask {
default-lease-time 14400;
max-lease-time 172800;

I have also changed /etc/sysconfig/dhcpd to have only DHCPD_INTERFACE=“eth0” set.

As I can’t make it to work, I also stopped dhcpd on both servers and run:
tcpdump -vnes0 -i eth0 dst host
on one and another. Old linux shows packets while 15.1 does not. It looks like something filters out broadcast packets but I just can’t figure out what. Firewall is down (iptables -L all ACCEPT). I am out of ideas so any idea would be more than welcome.

Thanks and kind regards,

I have found solution to this “problem” :slight_smile: The installed switch in network is smart switch where in the configuration, one must define “server port”. Looks like it sends broadcast only to that port. So, always know (and check) your hardware before trying to fix “software errors”.