Leap 15.1 re-image install generates repository error messages that risk integrity of system

Greetings Forum,
I did the upgrade from Leap 42.3 to Leap 15.1. During the upgrade I received several error messages during the product installation step . The message is produced when the installation process is downloading rpm’s from the Leap software repository over the internet. Lots of broken packages when I got Leap 15.1 up and running.

I’ve decided to perform a complete Installation. I’m getting the same error messages during the installation process.

Message is as follows.

File changes by accident or attacker since repository creator signed it. Using it is a big risk for the integrity and security of your system.

The dialog asks me if I want to proceed. I respond NO.

Then another message pops up informing me the package is broken. It asks if I want to Ignore, Abort or Retry. I respond Ignore.

  1. Are these messages normal? As a novice I would think not. This is why I’m reaching out to this forum.
  2. During the re-image dialog I only selected the four base repositories for Leap. Nothing else. What causes this message to pop up?
  3. What is the response? Should I select YES to the first message above?

I had to respond to over 50 - 60 messages. Packages effected are… Perl, Python, Nano, Make, Plasma5, pcutils, netcfg, LibreOffice, Kernel, system, zipper, xkeyboard, OpenSuse Key, parted, sysuser, mutt-doc, vlc-lang, media-player, libKF5Codecs5, util-linux

This is just a few.

Has anyone run into this? Please post how you fixed it.

Have you just carried out this install? If so likely because of the mirror issues (See the Forum notice) and things running slow.

You could look at changing the repository URL’s to point at a mirror in your local based on the list here;
](http://mirrors.opensuse.org/)openSUSE Download Mirrors - Overview](http://mirrors.opensuse.org/)
However, if there are updates and the mirror is out of sync, could create additional issues…

The install was started last night. This is a second attempt. I gave up responding to the messages as they are many.

Two questions from your response.

  1. Can you provide a pointer on the “Mirror Issues”. I searched the forum and did not find anything. I’m happy to do the leg work just need to know what door to look behind.

  2. Does the USB installation dialog provide the ability to customize the URL location of one of these mirrors? From your link I see the list of Mirrors. The closest to my location is the URI mirror. I can restart the installation dialog but I don’t recall an option where you can edit or change it.

I’m physically connected in my house to a 100 mb ethernet. The line into my house is T1 speed.

Do I need to keep replying retry until it downloads the rpm correctly?

Have a look at the top of the thread and the main Forum page… a notice/dialog box :wink:
See https://lists.opensuse.org/heroes/2019-06/msg00067.html

You should be able to ‘add’ the mirror repositories as ‘additional’ ones which is an install time option, even if duplicate it should find the files, I would disable the non-oss ones for the moment and just get the main install done.

I suggest;



Any estimate on when this will be resolved? I really like OpenSuSE but I have a dead laptop at the moment and if this takes too long I will have to look at another distribution.

The USB installation dialog gives me the ability to specify which repositories I can include and exclude, but no way to change the URL to a specific mirror.

Presently dead in the H20… open to suggestions…

The USB is the full DVD, or is this a net install? If it’s the full dvd on USB, then just do an offline install (as in don’t add the repositories)…

The USB is the Leap 15.1 ISO image. Still ok to do an offline install?

Yes, should be fine :slight_smile:

As part of the ISO installation dialog, there is a MORE option. When you get there another option presents itself to validate the source media. In my case the ISO. I ran the validation against my ISO image and several checksum errors occurred. I think I will rebuild the iso and try an offline install again.

That should be fine.

However, when you try doing an update, after the install, you might run into repo problems. If that happens, just put off updating until the issue is fixed.