Leap 15.1 is trying to mount a partition from other os on boot

Recently reloaded 15.1 due to home directory corruption. Re-formatted home, re-loaded 15.1 with all updates.
System is an older laptop with Leap 15.1 and AV Linux (dual boot - Grub). Before the reload it worked perfectly, but now when I boot into Leap, the first thing that shows up on the desktop is an authorization dialog asking for the root password to mount /dev/sda6, which is the home directory for AVLinux. sda6 is not in Leap’s fstab. This happens whether I have Leap start a new empty session, or continue with the previous one. There’s not a lot of info in the system log, just this line out of the blue, it seems:

2019-09-23T10:27:10.495867-04:00 yukoncornelius dbus-daemon[1624]: [session uid=1000 pid=1624] Activating service name='org.kde.KScreen' requested by ':1.8' (uid=1000 pid=1707 comm="kded5 [kdeinit5]                                  ")
2019-09-23T10:27:10.616432-04:00 yukoncornelius kwin_x11[1744]: kf5.kcoreaddons.desktopparser: Property type "Url" is not a known QVariant type. Found while parsing property definition for "X-KWin-Video-Url" in "/usr/share/kservicetypes5/kwineffect.desktop"
2019-09-23T10:27:10.908546-04:00 yukoncornelius org.kde.powerdevil.discretegpuhelper: QDBusArgument: read from a write-only object
2019-09-23T10:27:10.909256-04:00 yukoncornelius org.kde.powerdevil.discretegpuhelper: message repeated 2 times:  QDBusArgument: read from a write-only object]
2019-09-23T10:27:10.924525-04:00 yukoncornelius dbus-daemon[1057]: [system] Successfully activated service 'org.kde.powerdevil.discretegpuhelper'
2019-09-23T10:27:10.928881-04:00 yukoncornelius dbus-daemon[1057]: [system] Activating service name='org.kde.powerdevil.backlighthelper' requested by ':1.30' (uid=1000 pid=1816 comm="/usr/lib64/libexec/org_kde_powerdevil -session 101") (using servicehelper)
2019-09-23T10:27:10.983027-04:00 yukoncornelius dbus-daemon[1624]: [session uid=1000 pid=1624] Successfully activated service 'org.kde.KScreen'
**2019-09-23T10:27:11.105115-04:00 yukoncornelius polkit-kde-authentication-agent-1[1751]: Message of action:  "Authentication is required to mount WDC WD5000LPLX-08ZNTT0 (/dev/sda6)"**
2019-09-23T10:27:11.388283-04:00 yukoncornelius ksmserver[1725]: ksmserver: Kcminit phase 2 done
2019-09-23T10:27:11.390273-04:00 yukoncornelius ksmserver[1725]: ksmserver: Starting autostart service  "/etc/xdg/autostart/backintime.desktop" ("/bin/sh", "-c", "backintime pw-cache start 2>&1 >/dev/null")
2019-09-23T10:27:11.396884-04:00 yukoncornelius kwin_x11[1744]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1162, resource id: 14680068, major code: 18 (ChangeProperty), minor code: 0
2019-09-23T10:27:11.411465-04:00 yukoncornelius ksmserver[1725]: ksmserver: Starting autostart service  "/etc/xdg/autostart/org.kde.korgac.desktop" ("/usr/bin/korgac")
2019-09-23T10:27:11.420093-04:00 yukoncornelius ksmserver[1725]: ksmserver: Starting autostart service  "/etc/xdg/autostart/powerdevil.desktop" ("/usr/lib64/libexec/org_kde_powerdevil")

I don’t know where else to look to get it to stop trying to mount this partition on boot.

I think you are a bit confused because you write about mounting on boot and then you tell it happens in your desktop (which one?), which is way after boot, not a system/boot thing at all, but the desktop on behalf of it’s user.

It is normal for e.g. KDE to offer the desktop user a pop-up when a file sytem is available but not mounted. E.g. when you connect an USB mass storgae device. In this case it is done for that unmounted partition.

I do not know why this happened earlier. And because the earlier situation does not exist anymore, it will be difficult to test that.

What you could do is making an entry in /etc/fstab for this file sytem, adding the noauto option. It will then not be mounted on boot and because it is in /etc/fstab, the desktop will then also not start the pop-up, etc.

Hi Henk, thank you for replying, and so quickly.

I’m definitely not confused, however I know from frequent visits to this forum that you are very knowledgeable and I appreciate your advise. I think we’re just used to slightly different terminology and semantics. You have an interesting suggestion (noauto) and i will try it out, thanks!

From the output it’s clear the OP is using KDE. ( see ‘kwin’… ). And, I’ve never seen pop-ups from the device notifier for internal disks. AFAICS the OP has tried to open the content on the partition from Dolphin ( they show in the side panel ).

Unfortunately that didn’t help. I boot into Leap, and when the desktop appears, there’s a dialog box asking for the root password to mount sda6. I even included user with noauto, so it definitely should not be asking for a password even if i do choose to mount it.

UUID=0414c60c-d2bf-4e2d-b14a-296e88f34f43  /mnt/AVL_home    ext4   user,noauto       0  2

Again, that is not related to boot.

You apparently use automatic login for a certain user, but that is still login. And while this might trouble your idea about the differnce between boot and login, it is still importnat to understand that difference when you try to solve a related problem. Else you will spoil your time searching in the wrong direction.

And when you have added an entry with noauto in /etc/fstab, then please show it. How do you think we can walk with you and check what you do when we see nothing.

Exactly! - the dialog that’s waiting for me when I start up is exactly the same as what you get in Dolphin when you click an unmounted drive. It was for this reason I tried a new empty session as well as opening the previous session (Configure Desktop, Startup and Shutdown, Desktop Session) in case it was something holding over from Dolphin.

Yes, Automatic login was selected by accident when I reloaded, and I have since unchecked it in Account Details/User Manager, but I still get no loginid or password prompt where the login should be. But I can deal with that until later, unless it may be related, which I doubt.

This is likely Udisks2/udev mounting. Have you tried configuring the device notifier so that only removable devices are handled?

You can also check via System Settings > Hardware > Removable Storage

AFAIK ( but a bit off-topic ) the fstab line should have ‘users’, not ‘user’.

According to man fstab, it is user.
I had already checked System Settings > Hardware > Removable Storage and all was correct in there.

Amazingly, I had said I doubted the autologin thing was related and now I think I have to reconsider. While I was waiting I decided to chase the autologin gremlin and discovered that in addition to the setting in System Settings > Account Details > User Manager there is a setting in Yast > User and Group Management > Expert Options > Login Settings which must also be unchecked to disable automatic logins. After a reboot (plus another to make sure) I have my login back again AND my sda6 problem appears to be gone! I don’t see the relation, but i’ll take it!

Thanks to you both for steering me in the right direction!

I re-enabled autologin and rebooted once again to do a more thorough test, but the sda6 password dialog does not return when I log in. I guess the first time I disabled autologin and came out of YAST some config file was updated/refreshed, correcting the issue. Problem solved, as far as I’m concerned.