Leap 15.0 + LibreOffice: The connection to the data source could not be established

After upgrading the OS from Suse Leap 42.3 to Leap 15.0 mysql/mariadb database cannot be accessed any more by LibreOffice. I DL-ed LO from LO web site.
The error message reads as follows:
The connection to the data source could not be established.
SQL Status: 08001
Unable to load the libmysqlcppconn.so library.

So far, up to including Leap 42.3, I used a native mysql connector mysql-connector-linux_4-3_x86_64.oxt without any problems.
I also tried LO 5.4.7 and LO 6.1 beta with Leap 15.0. However, the result was the same; no connection to the database.
I tried mariadb JDBC driver and it worked fine. However, I sticked to the native driver since all my templates, forms, and querries are populated with plurality of database fields, and it would be a real nightmare to make everything from the scratch.

So far, I have discovered only one differnce between 42.3 and 15.0; the file libmysqlclient is missing in 15.0.

Any suggestions.

No replies so far. Now, I am certain that the problem lies in Leap 15.0 not LO or mysql-connector. Why? Because everything runs smoothly on the other machine with Suse 42.2, LO and mysql-connector-linux_4-3_x86_64. Therefore, either something is radically changed in LO since 6.0.4 or in Suse Leap since 15.0.

What is wrong with using LibreOffice- and libreoffice-base-drivers-mysql, etc. from the openSUSE-Leap-15.0 repositories? If you have decided to mix packages from different sources, then it is your responsibility to resolve dependencies.

I did not mix different packages. As I mentioned in my first post, I use the “original” LO downloaded form the LibreOffice site for years along with the mysql-connector extension for many years without any problem. The problem arose with the upgrading of Suse Leap 42.3 to Leap 15.0. At that time, I downgraded LO to 5.4.7, and upgraded to 6.1beta, but the problem remained.

Using the original packages (Suse version of LO) could be a solution, however, said LO is still based on Qt4 and KDE4 and also installs plenty of different packages. Nevertheless, I did install today, some minutes ago, the Suse version of LO, along with all dependecies that Yast requested. When running Suse LO and trying to connect to mysql/mariadb database, I got the error message saying sometnig about missing the libmysqlclient_r.so. Thus, also the Suse version of LO does not provide flawless connection.

Now, I am really frustrated since my entire work is based on LO and mysql/mariadb. I have no access any more to any of the data.

Are you absolutely certain your problem is the changed LO MySQL connector?
Could your MySQL security have changed?
Have you logged in with your MySQL adminstratior account and verified you can access your tables?

Simply re-apply basic security settings using the provided “mysql_secure_installation” script.
I personally create a HereDoc so that the settings are saved and can be re-applied any time



For the openSUSE version of LO you need to install the package “libmysqld-devel” to get libmysqlclient_r.so.
Not that easy to guess …


The OP was looking for libmysqlcppconn.so which is part of libmysqlcppconn7, installed by default with MariaDb and LibreOffice from the openSUSE-Leap-15.0 OSS repository.

My users have had an integrated MySQL/MariaDB and OpenOffice/LibreOffice workflow for more than 15 years now and the recent upgrade to Leap-15.0 (with three coming from 11.4 and 13.2) has not revealed a LO-MariaDB connectivity problem. They use a LAMP web-server to enter hundreds of daily reports into a MariaDB backend with LibreOffice Write to update contact details an produce periodic statistical reports.

Great to see users experience. But note, in addition I upgraded Leap 42.3 to Leap 15.0 on my laptop with the very same result, no connection to mysql. Also, you might want to know that mysql/mariadb database is located in a remote server where no changes have been made.
So, the bottom line is as follows: I want to run “native” LO (not LO made by Suse) and make a connection to mysql/mariadb using SDBC mysql-connector as I did for the last 15 years.As I already mentioned, everything ran smoothly with Suse up to Leap 42.3. Upon the upgrade to Leap 15.0 the following error is shown:
The connection to the data source “ip” could not be established.SQL Status: 08001 Unable to load the libmysqlcppconn.so library. No mysql security have been changed. One additional information. I checked in LO “Connection pooling enabled”. When LO has been restarted the connection to mysql worked great. However, when I restarted LO again, the connection has gone with the above mentioned error. So, the connection worked only on one occasion.

I placed same problems (bug) in a forum of LibreOffice document foundation (https://bugs.documentfoundation.org/show_bug.cgi?id=117931). The conclusion is to stop further investigation since the bug occurs only in SuSE Leap.
So, I believe it is now SuSE’s turn to solve the problem.

Identical problem here. Will prevent me from upgrading other computers.