Leap 15.0 freezes on every one to day of usage


There is an issue with a PC :
Processor : Core-i3-3240 CPU
SSD disk
VGA compatible controller : NVIDIA Corporation GP107 [GeForce GTX 1050] - used with lkatest NVidea drivers provided by the repository,
VGA compatible controller : NVIDIA Corporation GF119 [GeForce GT 610] -unused

Motherboard: ASRock : B75 Pro3-M

Kernel : Linux 4.12.14-lp150.12.58-default (x86_64)

There are two booting partitions installed:
One with OpenSuse 13.2 which works like a charm
Leap 15.0 which gives strange issue on every one to two days without matter the intensivity andf applications used - the machine freezes completely.
At first it stops for some time then do it more friequently and evetually it has to be shut down and rebooted for another day or two usage.
The freezing includes everithinh including interuption of Audio later full stop; slugishness of the coursor movement and later it freezes as well.
The CTRL-ALT-DEL combination doesn not work as sell, just powering off the machine.
It the very rare cases being able to glimp the latest activity it seems there is high activity of kworker processes, which seems to build up over time for some reason.

I can not see any indications for errors in the log files.

Could you please advice where to start the troubleshooting from.

Thank you in advance.

How old is that computer? It might be failing hardware.

Show zypper lr -d between code tags (# in the tool bar)

Note you have two NVIDIA GPU but only one used. This could confuse things remove the 610 card

Which Filesystem are you using for the System Partition?

  • The default Leap 15.0 choice: Btrfs?

If so, then, in “systemd rescue” mode (user “root” password):

# btrfs balance start -dusage=85
# btrfs balance start -musage=70

Wait until those Btrfs maintenance tasks have completed and then, start the systemd “btrfs-scrub.service”.
Wait until the Btrfs “scrub” has completed.
Then, start the systemd “btrfs-trim.service”.
Wait until the Btrfs “SSD fstrim” has completed.
Then, and only then, reboot.

To avoid this in the future, ensure that, the “btrfs-balance.timer”, “btrfs-scrub.timer” and “btrfs-trim.timer” systemd services are enabled …


thank you for the advice.
I followeded it but the problem stays.

I set the btrfs-trim.timer to enabled, as the other are enabled by default and this buys some more time to have the OS operational but it does not solve the issue.
Is it an issue with the BTRFS, as I have the 13.2 with btrfs for the system as well, but never had any problem?


I can only suggest my one remaining Btrfs suggestion: it may be a partition free space issue – check the Snapper snap-shots – remove the outdated (older) snap-shots.

  • Check the free space on the Btrfs system partition with “btrfs filesystem df /”.

There are differing views on the minimum size of a Btrfs system partition needed for reliable system operation – IMHO, the installation default is often not large enough – the default openSUSE Leap 15.0 installation disables snapshots if the Btrfs system partition is less than 16 GB – a separate Home partition is not setup if the disk capacity is 20 GB or less.

  • For single disk systems with a disk capacity of at least 500 GB, I tend to set the Btrfs system partition to at least 40 GB and, for 1 TB drives I usually set the Btrfs system partition size to 60 GB or even 80 GB …

I’ll mention this. It might not be relevant.

I have Leap 15.1 (release candidate) running in a virtual machine with “btrfs”. (Okay, currently not running).

Yesterday it was running, but idle. I heard some noise of disk activity, which I recognized to be from the disk where VM images are stored. There was nothing else going on that used this disk, so it was most likely from the running 15.1 system.

I looked at the viewer. I typed in a command (in an “xterm” window). It was a command from which I expect an immediate response. But nothing happened. The system looked frozen. The mouse pointer did move, but I could not do anything else.

Then, after about 2 minutes, the noise of disk activity stopped, and the command that I had typed finally did something (opened another window).

So I think this was all some background “btrfs” maintenance operation that had locked the system from doing anything else until it had completed.

If there are features of the btrfs which could lead to unresponsive system is it possible to convert the btrfs to ext4 or other file system ?
I have only the system part with btrfs within 50GB partition, 24GB of which are reported as free. I believe it is enough free space for any file system to operate stable. The home directory occupies other partition with xfs on top.

In my opinion, the best time to do that would be when you move to Leap 15.1, which is expected to be released in May.

Hello olegue,

did you ever find a solution for the random freezes? I am encountering the same issues on my older machine since the very first Leap OS / Leap kernel. For me, he last stable OpenSuse that worked (and still works even with btrfs) on the very same hardware is 13.2, as well. I noticed that the freeze manifests in form of a hard kernel panic during systemd’s regular btrfs maintenance. FYI, I run Leap 15.1 with btrfs on a newer computer 24/7/xxx without any issue. It very much feels like a kernel/btrfs bug that only manifests on older hardware? My computer is an i7-720 with a Crucial MX500 SSD. My working compute rig uses an Intel SSD in contrast. As said before with 13.2 I have no issue whatsoever with the same MX500 SSD.