LEAP 15.0-1 BETA BUILD 184.1 How to change screen resolution?


System: AMD64 with Win 7 and Leap on 2 separate hard drives
Graphic card: NVIDIA GT 9500T

When installing Leap with KDE, I chose “nomodeset” and " F3 >Video BIOS size = 1024x768" as boot options. However, after reboot, the screen still shows a 800x600 resolution.

How do I change the screen resolution to “1024x768”?

Thanks a lot for your help.


Do you mean you are still in the installer? Or, at boot into the system after install?


This was the initial reboot right after installation. Editing /etc/default/grub shows:

  1. “GRUB_CMDLINE_LINUX_DEFAULT” has “nomodeset” inserted well before “…splash=silent quiet showopts”.

  2. "GRUB _GFXMODE=“auto”

What works:

  1. "GRUB_CMDLINE_LINUX_DEFAULT= “…splash=silent quiet nomodeset showopts”

  2. "GRUB_GFXMODE=“1024x768x16”

I then had to save the file /etc/default/grub, then execute the following to update grub:

grub2-mkconfig -o /boot/grub2/grub.cfg


I celebrated too soon. After an update of 666 applications, I rebooted. Found that Plymouth screen with 3 green dots boots into a black terminal.

How do I get to the usual login screen?

Thanks a lot for your help.


What GPU?? generally you don’t need nomodeset since it forces use of fall back drivers

GeForce 9500GT

F3 at boot of the installer only sets 1024x768 for the installation process itself. 800x600 usually means required software either doesn’t exist or hasn’t been installed. Absence of /dev/fb0 would confirm such an absence.

Use the ‘e’ key when the Grub menu appears to remove “splash=silent quiet nomodeset showopts” from the kernel cmdline so that you can see the boot messages and maybe spot an error message. If it doesn’t help, do the same thing, but append “plymouth.enable=0” before proceeding. Any of these temporary changes can be applied to /etc/default/grub to make them default when grub update occurs. You definitely do not want nomodeset unless you are troubleshooting (IOW, temporary) or following instructions for installing a proprietary video driver (commonly NVidia). FOSS drivers for Intel, AMD and NVidia GPUs all require modesetting to be enabled. Do you get output from

ls -l /dev/fb*


If the native mode of your display is 1024x768, it should be picked up automatically by both the kernel and Xorg, but if necessary drivers and/or firmware are missing this function can be blocked. What is the output from the following (install inxi with yast or zypper if necessary):

inxi -G -c0

??? Post here /var/log/Xorg.0.log if it exists, or if it doesn’t, /home/<username>/.local/share/xorg/Xorg.0.log, using CODE tags, or upload it to susepaste.org and provide a link to it here.

… or it means the EDID fails detection, which does happen with some screens. At any rate, at the time of boot, the resolution can only be set to what is detected from the monitor.

Although, there are workarounds, a bit technical, to inject some modes pre-boot.

While it is common to see on the Internet recommendations and discussion how to specify modelines when EDID fails, it’s not particularly complicated to provide Xorg usable specifications so that it can do its customary automatic modeline calculation and selection without any help from manual (CVT or GTF) mode calculation and specification, e.g. using an /etc/X11/xorg.conf containing the following or similar, depending on the actual display specifications and desired mode:

Section "Monitor"
    Identifier	"LaptopPanel"
    HorizSync         30-80
    VertRefresh       56-61
    Option	"PreferredMode"	"1366x768"

I re-installed Leap 15 Beta without “nomodeset” as one of the boot options. After initial reboot, I got the login screen and a mouse arrow but I cannot enter my password.

Ended up re-installing Leap 42.3 from an old DVD. Everything is working smoothly, kernel 4.4.120-45-default.

Will wait until after Leap 15 is released.