LDAP

I have configured LDAP on debian linux 2.6 as authentication server and I have also configured one LDAP client on debian which is successfully authenticated by LDAP server which is on debian. Now I am trying to configure opensuse as LDAP client. I have tried to configure LDAP client on suse in the same way as I did in debian LDAP client but it doesn’t work as well as I tried from yast (using LDAP client network services), neither of them worked. Can anyone please help me with it?

Have you tried using the ldap browser?
Type in the ipaddress of the ldap server and password and it should connect.
If you see the server, you should be able to connect using the client. Make sure you have ticked the automounter and home directories boxes.
Next go to the advanced config and set up your options.
Works fine from opensuse 11.x to sles 10 and sles 11.

When I tried LDAP Browser, it allows anonymous user access only to the LDAP server. So where might be the problem, where should I look for?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

what happens if you try non-anonymous?

Good luck.

kailashb wrote:
> When I tried LDAP Browser, it allows anonymous user access only to the
> LDAP server. So where might be the problem, where should I look for?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJyUxpAAoJEF+XTK08PnB5ZM8QAMSBBbvlLYjmP8foyE3noeai
tjJ6Eq7+9+Wh5CiTXSpOTpNUZ3nCIpQ6bwWFnwcy9WxqhT0/1A/BzVRjOB45kQUl
upmkZY3ymlQxb5PxZWuOCNgzzZSz8d8Gk9LOqoAbH0KSHD/QpDmJj8v43k5C33Of
Ei+Jrpt72RwDUpoLhefiH8UXHE4lAErFbhwi/c0p1w+OPNzOMjTznK1RlHuRmO77
ucpj6uc5ZvlAu1eYoDsRquLvUqKRiu2ZjUFZHZe3EEoqQXCPftbR+qPAgiFyrlFs
m+z6CAhq12YoyVA6G5aK49aP2QXKHNnUdq0YOhfkUQZ6LXhAqHgMLkkrACnTmF/v
XDGOIu7Ehwl40jKmAiCEbQxI4fWMndrFb/YwBz2c9u3oZBDZ/Ze2o0w7bdSrQSpl
7IWapMlYbLPt7I5gt+pfgJYwqUab9NsH+H2+5lCxqVyOpPIcubTUHgXvl/k8JL0Y
69k6REWqHR/Lu/suiGdWTUwZ2yLuDMsnRHcPyWhXRhKkTReGhNoIOUzwqwrKnVet
lQPCmDe1LuXSPPyEAZxVz1st/EMmTuIy1KBYUTJQA0Pn6eextpXe4pHKflnYqdBl
AiARxuUc+PLkvosgKymljG7XbpOu/Bd7lZMQZxVEx5DmM5Hmxfq/S0oTe8vstjFJ
oZsuLG6cHrSjV9JQYUg5
=HaI5
-----END PGP SIGNATURE-----

When I try non-anonymous access, it gives me a message “A problem occurred while connecting to LDAP server, Invalid Credentials”.

Waiting for reply

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Simple enough… you have the wrong credentials. What are you putting in?

Good luck.

kailashb wrote:
> When I try non-anonymous access, it gives me a message “A problem
> occurred while connecting to LDAP server, Invalid Credentials”.
>
>
> Waiting for reply
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJy8bXAAoJEF+XTK08PnB57EMP/RvUc181Sb/AKr96j7Xbx5zJ
Ma/UXreOWv72Q2Ed76UyMFkYfPNLv6bjtn4U1tSoGkHUmB9sDSD8+DoPBKJ64JKu
X6irAJ7PSM4UmfX/fc7j9Sqtht0hG1kMjuGz23pygLiftwer2Fxv2Xy/zdEG5EOG
bS9oQbFWNG7RO46QzuSAKkKPgJAKongJybalpBA7whl9ZR/pp4nbb09ZZM0tNWPA
D2CkDXvZ5MEoXzURiUV6C4ttsPQQB1t783dDtNViY+EkrJCGCJaq/mOAP/phj1GT
TkCyQ8PX8W6oQdfqlkpgwCqwA5Y6146+QR0Z83xPTi7VBGuzGnw0yDGn6hVJtbH7
nO/MkUgzwy49uOWnLPL4YxuWd5oYsLQpw5RwlLIr4/vA+dgc6ZkO/whifw1yUI4u
iHoodveGj9o7MeWTyYWEcz3fqv2AoEGo4qMUYIZfx1ALLXlj1QGjmHcbfC5QLNDW
01kBJy9+l/1lQbDEjhpd/mDef1O7ClZQ8ZuzplLXPPYXAj1tFQJ/nycorHiYOX7l
MzKDL6z7GeL1isTGYVFjYdknNcfYMeO+nLFdVEFpSNhN4pmTzpjThXwd65Nxgnn6
ylVRFkE8/zYbH8hMDCMi9WJ93vwXPCmSByD4mul29CMu1HGzjb4LHnmv5eL1fX6N
q2SO17PF11FhM9NS7x2X
=2GlK
-----END PGP SIGNATURE-----

how is it possible because I am able to login through the same admin password in the ldap server (http://localhost/phpldapadmin)?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

You are not putting in the credentials correctly, possibly. As requested,
please post what you are putting in here. Post the information here
please. Perhaps post your phpmyadmin configuration file as well.

I guess it may be that you have a base context specified somewhere in your
application and it is set incorrectly. Either way I doubt the LDAP server
is lying.

Good luck.

kailashb wrote:
> how is it possible because I am able to login through the same admin
> password in the ldap server (http://localhost/phpldapadmin)?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJJ0QLDAAoJEF+XTK08PnB54LQQAL2GNgVXXwNqZt76DBgSLSnN
qAQRNJOi6EGgIJpurPcwuvxasYbgRRgBWtHH3jXV38vHQl2F1mInxElVnmKY8rzG
Lz96B6JQ5JOFQGkz3pfyhfm2QTGptNRKaf+mk5R5rg3T2kjidX2wGYQZzI136Kdy
wm73pb352drsIYqNSDJVuBIUCgcVe4GIKtjHCPYj/WKpjRnbB9D04Gmr64GEGyLk
9h+JMW2O0WUQ6Ard9so/ns20fC8Lva11z+tnCbUO6o+z/L51M9sNJSOB4fFsErEK
IFgCPrWbV9d6/sdVlv6yNcYdMvmXKg5m7AeQCVq1v3mik8ajtHEarCiGYroMiogm
hazzr1JFk8A55xXj1jhuaKT8ZYU4RGDBo3Ab87hnqwNc6tJ8kvLHEmREiv14ZC2s
kc+k+IeCqsU3O4BNSwLR9hdwqrPayoVC8bpE4s0UH1Fe78ZOdrNSJYYEQWur6EPI
CR2xMV9xQv8edc/ZqPruoNHGxc3L8/SPwlsIDGyF4ZUd2QLPK20GbSx+Ijv6l25T
xfGnxKTIpZm+Gx1PR1k/sF2zjApRvfB4YGUV5yIyP7xDL8fibNcmvJA1wNQVUPVl
a90Ptrzu0fJ3Vv/E3X+eb/En5+t1SuIGT2cfU9SSaKaWX61WlkHwLtax1EtN3II4
cBG/s/Xyuo7k4Gw/QiQ1
=IOZ+
-----END PGP SIGNATURE-----

Thanks,
I solved the credentials problem. Now I got the new problem. while configuring User Management Settings on Suse client I got the following error message.

"There was a problem with writing data to the LDAP server. Invalid syntax objectClass: value #1 invalid per syntax

I also want to let you know that LDAP server is on Debian and Client is on Suse.

I have the same problem, with the server browser it works fine. But when I create some modules (the group and the user ones) it gives the error.
What am I doing wrong?

(My LDAP server is running on Ubuntu 14.04)

This is a very old thread. It is very unlikely that:

  • you have the same software versions as this thread is about;
  • you have exect the same problem’
  • many people will still look at this very old thread and thus see your post.

To get maximum exposure of your problem to draw the attention of the people that may be able to help you, it is always the best to start a new thread, in the best fittting (sub)forum, that has a title with keywords of the problem.

This thread is CLOSED to avoid further confusion.