LDAP UI Error fault

Hi everyone,

This is my 1st post. I set up LDAP on my opensuse11.3 following a youtube video and it was fine.

Tried to do the same thing tonight on 11.4 and it gives me an error when I click on the Finish button.

Step 1: General Settings
a) Clicked on LDAP server in YaST
b) Start LDAP Server -> Yes
c) Register at an SLP Daemon -> No
d) Open Port in Firewall -> Checked
e) Clicked on Next

Step 2: Server Type
a) Stand-alone server -> Checked
b) Clicked on Next

Step 3: TLS Settings
a) Left everything as it is, i.e TLS not checked and Enable LDAP over SSL selected by default but greyed out
b) Clicked on Next

Step 4: Basic Database Settings
a) Database Type -> hdb
b) BaseDN -> dc=royweb,dc=net
c) Administrator DN -> cn=Administrator & Append Base DN box -> Checked
d) LDAP Administrator Password -> Provided and re-entered on next line
e) Database Directory -> set by default to /var/lib/ldap & "Use this database as the default for OpenLDAP clients -> Checked
f) Clicked on Next

I get an error every time

A new window called YaST<2> opens up with black text in an orange background
UI Syntax Error
Invalid arguments for the RichText widget
Check the log file!

[Close Button]

The window goes away and on a new window YaST<3> I can click on Finish.

This generates a new error on a 4th window YaST,4>,
Enabling the LDAP server failed
Buttons -> [Ok] or [Details]
Clicking on [Details] does nothing so I have to click [Ok] to close it:\

When I closed it and tried to do this again, the only difference now is that before I go through Step 1, I get a window saying
Existing configuration detected
3 Buttons -> [Restart], [Cancel], [New Configuration]

I tried doing [New Configuration] as the others didn’t make much difference.

Could you please advise what I’m doing wrong?:expressionless:

Everything else is absolutely awesome and overall experience has been fantastic.

Many thanks,


Further to my post last night, I have found some sort of a detailed error message this time.

A window called Error - KDialog opens up following the UI error and has the following information in it:

MESSAGE IN Error - KDialog Window AS FOLLOWS:

Use of uninitialized value $hashAlgo in string eq at
/usr/share/YaST2/modules/LdapServer.pm line 2667 (#1)
(W uninitialized) An undefined value was used as if it were already
defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
To suppress this warning assign a defined value to your variables.

To help you figure out what was undefined, perl will try to tell you the
name of the variable (if any) that was undefined. In some cases it cannot
do this, so it also tells you what operation you used the undefined value
in.  Note, however, that perl optimizes your program and the operation
displayed in the warning may not necessarily appear literally in your
program.  For example, "that $foo" is usually optimized into "that "
. $foo, and the warning will refer to the concatenation (.) operator,
even though there is no . in your program.


Any help will be greatly appreciated.

Many thanks,


Hello, I have set without any problem several times LDAP server in 11.4 with only one difference - I have set it with TLS support (for this it is necessary to have a common server certificate or to generate it and to idicate it by yourself).
I will try to set it on a virtual machine without tls and will wrote here about result.

it works for me without tls also…
then I don’t know

Thanks for trying. I think based on the error, this might have something to do with Perl rather than LDAP.

I’m going to format and reinstall the default KDE setup from scratch, install LDAP after and retry.

That might fix it.

I’ll get back with the result.