LCP terminated by peer, with KVpnc

Hello Everyone,
I am attempting to connect to our corporate VPN, which I do not manage and I receive the error LCP terminated by peer, from the debug process everything else looks OK:

debug: No default interface given, tried default interface, got success, using “eth0”.
debug: Username: xxxxxxx
debug: Trying to connect to server “12.27.xxx.x” with user “xxxxxxx”…
debug: [pppd] using channel 7
debug: [pppd] Using interface ppp0
debug: [pppd] Connect: ppp0 /dev/pts/5
debug: [pppd] sent [LCP ConfReq id=0x1 ]
debug: [pppd] rcvd [LCP ConfReq id=0x0 ]
debug: [pppd] sent [LCP ConfRej id=0x0 ]
debug: [pppd] rcvd [LCP ConfAck id=0x1 ]
debug: [pppd] rcvd [LCP ConfReq id=0x1 ]
debug: [pppd] sent [LCP ConfNak id=0x1 ]
debug: [pppd] rcvd [LCP ConfReq id=0x2 ]
debug: [pppd] sent [LCP ConfAck id=0x2 ]
debug: [pppd] sent [LCP EchoReq id=0x0 magic=0xa46be23e]
debug: [pppd] rcvd [CHAP Challenge id=0x0 , name = “xxxxxxx”]
debug: [pppd] sent [CHAP Response id=0x0 , name = “xxxxxxx”]
debug: [pppd] rcvd [LCP EchoRep id=0x0 magic=0x677772e7]
debug: [pppd] rcvd [CHAP Success id=0x0 “S=C62FFC71C768E950508B40275D244AF68EAB4772”]
debug: [pppd] CHAP authentication succeeded
debug: [pppd] sent [CCP ConfReq id=0x1 ]
debug: [pppd] sent [IPCP ConfReq id=0x1 ]
debug: [pppd] rcvd [CCP ConfReq id=0x4 ]
debug: [pppd] sent [CCP ConfRej id=0x4 ]
debug: [pppd] rcvd [IPCP ConfReq id=0x5 ]
debug: [pppd] sent [IPCP ConfAck id=0x5 ]
debug: [pppd] rcvd [CCP ConfRej id=0x1 ]
debug: [pppd] sent [CCP ConfReq id=0x2]
debug: [pppd] rcvd [IPCP ConfRej id=0x1 ]
debug: [pppd] sent [IPCP ConfReq id=0x2 ]
debug: [pppd] rcvd [LCP TermReq id=0x6 "gwr\37777777747\000
debug: [pppd] LCP terminated by peer (gwrM-g^@
debug: [pppd] sent [LCP TermAck id=0x6]
debug: [pppd] Connection terminated.
info: Connection has been terminated.
debug: [pppd] Modem hangup
error: Remote modem has hung up. Connection was terminated.

This is a simple PPTP connection, but I’ll be darned if I even know what LCP is!!!

slacker9876 wrote:
> Hello Everyone,
> I am attempting to connect to our corporate VPN, which I do not
> manage and I receive the error LCP terminated by peer, from the debug
> process everything else looks OK:
>
…snip…
>
> This is a simple PPTP connection, but I’ll be darned if I even know
> what LCP is!!!

Link Control Protocol

I know that with my cell phone, I need to turn off all of
the lcp options in my ppp/options file. I just comment
them out. If I don’t do this, the connection gets
terminated after a bit.

Ok I figured it out, well kind of. My Ubuntu machine works flawlessly so I checked it and compared. I needed to check the boxes for require MPPE, Get DNS from peer and allow MPPE stateful mode.

Done

>:)

~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~
~^?}#@!}!}!} }<}!}$}%}"}&} } } } }%}&n&&H}’}"}(}"}#}$@#fp~

this is what i got after trying to communicate with isp with PPP.
it works well till the send accept script of " send atdt 99**1# accept connect" but LCP negotiation fails .
can any one tel y dis happen???