LCD screen brightness reset after reboot in 11.4


I am using OpenSuSE 11.4 32-bit Gnome and Nvidia binary driver 270.14.06 installed using the steps given in SDB:NVIDIA the hard way - openSUSE.
Everything is working fine except LCD screen brightness.

List of issues:

  1. LCD screen brightness is set to maximum once rebooted.
  2. Once logged in, if the screen brightness is set to minimum, it is set automatically to maximum brightness. Same issue when running on AC and battery.
  3. nvidia settings application is not in Applications. But from command line I can start the application using “nvidia-settings”.

xorg.conf file:

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 270.41.06 ( Mon Apr 18 15:15:12 PDT 2011

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”

Section “Files”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24

I am having Nvidia 8200MG with 512MB memory. I found that direct rendering is enabled by using glxinfo if it makes any sense:).

I am new to OpenSuSE. Please help.

In your xorg.conf file, add the line Option “RegistryDwords” “EnableBrightnessControl=1” to your device section, as illustrated below.

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "RegistryDwords" "EnableBrightnessControl=1"

You should not have an xorg.conf at all. Rename it, reboot and see what happens. AFAIK the issue should be fixed.

Thanks for the reply.

I have renamed the xorg.conf file as suggested by Knurpht.
After this, the screen brightness is minimum and is not reset to maximum once rebooted. Also, fan is making less noise :).

Howerver, on running powertop, I came to know that nvidia<interrupt> is the top cause for wakeup with 45%.
Is this normal?

Powertop output:
Wakeups-from-idle per second : 67.9 interval: 5.0s
no ACPI power usage estimate available

Top causes for wakeups:
48.3% ( 61.0) [nvidia] <interrupt>
16.6% ( 21.0) [Rescheduling interrupts] <kernel IPI>
8.9% ( 11.2) kworker/0:0
7.6% ( 9.6) [kernel scheduler] Load balancing tick
4.1% ( 5.2) [ahci] <interrupt>
2.7% ( 3.4) chrome

Thanks for the suggestions :slight_smile: I am liking OpenSUSE even more!!

But with the above renaming of xorg.conf, video playing in full screen has become choppy which was fine earlier!!
So I have moved back to xorg.conf again!!

Try the suggestion of adding Option “RegistryDwords” “EnableBrightnessControl=1” to your xorg.conf.

I added the above Option to xorg.conf file. But still the brightness is maximum once rebooted :frowning:

Again, I renamed the xorg.conf.
I added the line Driver “Nvidia” in file /etc/X11/xorg.conf.d/50-device.conf after reading the guide for OpenSUSE configuring graphics cards.
After this the full screen video choppiness is not happening.
But same problem of screen brightness is happening. I checked the Xorg.0.log file in /var/log but I couldn’t find any errors.