Latitude E5400 Sound Issues

Hey all,

I just loaded up OpenSuse 11.1 on my new E5400. At first, the sound was ok, but now after updates, it is no longer working correctly. I am rather new to Linux in that I am not that great at drivers and such, so be patient. :wink:

The sound file that I have though is :

options snd slots=snd-hda-intel

u1Nb.kAkNg_RVrkE:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Also, when I do head -n 1 /proc/asound/card0/codec* -
Codec: IDT 92HD71B7X

Any help is appreciated. I tried SDB:Intel-HDA sound problems - openSUSE but this did not work.


P.S. - Using headphones don’t work either. I say that because I know that there were some that had their headphones working but not their main speakers.

openSUSE-11.1 (with alsa 1.0.17/1.0.18) running the IDT 92HD71B7X was broken by the kernel update from the original kernel to the kernel. To address that the alsa/openSUSE dev posted some alsa 1.0.19 rpm updates on a repos that one needs to apply to repair sound.

There is guidance here: Alsa-update - openSUSE

Note you must send 6 zypper commands. Three to update all of the nominal alsa versions you have installed (to 1.0.19) and three more to add alsa-driver-kmp-yourkernel version. Be very careful to install the alsa-driver-kmp-yourkernel that matches your kernel. Also, do not install the debug nor unstable alsa drivers. And note for the nominal alsa versions, what is given is an example. Update all your alsa as applicable.

You need to restart after updating to unload the old modules and add the new modules.

Thank you very much. It worked perfectly.