Latest Updates To KDE Current Repo Breaks Oxygen Widget Style For OpenSUSE 13.1

Hi All,

Updated the latest files in KDE current this morning for openSUSE 13.1 and it broke Oxygen widgets style. If anyone else runs in to this just delete (or rename to old) trolltech.conf in your home directory and all will be fixed, it’s an old bug that occasionally reoccurs.

http://forums.opensuse.org/showthread.php/487788-KDE-Missing-Oxygen-Widget-Style-After-Upgrade-To-4-10-4-SC-Opensuse-12-2

Bug report submitted:

http://bugzilla.opensuse.org/show_bug.cgi?id=898815

Hm, I didn’t have any problems here.
And I doubt it’s directly related to that “update”, as there hasn’t really been any change AFAIK. (only the packages got rebuilt by OBS)

But I have read about similar problems in the past, yes. But I never experienced anything like that myself.

I suppose you mean ~/.config/Trolltech.conf though. There shouldn’t be any Trolltech.conf in the home directory. :wink:

Hi wolfi, I do mean ~/.config/Trolltech.conf, not the one for root :slight_smile:

There have been plenty of reports over at KDE on this and many other distros this happens to; it has been going on for quite some time now (4 years+).

https://forum.kde.org/viewtopic.php?f=66&t=91301

https://bbs.archlinux.org/viewtopic.php?id=137257

https://forums.gentoo.org/viewtopic-t-998528.html?sid=2815f43e7a74947414ac29f0d61c13a9

[863121 – oxygen widget style cannot be used

KDE Theme broken after 13.10 → 14.04 upgrade - Ask Ubuntu](863121 – oxygen widget style cannot be used)

The one for root would be in /root/.config of course, not in your home directory either… :wink:

There have been plenty of reports over at KDE on this and many other distros this happens to; it has been going on for quite some time now (4 years+).

Yes. As I said, I am aware that people are reporting similar problems for quite some time.

But even more so it’s unlikely to be related to the latest updates.

I could think of two things causing this.
Either the style is set wrong in Trolltech.conf, in this case you could set it manually using “qtconfig”. It is set to “Desktop Settings (Default)” here, and I never had that problem.
Or as the Trolltech.conf also contains a list of all found plugins, may this got corrupted/missed the oxygen style.
Not sure how that could happen though, probably a bug in Qt4?

Happened to me as well but the update was from a few days before.
Strange… I’d say it’s probably some kind of race condition, and maybe recent changes have increased the probability of having it occur.

Anyway, thanks for your advice on removing Trolltech.conf, that fixed it for me :slight_smile: