Latest kernels won't boot completely.

Dear people,
Having problems with the latest kernel kernel-default-5.13.0-5.1.g9140415.x86_64.
The later kernel kernel-default-5.13.1-1.1.gbebf622.x86_64 has the same issue.
But the kernel-default-5.13.0-4.1.gaa40472.x86_64 works fine, although for some reason logrotate fails to start at boot time en needs to be started manually.

The attachment shows the error I get when one of those two mentioned kernels are booted.
Uff (don’t know how to upload picture from computer here)

# rpm -qi kernel-default-5.13.1-1.1.gbebf622.x86_64
Name        : kernel-default
Version     : 5.13.1
Release     : 1.1.gbebf622
Architecture: x86_64
Install Date: Thu Jul  8 11:13:05 2021
Group       : System/Kernel
Size        : 180010351
License     : GPL-2.0
Signature   : RSA/SHA256, Thu Jul  8 02:40:23 2021, Key ID eceef21003579c1d
Source RPM  : kernel-default-5.13.1-1.1.gbebf622.nosrc.rpm
Build Date  : Thu Jul  8 02:35:16 2021
Build Host  : lamb67
Relocations : (not relocatable)
Vendor      : obs://
URL         :
Summary     : The Standard Kernel
Description :
The standard kernel for both uniprocessor and multiprocessor systems.

Source Timestamp: 2021-07-08 05:02:50 +0000
GIT Revision: bebf622aff1cb3cc04057e235652056aa3e2cff5
GIT Branch: stable
Distribution: Kernel:stable

# cat /etc/SUSE-brand 
VERSION = 15.2

Thank you so much in advance!
Please let me know if you need more information.


Welcome to the forum!

Good you know how to boot with an older kernel so at least you are not blocked.

For posting thing, you can use, that even works from the command line:

$ man susepaste
       susepaste - paste text on openSUSE Paste 

       **susepaste **[options] [FILE] 

       Paste  some  text to the openSUSE pastebin site, namely and These links are interchangeable, both sites are the same server, so you can use 
       either one of them.  If no argument present, it will read the text from standard input. Otherwise it will paste content of the file. After pasting, it will print out URL. 

       Options can be changed in ~/.susepaste configuration file as variables or specified as arguments. 

       -n **NICK**
              nickname of the author of the paste 

       -t **TITLE**
              name of the paste

[FONT=monospace]       -e **EXPIRE**
              for how log will be paste stored on the server. Default is 30 minutes, possible values are: 
                   30            30 Minutes 
                   60             1 Hour 
                   360            6 Hours 
                   720           12 Hours 
                   1440           1 Day 
                   10080          1 Week 
                   40320          1 Month 
                   151200         3 Months 
                   604800         1 Year 
                   1209600        2 Years 
                   1814400        3 Years 
                   0                Never[/FONT]

Hard to say what exactly goes wrong but the screen show already two good suggestions (See … for details)
Just log in as root and execute these commands, you can save the output to a file with a command “systemctl status auditd.service > auditd.log”

Would be good if you can post that output Using Code Tags Around Your Paste.

Thank you for your response!

Booted one of the faulty kernels, and it starts immediately with not taking the configured resolution, starts with big letters.
Fails root partition to mount in rw mode, but can save it to the home directory.

Tried a few times to paste the log to the url you provided, but it says:

**An Error Was Encountered

You are spammer!!!**

So i’ll paste it with Pastebin and submit the link here.

Errors start at line 649

#journalctl -xb

Just read you used a different command for log results, gives that the same info?

Thank you kindly for your help.

Try this command as root:

zypper in -f $(rpm -q -a --qf '%{NAME} ')


Thank you kindly, but the system works fine with the older kernel, so why should I take such a big risk?

ldconfig does give a few errors, but no empty library files.

#ldconfig -v
ldconfig: Can’t stat /usr/lib64/graphviz/sharp: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/java: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/perl: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/php: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/ocaml: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/python: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/lua: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/tcl: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/guile: No such file or directory
ldconfig: Can’t stat /usr/lib64/graphviz/ruby: No such file or directory
ldconfig: Can’t stat /libx32: No such file or directory
ldconfig: Can’t stat /usr/libx32: No such file or directory

Do you search for unneeded packages?


I find this one only for opensuse 13.2

That is a non-existent directory, don’t know why ldconfig complaints about that, but it only shows up with the verbose option.
If ldconfig had serious errors, then it would show up without the verbose option.
But ldconfing without that option has no errors.
Think we are searching in the wrong direction.

#rpm -qai | grep "Distribution: " | sort -u
Distribution: Essentials / openSUSE_Leap_15.2
Distribution: Extra / openSUSE_Leap_15.2
Distribution: home:aevseev / openSUSE-15.2
Distribution: home:alarrosa:packages / openSUSE_Leap_15.2
Distribution: home:cabelo:intel / openSUSE_Leap_15.2
Distribution: home:ecsos:ardour / openSUSE_Leap_15.2
Distribution: home:ecsos / openSUSE_Leap_15.2
Distribution: home:geekositalia:daw / openSUSE_Leap_15.2
Distribution: home:hawkeye116477:waterfox / openSUSE_Leap_15.2
Distribution: home:Lord-Master / openSUSE_Leap_15.2
Distribution: home:megamaced:spotify-easyrpm / openSUSE_Leap_15.2
Distribution: KDE:Extra / openSUSE_Leap_15.2
Distribution: Kernel:stable
Distribution: M17N:fonts / openSUSE_Leap_15.2
Distribution: mozilla / openSUSE_Leap_15.2
Distribution: multimedia:apps / openSUSE_Leap_15.2
Distribution: Multimedia / openSUSE_Leap_15.2
Distribution: (none)
Distribution: openSUSE Leap 15.2
Distribution: openSUSE:Leap:15.2:NonFree
Distribution: SuSE / Leap_15.2
Distribution: system:snappy / openSUSE_Leap_15.2

#rpm -qai | grep -C1 "Distribution: (none)" | grep Name
Name        : libftgl2
Name        : dd_rescue-lzo
Name        : libcolamd2
Name        : gitk
Name        : gcr-ssh-askpass
Name        : python2-pycparser
Name        : libpng12-0
Name        : iceauth
Name        : noto-sans-sc-bold-fonts
Name        : libSoundTouch0
Name        : typelib-1_0-Geoclue-2_0
Name        : libpopt0-32bit
Name        : mkcomposecache
Name        : libhogweed4
Name        : libjson-c3-32bit
Name        : javapackages-filesystem
Name        : libKF5AlarmCalendar5
Name        : libbluray2
Name        : gpg-pubkey
Name        : kde-user-manager
Name        : patterns-non_oss
Name        : libthai-data
Name        : libyui-qt11
Name        : plasma-nm5
Name        : libksba8
Name        : pkg-config
Name        : gnome-games
Name        : git-gui
Name        : xorg-x11-libs
Name        : Mesa-libva
Name        : librecode3
Name        : python2-cryptography
Name        : gtk2-branding-openSUSE
Name        : gpg-pubkey
Name        : gnome-themes-accessibility-gtk2
Name        : libgirepository-1_0-1
Name        : gpg-pubkey
Name        : libxcb-xv0
Name        : python2-CDDB
Name        : libqca-qt5
Name        : libKF5Kipi32_0_0
Name        : python2-feedparser
Name        : libpulse-mainloop-glib0
Name        : kmahjongg
Name        : libSM6

I would believe that there is some incompatibility with the latest kernels, but how or what?
Anybody used those latest kernels?




zypper lr -d
zypper se -si | grep -Ei 'system_p|system p|system-p|systemp'

Check it with TW + new kernel or Leap 15.3 + new kernel.

Maybe you don’t need new kernel at all - your hardware is rather old.

Yes, I need that for the external sound card.

Have installed kernel-default-5.12.15-lp152.1.1.x86_64 from a different repo and removed the old kernel.repo.
5.13 is just tooo much bleeding edge.

Thank you all!

JFYI: There is an issue with kernel-default-5.13.1-1.1.gbebf622.x86_64 and kernel-default-5.13.0-5.1.g9140415.x86_64 from Kernel:stable repo if secure boot is enabled (bad shim signature). Version 5.13.0-3.1.g531fe4a.x86_64 works fine (cf.

Regards, Frank

kernel-default-5.13.1-4.1.g72aabc2.x86_64 from Kernel:stable might solve your issue.

Regards, Frank