latest kernel update kill my pc !

I all

I updated the kernel (automatic by yast) and now i got grub screen and no more

I have try to update opensuse 11.3 with DVD but always i got error message

“script /lib/mkinitrd/setup/01-dcbd.sh failed
there was an error generating the initrd”

the kernel update from 10-10-2010 is 2.6.34-7

i am not a grub sprecialist and so i dont want to do a mistake

could you give me a solution ?

why this update make a so big … in my pc ??>:)

note : i have only opensuse on the machine (no dualboot) and twa partition /sda2 for / and /sda3 for /home

Did you upgrade a openSUSE-11.2 to the actual openSUSE-11.3 ? If so:
mv /lib/mkinitrd/setup/01-dcbd.sh …

no it is an automatic upgrade with yast auto-update. i run 11.3 since 3 months

any way i can use unix command, i just get the “grub editor” at boot

i can use system rescue to do that il you want, but ?? i should do that and after try again with 11.3 dvd to repair installation
regards

may be that help ?

because there is no repair option on 11.3 dvd and because i read on suse faq it is possible to use another version of opensuse to repair grub, i use 11.2 dvd and “repair boot loader” option but that does’nt work

regards

If you have the 11.3 DVD
Picasa Web Albums - carl fletcher - DVD Kernel Fix

?? if i have the dvd ??? yes and so what ?

Picasa Web Albums - carl fletcher - DVD Kernel Fix

i finally found i should clic on link
I try like you explain to downgrade the kernel and re install the dvd version but i still got error message "script /lib/mkinitrd …

before that i have another error message

“cannot read table of mounted file system no such file or directory”

so it is not the solution for my problem which seem a grub problem

thank’s
regards

note : i have only opensuse on the machine (no dualboot) and twa partition /sda2 for / and /sda3 for /home

And what about swap?
I assume you have it because you have I guess 3 partitions, not 2. Presume sda1 is swap?

Might it not be easier to just re-install and keep /home

of corse/dev/sda1 is swap

if i re install, that ’ will be the ultimate solution, i will have i day of update after the installation !!!

I see
You are on dialup internet then?

Live CD - then chroot to the installed system
start yast, re-install the kernel and check your bootloader

we would be interested to see

fdisk -l

and the contents of your installed menu.lst

just a remark at this time.

now from 11.3 dvd menu when you choose install, you can’t avoid a re-format of / partition, that’s was not the cas with 11.2. what about a machine with no /home partition ???

I use 11.3 dvd no live cd

should i make one ?

i do that now :
boot from dvd, choice rescue menu
with rescue, mount /sda2 on /mnt

fdisk -l give :
/dev/sda1 1 262 210 id 82 linux swap
/dev/sda2 * 263 873 id 83 linux
/dev/sda3 2874 30401 3 linux

menu.lst under /boot/grub is :
timeout 8
gfxmenu (hd0,1)/boot/message
default 0
I does not write comment line

just a remark it is writen " modify by perl-boot loader ?
regards

You could save your self time by writing a menu

I have to go out now so can do it for you

Someone else may help in the mean time

no but even with adsl, update of kde to 4.4 version, openoffice, mozilla product, virtualbox and so on take a while and i should re enter deposit on yast !!!

regards

You were allready nice with me
i don’t know what i should write un menu.lst to be good ?

regards and thanks

Find out if you actually have a kernel installed first by examining your root /boot partition from a live cd
This will do:
http://dl.dropbox.com/u/10573557/pmagic-4.5.iso

all right i have created a dvd

should i use option 13 in menu ?

regards

i run first option
i can mount my device from the nice (ENGLISH !!!) menu and KEYBOARD !!! but ?? now can i run yast ? to try to repait my boot loader ?

regards

first i have downloaded version 5.6 and on these i canuse french keyboard !!
second i still does’nt see how i can repair my boot loader

third i read that
http://opensuse.swerdna.org/susebootfive.html#brokengrub

and command

root (hd0,1) work
kernel /boot/vmlinuz run
but the command
initrd /boot/initrd return an error message no file

effectively i mount device sda2 and i dont have /boot/initrd file !!!