Latest Flash plugin Firefox 12 crashes with "dequeue_pending_request .. failed"

I have Firefox 12 installed on Opensuse 12.1/64-bit.

I have the Flash plugin installed

flash-player-kde4-11.2.202.235-89.1.x86_64
flash-player-11.2.202.235-89.1.x86_64

At many Flash content-containing site, e.g.,

http://www.cbs.com/shows/amazing_race/video/2230970338/the-amazing-race-ep-11-12-it-s-a-great-place-to-become-millionaires

I get a Flash crash,

“The adobe flash plugin has crashed. There is no report.”

If I quit and re-launch Firefox from the shell with just

firefox

and visit the same site, I get this output

plugin-container: xcb_io.c:140: dequeue_pending_request: Assertion `req == dpy->xcb->pending_requests' failed.
WARNING: pipe error (112): Connection reset by peer: file /builds/slave/rel-m-rel-lnx64-bld/build/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 419

I’d appreciate ANY suggestions of what to do to fix this.

I’ve not seen any issues other than those mentioned since the previous update, which is still an issue in this latest update. Users have disabled the Hardware Acceleration option in the settings
SUSE Paste

Hi,
The latest update seems to cure the discoloration when hardware acceleration is enabled.
To the op I had the problem the same as yours after updating. The same message in the terminal as yours.
When I run top I saw the plugin-containe using 100% CPU that even crash firefox.
When I changed the flash video to play 1080p it crashes flash also. When I killed the plugin-containe
flash started to play nicely. Then after a while starting to crash again.

Edit for update:
Now with your link flash totally crash!
plugin-containe is using 191% CPU

I’m getting a LOT of crashes with Flash in Firefox 12 since the update (mostly with 1080p but also with lower resolutions too). NEVER had crashes before this. Any idea what’s causing it and how to fix it?

This seems to work, but the changed setting will not stick across restarts.

Instead, editing:

vi /etc/adobe/mms.cfg

  • EnableLinuxHWVideoDecode=1
  • EnableLinuxHWVideoDecode=0

works, and sticks.

I use a vdpau-capable NVidia card, with the nvidia driver.

Until recently, I never had issues with Flash use. ALthough this quick-edit works, I don’t know if the problem is Flash ( I suspect it is ), NVidia, etc. or some combination of issues.

It’s definitely Flash because the only update I applied was Flash and all of a sudden it started happening. I also turned off hardware acceleration and that fixes it, but that kind of negates the purpose of having a good graphics card.

It’s a bug in flash-player
You live with it until Adobe fixes it or you can roll back
http://dl.dropbox.com/u/10573557/12.1_Misc/flash-player-toggle.png

Dowgrading to 11.2.202.233 solves the problem. If you have this version, you can put a lock on flash-player until the bug is fixed.

sudo zypper al flash-player*

This command excludes flash-player, flash-player-kde4 and flash-player-gnome from zypper update.

Downgrading to any 11.2.x version doesn’t seem to do a thing here. Downgrading to v11.1.x does fix the problem – but seems a bad idea given security problems.

Reading at Adobe Forums: Flash player crashes my computer every single time suggests that the coming v11.3.x fixes the problem. There’s a beta available at Download Adobe Flash Player 11.3 Beta for Desktops - Adobe Labs, but only for Mac & Windows.

If I read this correctly,

https://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html
“For Flash Player releases after 11.2, the Flash Player browser plugin for Linux will only be available via the “Pepper” API as part of the Google Chrome browser distribution and will no longer be available as a direct download from Adobe. Adobe will continue to provide security updates to non-Pepper distributions of Flash Player 11.2 on Linux for five years from its release.”

Unless
(1) Adobe considers fixing this current hardware-acceleration problem a “security update” (I doubt it),
or
(2) Firefox and other non-Chrome browsers implement the “Pepper” version of Flash (Haven’t heard anything about that),

we shouldn’t be expecting any fix from Adobe.

And, that seems to be the case: https://bugzilla.mozilla.org/show_bug.cgi?id=729481.

Thanks Adobe & Google!

Wow, that’s awful! I know Adobe is moving away from Flash in general anyways, but the problem is it’ll probably take 5-10 years to get Flash use (for video, etc) on the web to dip to 10% or lower. Look how long it took for IE6 use to dip below 10%: 11 years! Hopefully, the increase in Ubuntu machines on newly shipped computers (e.g. Dell) will help push Adobe to change this policy, but I doubt it.

Is there an opensource alternative to flash (like moonlight instead of silverlight)?

The best I could find is:
Technology Temple - the tech blog of the students of Sant’Anna School of Advanced studies
Lightspark

It apparently has a plugin for Firefox.

Hardly seems worth the effort.

“Support for various websites using Flash”
Create new page · lightspark/lightspark Wiki · GitHub

doesn’t look good.

Sounds like it’s Flash-in-Chrome, or InternetExplorer-in-VirtualBox (Wine, maybe?)

Downgrading to version 11.2.202.233-15.1 appears to have solved the problem for me.

I had to logout/login otherwise, “zypper ps” showed deleted files were running. I have since successfully run several flash videos in both Firefox and with Thunderbird’s rss feeds.

FYI,

Gordon

I can confirm it, when i downgraded to 11.1.102.x it worked!
So now wait until a new patched version come out.

Thank you guys!! :wink:

So even the last update of flash sucks… lucky me i have seen this thread before upgrading from flash player 11.1.

One of my younger k4 users has his own solution, each time saw flash error, he selected report the error, then selects reload.

Asked if it worked he replied yes - usually, sometimes needed a couple of times to repeat the steps, and sometimes it just does not work so gives up, switches to another video.

SInce upgraded to 12.1 this year, few complaints, only now realized not yet installed moonshine.

My flash was fixed downgrading to .233. I made a thread about it a few days previous.