Latest Flash in FFox doesn't fix the Playback Issue

I just ran the latest flash update and tested Firefox on IMDB videos.
Still the same issue exists

Just FYI :wink:

Is this, by any chance, related to the graphics driver?
I still use the Niveau drivers.

YouTube works for me. The IMDB videos look ripped apart with blocks flickering around. Mmm…

Nothing to do with graphics drivers.
Only a few sites are affected, IMDB being one of them.

You probably mean Nouveau driver…Yes?

Thanks for checking this out Carl. It is kind of odd that such a problem would persist and not yet be corrected in the latest updates. I presume that our original solution Here still works OK for you?

Thank You,

Just checked and you are right about Firefox. It is curious that it plays fine in SeaMonkey 2.1rc1 though.

I never used the fix.
I just don’t use much flash and all I do use is OK

The problem is general, this problem has not solved.

No. It’s isolated to a few sites.
And there is a solution that is well documented.

Exactly, thats the one i am using. Never remember the name :slight_smile:
But it is strange, isn’t it? Why does it not work on some sites? I am really puzzled.

Why does it not work on some sites? I am really puzzled.
You and me alike.

Why some sites? I have no idea

As to “Why some sites?”, a number of issues come to mind, such as embedded frames and iFrames, embedded 0px’s and so forth. I had not experienced this issue (Flash playback) on Firefox 3.6.17. After (at long last) installing Firefox 4 (4.0.1), the playback problem presented on an Intel Arrandale/Ironlake graphics PC, although did NOT present on an ATI Radeon. Considering the ongoing kernel graphics issue(s) with the Arrandale, I was not surpised.

Since Flash runs on Firefox via the “plugin-container”, a little research turned up a subtle change in the defaults for isolating plugins. In Firefox 3.6.4 -->3.6.<latest>, the default value of “dom.ipc.plugins.enabled” was FALSE. As such, individual plugins (such as Flash, pdf, and Java) only run “isolated” if the associated “dom.ipc.plugins.enabled.<plugin>” was set to TRUE.

With Firefox 4, apparently the default for “dom.ipc.plugins.enabled” is now TRUE. Thus, any plugin (Flash, Java, etc) will run “isolated” unless specifically set to false. The kicker in this long explanation is that there is NO “About:config” variable for “” !!!

CAVEAT: The following changes, if done improperly, MAY result in an unusable profile. (so have a backup??).

In the address bar, enter “about:config”, promise you will be nice, and locate “dom.ipc.plugins” (sans the quotation marks). Right-click on “dom.ipc.plugins.enabled” and “Toggle” to FALSE. This change will eliminate the playback corruption in Flash, but … (there is always a but…), Flash videos will be slow to start and slower to stop.

Next, being very careful, right-click anywhere in the empty area, and click “New”, and “Boolean”. Enter the following EXACTLY:

Click “OK” then set the value to TRUE. Restart Firefox, and Flash videos should be happy once again. As to why this works, I have a suspicion that Firefox is not applying the default isolation to non-specified Flash plugin.

Now, for the “I wonder”: is the current Flash plugin 32-bit, 64-bit or unsure ? All I am sure of is that my ATI Radeon is a 32-bit openSUSE 11.3 on 32-bit hardware, and the Intel Arrandale is 64-bit openSUSE on 64-bit hardware.

Wow SeanMc98, you once again amaze me with your know how. I have saved your steps, but since the beta Flash still works OK, I am unsure if I should perform your procedure and switch back to the main line flash file or not. Still, I thank you for your diligence with working through this solution. Well done!

Thank You,