Last update sent login-screen to infinite loop

Have a Dell Precision M6300 with Nvidia graphics card (no Nvidia driver installed), doing fine for about a year. Machine is TW with KDE and configured for autologin on boot.

Last update this morning (including kernel) sent machine to an infinite loop on reboot, I see the login screen (splash?) for 1-2 seconds, then it is trying to start the GUI (screen turns black), but after 1 second the login screen is back and so on and so on and so on. Reboot, tried previous kernel, same result.

Something messed up graphics?

With ALT+CTRL+F2 I reach a console, but no idea what to try there…

Any advice how to switch graphics back to working mode?

…in the console I got these two messages:

Nouveau 00... DRM: EVO timeout
Nouveau 00... DRM: base-0: timeout

Dunno what to make out of this…

Any way to switch back nouveau to working version?

PS: in dmesg I see:

14.92... KLEOPATRA[1566] segfault at 8 IP 00007f8c63a87ea9 SP 00007fff77079710 ERROR 4 in LibQT5XcbQpa.SO.5.7.1 [7F8C6394C000 +FC000]

I have the same problem i think: booting the system end in a black screen, i can access text consoles but i have to spam the hotkeys to reach it, if i try to switch back to the login manager (CNTRL+ALT+F7) the login menu pops up for a second and then the screen gets black again. I also use nouveau.

…did you have a look at dmesg in the text console? :slight_smile:

According to Yast the KLEOPATRA thing is the KDE key manager. Sigh…

Any news here? Machine still not working…

Someone on IRC ran into a similar issue and we debugged it being related to xauth, so see if you suffer from the same issue;

Look at your /home/username/.xsession-errors-:0 file.

If at the end of that file it refers to MIT-MAGIC-COOKIE errors, rename your .Xauthority to something else and restart (it’s also located in that users home directory).

Hi! Many thanks for reply, but there are no such Magic-Cookie errors in the :0 file and renaming .Xauth didn’t change anything on reboot…

try downgrading nouveau to previous package version. If that works, lock the package for now. There seems to be a problem with the latest package, see

Until it’s figured out, I have everything here working again, as normal, following the tip to downgrade XF86-video-nouveau to version 1.0.14-1.1.

…I guess

sudo downgrade nouveau

is not an option? :wink:

Have NO idea how to achieve that in the console…

sudo zypper in --oldpackage ./xf86-video-nouveau-1.0.14-1.1.x86_64.rpm
sudo zypper al 'xf86-video-nouveau*'

There is probably some zypper command for this but the above should do.


Many thanks for reply. Some days of pain for my wife ended! :slight_smile:

I was told to use zypper install --old-package as the zypper command. I’m not an expert on zypper, but it worked when I did that. However you did it, must have done the trick. Glad it worked for you, as well.

Thank you for suggestion! As even after some days of repeated reporting of this issue the defective package apparently is distributed via regular update of TW this thread might help someone disparate to recover his computer from a near-death experience…


This is not working for me, because there is only the new (buggy) version xf86-video-nouveau-1.0.14-2.1.x86_64.rpm available.

I have a local copy, PM me your eMail and I will send it to you… :slight_smile:

After an installation of the latest snapshot of TW I’m also facing the login/loop problem. It goes always back to login despite choosing xorg or Wayland.
Not able to open a virtual console though. My machine is Skylake Dell Inspiron with Intel integrated graphics and Radeon.

…have a Dell Latitude with i5 here, but didn’t update ANYTHING since the first machine got bricked. Maybe try the old xf86-video-intel?