Last Security Update Borked Desktop Access

Don’t know what was in that last security update but I can no longer boot to desktop, it gets stuck before KDE loads. Final Plymouth dots finish and then the screen goes blank, no life.

Prior, I noticed that the software updater kept spitting error message when I clicked to install the security update. So I did zypper up instead which seemed to complete, so I refreshed the software updater (clicked install) but the same update was still there giving the same error message. Went to log off / on to see what would happen and system hung, so had to dirty reboot. And that’s where I’m stuck, at the above.

What gives, was running fine before? Quick cure?


Video driver and how installed?

I had the same problem this morning.
Updated the system yesterday evening, shutdown the Laptop and this morning it doesn’t boot up in KDE anymore. My solution was to rollback to an earlier stage with snapper and then I installed the updates again. It works now. I don’t know what went wrong by the first time…

I knew it was that update, I sat watching the bugger and knew it wasn’t right. I’m just waiting for more people to pipe up.

Problem for me I don’t run Btrfs, due to it being unreliable ****, the only thing I can think to do is run fsck from a live disk atm.

fsck repairs broken file systems it will not repair incorrect packaging

  1. check your repos be sure ALL are for the right version

  2. if you installed NVIDIA driver the hardway reinstall

  3. run yast from command line and roll back broken packages, if you know which

fglrx all the way for me, nice and stable, never had issues before. Repos were fine, I moved to the plasma 5.5 and did dup not long ago.

Last one sounds interesting. So from DVD rescue prompt, mount both root and home and then what command wise, sudo yast?

Not familiar with what that will look like so assume it’s text mode yast box - where do I head after that? I could spot the update by date I reckon.


You have to do a chroot after you mount the partition just the root no need to bother home
Were X# is your root partition on the hard drive

mount /dev/sdX# /mnt

mount --bind /dev /mnt/dev

chroot /mnt
mount -t proc proc /proc
mount -t sysfs sysfs /sys/sbin/yast

Unfortunately command line yast does not have a history module you can see history in the GUI though
Maybe try another desktop??

Had to reinstall in the end. Not the end of the world, least all my stuff is in tact and retrievable, needed to rejig things anyway. Thanks, I’ll keep for future reference.