Last 12.1 update switched to systemV by itself

As the title say, it seems that the boot sequence switched to the old one after an update last Sunday.

However is seems practically as fast as the new one (can’t remember the name right now).

Or is it still the new one, with better formatted and more extensive boot messages?

I’m just curious, it is working fine.

There are of course different methods to check that, one of the simplest
is to run the command systemd-analyze, if it gives you an output similar
to that


martinh@ganymed:~/scratch> systemd-analyze
Startup finished in 6449ms (kernel) + 25172ms (userspace) = 31622ms

you run systemd, if it fails you run sysvinit.


PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
GeForce GT 420
Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.0
| nVidia ION
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
xf86-video-geode

Hmm, I hadn’t noticed that. But, when I check:


% ps -fp 1
UID        PID  PPID  C STIME TTY          TIME CMD
root         1     0  0 Mar04 ?        00:00:01 /sbin/init

Check what /sbin/init really is


martinh@ganymed:~/scratch> ls -l /sbin/init
lrwxrwxrwx 1 root root 14  3. Mär 22:31 /sbin/init -> ../bin/systemd


PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
GeForce GT 420
Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.0
| nVidia ION
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
xf86-video-geode

Thanks, martin_helm.

It seems I’m running systemd, although the analyse tool isn’t installed:

~> systemd-analyse
If 'systemd-analyse' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf systemd-analyse

~> ls -l /sbin/init
lrwxrwxrwx 1 root root 14 Mar  4 14:59 /sbin/init -> ../bin/systemd

~> ls -l /bin/systemd
-rwxr-xr-x 1 root root 899520 Fev 20 12:20 /bin/systemd

systemd version is 37-3.8.1_x86_64 according to yast’s software manager.

Pics (click to enlarge):

http://thumbnails28.imagebam.com/17847/09fa93178464419.jpg](http://www.imagebam.com/image/09fa93178464419)

http://thumbnails42.imagebam.com/17847/04f99e178464422.jpg](http://www.imagebam.com/image/04f99e178464422)

It’s nice.

Thanks. Much appreciated.

This is great stuff. I decided to add what you found to my blog here. Have a look:

systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

Feel free to add anymore you wish to say…

Thank You,

Hi, it’s systemd-analyze (iwth a z) and not systemd-analyse (with an s).

HTH

LEnwolf

Yes, copy/paste is a very difficult technique to master rotfl!

It is! CTRL-V on the 12.1 netbook didn’t paste what I CTRL-C’ed in my 11.4 desktop where I was logged in this forum, I don’t know why… :slight_smile:

@ lenwolf

Yes, I first tried martin_helm’s command, with a “z”. Got the same command-not-found warning. But I was not motivated enough to search for/install the package, as I saw I was still on systemd. Perhaps I made another typo, but I don’t think so. I’ll check later, maybe. Now I’m at the 11.4 desktop that won’t CTRL-C to the netbook! D*mm linux! I think I’ll go back to OS2! :slight_smile:

??? This is about Linux, what has this to do with CTRL-V and CTRL-C? Isn’t that Windows stuff?

Am 07.03.2012 18:16, schrieb brunomcl:
>
> hcvv;2446452 Wrote:
>> Yes, copy/paste is a very difficult technique to master rotfl!
>
> It is! CTRL-V on the 12.1 netbook didn’t paste what I CTRL-C’ed in my
> 11.4 desktop where I was logged in this forum, I don’t know why… :slight_smile:
>
What a crappy system :wink:
You should enable the remote copy and paste feature for physically
disconnected systems.
It uses the builtin laser of your desktop to burn the information
directly into the RAM of your netbook, make sure the netbook sits face
to face to your PC.

> @ lenwolf
>
> Yes, I first tried martin_helm’s command, with a “z”. Got the same
> command-not-found warning. But I was not motivated enough to search
> for/install the package,
:frowning: not motivated enough ??? :frowning:

> as I saw I was still on systemd. Perhaps I made
> another typo, but I don’t think so. I’ll check later, maybe. Now I’m at
> the 11.4 desktop that won’t CTRL-C to the netbook! D*mm linux! I think
> I’ll go back to OS2! :slight_smile:
>
Its part of the systemd package, so I guess you simply made a typo


martinh@ganymed:~> rpm -qf /usr/bin/systemd-analyze
systemd-37-3.8.1.x86_64

but of course you already have the info you needed, so no need to check
this again.


PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
GeForce GT 420
Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.1
| nVidia ION
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
xf86-video-geode

On 2012-03-07 18:26, hcvv wrote:
>
> brunomcl;2446581 Wrote:
>> It is! CTRL-V on the 12.1 netbook didn’t paste what I CTRL-C’ed in my
>> 11.4 desktop where I was logged in this forum, I don’t know why.
> ??? This is about Linux, what has this to do with CTRL-V and
> CTRL-C? Isn’t that Windows stuff?

Not entirely, there are some programs in Linux that also use those keys for
copypaste. For example, thunderbird, firefox…


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

It’s called retribution.

Now, I’m sure you know it works as well as the select and middle-click linux way, at least here in KDE. Perhaps in gnome is different.

ROFL!

Thus the lack of motivation.

On 2012-03-08 06:16, brunomcl wrote:
> Now, I’m sure you know it works as well as the select and middle-click
> linux way, at least here in KDE. Perhaps in gnome is different.

No, the same.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I use FF and I never used such finger braking keyboard combinations, only use the mouse for copy/paste. (as I do since the the 90ties)

On 2012-03-08 11:26, hcvv wrote:
> I use FF and I never used such finger braking keyboard combinations,
> only use the mouse for copy/paste. (as I do since the the 90ties)

I use all combinations. In Linux, some times mouse copy paste produce
different results than ^C,^V, the later also carry format information. You
can, for example, copy paste a page displayed in FF to an openoffice write
document, and carry over the tables, figures, font sizes.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)