Large file transfer with Samba crashes openSUSE 11

This happened to me twice in the past two days. I was transferring about 7 to 10 gb each time from a windows machine one day and a mac the other day via samba to my new openSUSE 11 box. About halfway into the transfer the transfer stops. I was also logged in remotely to the computer via VNC and that stopped working also. At first I thought it was because I ran out of hard drive space. So after I rebooted the first time I increased the side of my LV. I was able to finish the transfer just fine. Then the next day (the second time this happened) I tried to transfer another 7 to 10 gb and it crashed again on me. The LV had almost 60gb worth of free space so I am going to say it is not an out of space issue.

It crashed both times while transferring large amounts of data via samba.

Any ideas or where to start looking etc?

Hi dtd,

How is the file transfer between the windoze and the mac? Do they transfer without a hiccup between them?

Are all the machines hooked up to the same switch/router?

As for Samba, you will Swerdna’s almighty Opensuse samba config guides very valuable on his site here.


Between windows and mac is fine. They are running on a 100mb switch.

The samba works after a fresh reboot, and I was able to get the files to the openSUSE 11 box it was just funny that the computer crashed twice during the same procedure.

So I guess I was wondering if it was a known issue where samba would choke up during large file transfers. If that is not the case then I will look elsewhere since I do not know samba is the exact problem.

dtd33inc schrieb:
> This happened to me twice in the past two days. I was transferring about
> 7 to 10 gb each time from a windows machine one day and a mac the other
> day via samba to my new openSUSE 11 box. About halfway into the
> transfer the transfer stops. I was also logged in remotely to the
> computer via VNC and that stopped working also. …]
> Any ideas or where to start looking etc?

Start by checking the standard questions:
Exactly what happens when it crashes? Is it just the network
connection that goes dead, or is the console unresponsive too?
Does the keyboard still react? (NumLock test) Do the special SysRq
key combinations still work? (Enable it if you haven’t done so yet.)
Are there any error messages on the screen or in the system logs?

Then, try to find out what reproduces the problem. Only Samba transfers
to the Linux machine? Or also Samba transfers from the Linux machine to
your other machines? What about non-Samba network traffic? (for example,
FTP) Non-network disk activity? (eg. copy a 7 to 10 GB file from disk
to /dev/null or from /dev/zero to disk)

That way, you should get a feeling whether it’s more of a network, disk,
or Samba issue - or perhaps not even an issue with the Linux machine at


Tilman Schmidt
Phoenix Software GmbH
Adolf-Hombitzer-Str. 12 Amtsgericht Bonn HRB 2934
53227 Bonn, Germany Geschäftsführer: W. Grießl

Had a similar issue last week on OpenSuse 10.3 with the RT kernel.
Rebooted the machine with the default kernel, and things haven’t hung ever since.

I saw it happening while I was transferring all data from a Netware 6 (running cifs) server to my new OpenSuse server.
During the copy job, switching between apps in KDE started to become slower, then stopped, and a bit later the mouse became completely unresponsive. After that I couldn’t do anything any more (no even switching to TTY screens)

System is AMD Sempron 64 based, 22,5" ATA disks, 23,5"SATA disks, 2GB RAM, and that’s about it (its a low power system)

This will probably not help you very much…



Dear list,

that large file transfer crash seems to me to be of much larger significance than hitherto debated: It occurs regularly, and it occurs not only under control of Samba, but under that of any file transfer program that exists: ftp as well as opera and firefox (http), and it occurs whenever files larger than ca. 800 MB ar being transferred. The usual (but not “normal”) result is that the system gets fozen. It gets frozen, because under these circumstances inconsistencies occur in the file system. Either all (or sometime only one) of the partitions gets marked “with errors” and is suddenly remounted “read-only”. This means: ONe cannot write to it any more, before a fsck run has been made (unmounting the partiton, fsck-ing it and cleanly remount the partition). Under these circumstance, there are normally many “orphaned” inodes and quite a few wrong deletion time settings left in the file system, and also many erroneous group ascriptions.

This points to some error in one of the file system drivers of SuSE 11, x86_64 version, which are used by the file transfer programs,

One way to reproduce the error is to try to install either of the two programs via Yast2: z88 finite element program the acrobat reader. Both packages are large enough to securely crash the system. I guess the error must be somewhere in the scsi drivers or in the layer interacting between ftp (or http for that matter) and the file system (ext3).

Without such large file transfer, the system runs quite stably, though.

I suggest, however, to somehow replace the buggy wpa_supplicant version of SuSE 11 by a more recent version: The stock version contains an error in the handling of psk keys, which makes it pracically unusable. With a new version, there are no problems. I also suggest to update ath_pci (for less random behaviour) and to enlarge the selection of accelerated graphics drivers.

Burkhard Meissner

mkather wrote:
> Hi, I have exactly the same problem towards a SuSE 7.0 share. There is a
> new Samba version in SuSE 11, it’s just not fully tested,
> alpa-version at most. Forget about it and go back to SuSE 10.2

10.2 is discontinued, do not use.

I agree with AndreasStieger, 10.2 is past end of life. This is bad info to give as anyone going back to 10.2 won’t get any updates. If you have issues with Samba under 11.1, best bet is to ask for help.

Are you running the stock 11.1 kernel? Maybe it’s this problem:

11.1 systems locking up? - openSUSE Forums

AFAICT the fixed kernel is still in Factory, no update has been released yet. Apparently the developers are still sorting ABI issues as a kernel update is disruptive of other things like NVidia drivers, etc.

I have the same problem! OpenSuSe 11.1, 64 bit, samba share It’s driving me nuts!

BTW that kernel fix was released to update about a month or two back, so anybody who thinks they might have this problem should update. If the problem continues with the latest openSUSE kernel RPM, it’s a different cause.

You’re right. Suddenly Samba drives are read-only despite the fact they are writable. I’ve got x86_64 openSUSE 11.1

ken_yap says that there is a new kernel. I’ve got updates enable and kernel-default- and the problem still exist.
BTW I’ve samba-3.2.7-11.3.2.