Large binary size of Qt4-Application on openSUSE 11.0


since openSUSE 11.0, I noticed that the binary size of my Qt4-Application increased from 1.2MB to 14.3MB.
First of all: I compiled the application as “release” and the Qt4.4-libraries are definitely built shared :wink:
It is also NOT caused by changes of my source-code, because I didn’t change it and the problem also occures when I recompile old versions I made with Qt 4.2.
Oh, and my application doesn’t use any extra resources (only Qt, of course the standard-lib and it calls some POSIX-functions).

I did a lot of experiments during the last days:

  • tried on a clean system
  • tried Qt-packages from different sources
  • downloaded the Qt-sourcecode from Trolltech and compiled and installed it by myself
    => no difference, so it is not a package-problem
  • tried with Debian Etch, Kubuntu 8.04 (also Qt-distro packages and manually compilation) and finally with openSUSE 10.3
    => in all these cases everything is fine and I get 1.2MB again…

Any suggestions/ideas ??? :slight_smile: