Laptop - xfce DE - WiFI connects to network -no internet

On boot up notification indicates a connection to my router is completed.

I’ve been through lwfinger’s sticky posts. Everything checks out from there.
Browser and email all give ‘site not found’ or email ‘could not connect to xxx server. All 6 email accounts do that.

I have done the service restart (found in other threads these forums) several ways and still no browser/email connect beyond the machine.
BTW, if I reboot into Windows, no problem.

I suspect it may be a dns problem within Leap, but so far everything I have found on the web hasn’t helped.
I have check NM’s settings numerous times, and they have not changed since I set it up.
IpV6 is disabled.

It worked yesterday, only thing different was Leap would not complete a shutdown, and frustration pushed the power button.

I don’t know if this happens wired, but I suspect it will if I plug in the Ethernet cable.

Where to start looking for answer?

Am beginning to think the Toshiba laptop is Linux jinxed!

All other PC’s and both iPads all function as they should.

Regardless of address, pings are ‘not reachable’.

Hi Bill. To get a comprehensive idea about the NM connection, run

nmcli

Press to terminate

The above will provide IP address, default route, and DNS information, but you could run these as well to get that information…

ip a
ip route

This will show current DNS configuration if it exists…

grep name /etc/resolv.conf

If no valid nameserver exists, then name resolution won’t work. You could then try

sudo rm -f /etc/resolv.conf
sudo systemctl restart network

There were two valid nameservers listed for

grep name /etc/resolv.conf

But I did the rm -f and the restart ones and I can get past a do nothing browser and email screen finally.
I’ll see what happens on a restart.
But Dean, I did those last two several times today without good results. I guess you are magic.

Strange, but good outcome anyway. :slight_smile:

The only other thing I can think of is that perhaps you didn’t kill and restart the browser and email client after restarting the network?

I made sure browser and email client were closed before a network restart.
AFAIK, I thing else trying to access the ‘outside’.
Maybe the updater, not sure.

If you’re dual-booting Windows and something else (eg openSUSE),
Keep in mind that no matter which OS you boot into, unless you mask your MAC address, you appear to be the same machine to your DHCP server.

The consequences of this is that the DHCP server will literally think “Oh, it’s you again and you already have the IP address so if nothing has changed I’m going to ignore your query so you can use what you already know.”

The problem of course is that maybe in MSWindows the OS has that DHCP info but when you boot into openSUSE the OS won’t have that info.

If this is what is happening to you,
There can be two fixes…

  • Do a network restart as you’ve done which tells the DHCP server “I <really> don’t know my IP address so give it to me again” - If this happened in MSWindows you would do an “ipconfig -renew”
  • As I briefly mentioned above, you can “mask” your MAC address, ie configure a software MAC address for your network interface which over-rides the MAC address in the network adapter silicon. With a different MAC address, your DHCP server will <know> that your MSWindows and your openSUSE are two different machines on your network.

HTH,
TSU

… you are probably right about the Magic.

Deano forgot to mention to you that he stirred some extra bats ears and lizard tails into the cauldron.:wink: