Laptop wifi connections fail on all confiured SSIDs - Where to look next?

I had been trying to sort out a strange problem with my NFS connection to NAS and traced one problem to a long forgotten user on this laptop which had been set up with UID of 1002 and which somehow had become remembered in the NAS. In my ignorance I deleted the rogue user and associated line in /etc/passwd.

This didn’t solve my NFS problem but has entirely broken my wifi connection. The AP is working fine and other wifi devices can and are connecting to it but my T530 laptop cannot connect.

It seems that the authentication is what fails because I get repeated requests to enter the SSID password, which I do, even though my Network Connection are all set up as usual with passwords saved in the configuration. The connection always fails.

I have deleted and rebuilt the wireless connections but to no avail and and need help on where to look next please.

I am able to connect using lan which is how I am connecting to this forum. I have an almost identical laptop with same OS which is working fine so do not attribute the problem to updates and am stuck.

Once again, all help gratefully received.

I was too quick to post. I now find that my other laptop cannot connect so my diagnosis was probably wrong. It has been the upgrade which has broken the wifi connection.

In summary Leap 15.3 update has broken my workstations and TW update has broken my laptops.

I suggest the openSUSE maintenance team need to review their QC/QA procedures.

Meanwhile is there a fix for the wifi as my laptops are virtual bricks without connectivity?


Too bad things did break for you, without more information is it hard to debug things.

I am wondering if the problem is the same as discussed in Network Manager wireless must be turned off and then on after booting since latest wpa_supplicant

Hi and thanks for the reply. I have switched to Wicked for now. The turning wifi off and on didn’t work but that may be a hardware issue.
Now I have connectivity will browse the thread.
Thanks again,

Many thanks for the link. I too am using KDE but on this machine I am running TW.
For the same problem to appear on both of my laptops suggest that there is a bug with the last update.
I hope somebody has the time and knowledge to be able to post a bug report but regret beyond my capabilities. Just happy Wicked allows me to keep working.

I Had The same problem after kernel update and test update. went through many different procedures but none worked I remembered to reboot from the previoue kernel in grub menu ? the previous kernel in revovery mde restarted all my networks. then i rebooted from the updated kernel and things worked fine. they still are . Today is 02/03/2022. the update broke my net 2 days ago. If this works you can also use yast to choose which kernel boots first. I would think that maybe the new kernel needs a patch. PS . Leap 15.3 HP 17" laptop amd ryzen

Update From yesterday. (2/3/2022) Had an update to wicked. It also broke my network connections. Had to reboot from previous kernel again. Have set previous kernel as default now. All net working ok now from previous kernel.