Laptop sporadically failing to suspend and hard lockup

Hi, I have a Lenovo T530 laptop that is highly compatible with Linux, running openSUSE 13.2 on it. Recently it has started to sporadically fail when trying to suspend to RAM. When it fails, the screen stays on and it completely locks up, forcing me to hard power-off.

This is the pm-suspend.log after rebooting from a failed suspend:

And this is after resuming from a successful suspend:

Any suggestions? Or are there any other relevant logs elsewhere? Thanks a lot!

What video GPU and what driver?

Standard Intel graphics with the Intel driver.

Have you gotten all the updates I believe the installed driver had a bug but a fix cam in via update.

I have seen those very symptoms on other machines when the HD begins to fail or contact to the HD is lost, so check your drive.

Also, check your memory … er, I mean, the laptop’s memory.:wink:

Hi again, and thanks to everyone for their replies.

My system is 100% updated.

I ran a memtest86+ and it returned no errors after the first pass.

I don’t think it could be a loose hard disk, because I never move the laptop, and it only acts up during suspend.

Any other relevant log files that could help diagnose this? Thanks again!

I got lock ups trying to get a desktop computer out of hibernation. Searched here and there and found this

So I uninstalled pm-utils and let kernel handle everything. Voila, problem solved.

At that time I was on 3.18.x, now 3.19 so since kernel gets involved success or not might depend on version. In the link he says pm-utils is deprecated so that must mean kernel features cant be that experimental.

Should be safe to test by removing pm-utils.

@js9600]( Thanks for the tip! I removed pm-utils, and suspend still works. I’ll report back if it locks up on me again.

Incidentally I forgot to ask, were your lockups happening every time or just sporadically?

Every time, no problems hibernating but getting back to life only got to the 3 loading dots on screen. Just sat there doing nothing.


I run into a similar issue on my HP laptop with openSUSE 13.2 fresh install. Hibernate and suspend with pm-suspend/s2ram/systemctl suspend failed after 2 or 3 hours usage of the computer. The screen went black but the power was still on.

I found this bug report

After entering
blacklist mei
blacklist mei_me
in /etc/modprobe.d/50-blacklist.conf the suspend and hibernate works now as expected.

Good luck