laptop sound will not work

OK, boot your PC and immediately after boot is complete, copy and paste this into a gnome-terminal or a konsole:dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/aand post here the URL that will give. That command will post a sort of boot log file to a web site, where by passing the URL I can look for error messages.

Also, to remove the possibility of a hardware problem, does your sound work in another OS (such as windows)? You may have mentioned this already, but I did not see this in a quick skim, and I can not remember if you mentioned it.

Please also copy and paste into a gnome-terminal or konsole: /sbin/lspci -nnand post here the output.

That /etc/modprobe.d/sound file has wrong syntax. Is that a cut and paste error ? Note what I highlighted in red. That sound be an “s” and not an “a”.

chetan@ATECH-7fe15baee:~> dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
**http://nopaste.com/p/aa4B0kjM8**
 
chetan@ATECH-7fe15baee:~> /sbin/lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 0c)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 02)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 02)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 02)
**00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)**
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 02)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 [8086:2849] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 02)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [8086:2829] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M GS [10de:0427] (rev a1)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 12)
03:01.3 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
03:01.4 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev ff)
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express [14e4:1713] (rev 02)
0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection [8086:4229] (rev 61)
chetan@ATECH-7fe15baee:~> 

I fixed my error in the /etc/modprobe.d/sound file. Thanks!

The Audio works fine in the Dual boot with XP Pro.
If I install the Vista Hard Drive all devices including Audio work fine.
Also, with openSUSE 10.3 Audio worked fine right out of the box.
It was Video with Nvidia that was the hassle.
With openSUSE 11.0 Video is fine out of the box; with Audio being the strange child.

Also, in Yast > Hardware (there is no <Sound> entry.

Thankyou OldCPU,
Chetanji:)

I don’t understand what you mean by “if I install the Vista Hard drive”.

then it should work now as well.

I note the following in your dmesg> If there is a warning there, I do not understand it:

ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:2555: hda_codec: model '3stack' is selected
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:3268: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:3272:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:3276:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:3277:    mono: mono_out=0x0
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/hda_codec.c:3285:    inputs: mic=0xe, fmic=0xb, line=0xf, fline=0x0, cd=0x0, aux=0x0
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/patch_sigmatel.c:2775: dac_nids=3 (0x2/0x5/0x4/0x0/0x0)
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input12 

I also note this:

PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report 

which is something we can consider.

Lets check the interupts. Please post here the output of: cat /proc/interrupts

Also, please try to configure your sound with alsaconf instead of yast. ie type: su -c alsaconfand please when testing your sound, use the audio test:speaker-test -Dplug:front -c2 -l5 -twav
Dont forget you need to keep checking your mixer.

Also try that audio test with root permissions:su -c ‘speaker-test -Dplug:front -c2 -l5 -twav’

The final tests I can think of are removing the pulse audio applications, and then, if you still have no sound, we can do some tests with boot codes, such as pci=routeirq or acpi=off or pci=acpi

One test you could do is boot to run level 3 (ie type “3” (no quotes) in the grub menu and select the suse boot) and log in to the ascii text prompt as a regular user. Then type : speaker-test -Dplug:front -c2 -l5 -twav

If I put the hard drive that came with this laptop into the bay and boot up MS Vista; the Audio and Video are fine.

ATECH-7fe15baee:~ # cat /proc/interrupts
           CPU0       CPU1       
  0:     404786     420336   IO-APIC-edge      timer
  1:       2343       2176   IO-APIC-edge      i8042
  8:          0          1   IO-APIC-edge      rtc0
  9:         28         29   IO-APIC-fasteoi   acpi
 12:     131590     122145   IO-APIC-edge      i8042
 14:      67977      18641   IO-APIC-edge      ata_piix
 15:          0          0   IO-APIC-edge      ata_piix
 16:     282799     229260   IO-APIC-fasteoi   nvidia
 18:          6          5   IO-APIC-fasteoi   sdhc0:slot0
 19:          2          0   IO-APIC-fasteoi   ohci1394
 20:     689425     235404   IO-APIC-fasteoi   uhci_hcd:usb1, uhci_hcd:usb4, ehci_hcd:usb7
 21:       2231       2372   IO-APIC-fasteoi   uhci_hcd:usb3, uhci_hcd:usb5, HDA Intel
 22:         18         13   IO-APIC-fasteoi   ehci_hcd:usb2, uhci_hcd:usb6
4344:       2549       2165   PCI-MSI-edge      iwl4965
4345:      53441       4669   PCI-MSI-edge      eth0
4346:      65382       8632   PCI-MSI-edge      ahci
NMI:          0          0   Non-maskable interrupts
LOC:     278507     343494   Local timer interrupts
RES:      87850     116676   Rescheduling interrupts
CAL:       9302      22822   function call interrupts
TLB:       1308        980   TLB shootdowns
TRM:          0          0   Thermal event interrupts
THR:          0          0   Threshold APIC interrupts
SPU:          0          0   Spurious interrupts
ERR:          0
ATECH-7fe15baee:~ # 

I am able to access the alsamixer and make adjustments but alas no sound.
Also the sound button on the laptop make the icon come up on the display and show volume up and down and off.
But again no sound.

I will remove the pulse audio applications.

Should I go into Yast to do this or is it easier/faster with the command line?

Thanks,
Chetanji

This suggest a mixer setting, or a bad codec. But if you do the sound test I asked, then codec is not an issue.

Do it the way in which you are most comfortable.

Don’t forget to do the other tests that I listed in my previous post.

The speaker tests always run the script but then hang up and I must ctr-Z to quit.

alsaconf always finds the correct card and then I do restart just fine.

But no sound in speaker-test

I removed all pulse apps with Yast and will now try your Boot codes and booting runlevel 3.

Thanks, Will let you know shorly.
Chetanji

delete …
info already provided.

I note your audio is sharing an interrupt with some usb devices. What (if any) usb devices to you have plugged in?

I plugged a pen drive last week into the laptop with some mp3 music for banshee to play.
This was the only way I could think of to test the sound.

I must have left the pen drive in at some config point.
This is what comes to mind.

How do we correct this?

Thanks,
Chetanji:O

Keep using the sound test I recommended (even IF you need to “kill” it all the time).

Simply remove it. It should not have a permanent affect.

No other USB devices?

Did reboot with pulse removed work? How about audio test from run level 3 (ascii/text loggin)?

I would really like to see your mixer settings again. How 'bout installing tsalsa: PackMan :: Package details for tsalsa
after which it is a simple matter to run it by typing: su -c tsalsa

Chetanji writes: 
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/chetan/.gvfs
      Output information may be incomplete.
md5sum: tsalsa: No such file or directory
uploading /tmp/tsalsa.txt to nopaste.com
 tsalsa completed in 130 seconds
paste this url in #alsa: **http://nopaste.com/p/aEtfIk0a7**

What happens if you (very very briefly) boot without this USB cooler in place (and test your audio). Does it make any difference? (Don’t leave it like this for long).

Amixer contents for card 0 [Intel] _____________________________________
amixer set ‘Surround’,0 100% off 100% off
amixer set ‘Center’,0 100% off
amixer set ‘LFE’,0 100% off
amixer set ‘IEC958 Playback Source’,0 Items: ‘Digital Playback’ ‘ADAT’ ‘Analog Mux 1’ ‘Analog Mux 2’ ‘Analog Mux 3’ Item0: ‘Digital Playback’
amixer set ‘Swap Center/LFE’,0 off
Have you tried setting your mixer to one of the analog settings, instead of digital? Also, have you tried switching ON surround (having it at 100% with it muted makes no sense). The same is true wrt Center and LFE. You should be consistent with your mixer settings.

The only way I adjust the mixer is with…

# alsamixer

This is what it looks like for me…

┌──────────────────[AlsaMixer v1.0.18 (Press Escape to quit)]──────────────────┐
│ Card: HDA Intel                                                              │
│ Chip: SigmaTel STAC9228                                                      │
│ View:  Playback  Capture [All]                                               │
│ Item: Front [dB gain=-12.00, -12.00]                                         │
│    ┌──┐     ┌──┐      ┌──┐     ┌──┐                                 ┌──┐     │
│    │  │     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     │
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
<    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     >
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│                                 │▒▒│     │
│    ├──┤     ├──┤      ├──┤     ├──┤     ┌──┐      ┌──┐   Analog M   └──┘     │
│    │OO│     │MM│      │MM│     │MM│     │MM│      │MM│                       │
│    └──┘     └──┘      └──┘     └──┘     └──┘      └──┘             L    R    │
│                                                                    CAPTUR    │
│   87<>87  100<>100     100      100                                93<>93    │
│ < Front  >Surround   Center    LFE    Line In   Mic as O IEC958 P Capture    │
└──────────────────────────────────────────────────────────────────────────────┘


All I am able to do is adjust the volume gain up or down. I don’t know how to mute it or otherwise with the keyboard.

Next boot I will unplug the cooler and mouse. Just found out the touchpad doesn’t work now.
Thanks,
chetanji

I don’t user alsamixer, but either with alsamixer or amixer it should be possible to umute those levels. Frankly I would be surprised if it is not possible to umute via some key sequence in alsamixer.

Typically Gnome users are the one’s who use alsamixer. I don’t like Gnome. I have not installed Gnome for many years, and I figure Gnome users can support Gnome users. So, perhaps you can search google to learn more about alsamixer in Gnome?

The only reason I started off with Gnome is because I read that Beginners should stay with Gnome as KDE is tricky and tempermental/ really for experts and developers.

The touchpad not working with USB mouse unplugged looks like its related to the sound irq mixup.

What do you think?

Thanks,
Chetanji

Another strange item…

While in alsamixer if I use the keyboard sound buttons to raise/lower/off any highlighted slider;
Only the Main slider is effected.
The slider I am currently in is not effected.
This is a classic conflict situation.
I just don’t know enough about Linux to help myself.

Thanks,
Chetanji:)

Thats just FUD from axe grinding Gnome users. There is no truth to that wrt KDE3. None.

One can toss a coin as to the desktop they start with (KDE3 or Gnome).

Now one consideration today, where is KDE is in flux, with KDE4.1.2 (which looks pretty good IMHO) is just around the corner, but KDE-4.0.4 on openSUSE-11 has maturity problems. KDE-3.5.9 (on openSUSE-11) is very nice and stable but it does mean if one learns KDE3, … in a year or so one will have to learn KDE4 (or switch to Gnome).

Anyway, the questions you are asking now are very Gnome/desktop specific. I can’t help there.

I just deleted the openSUSE partition and started over with KDE4 and have now just got on the WEB.

So it looks like you are recommending KDE3 instead of KDE4.
Oh well, let me know what you think.
I appreciate your help very much as well as your opinion.
I need to get this working.
I will go back over this thread and install the correct /etc/modprobe.d/sound file and the proper alsa files.
Hopefully all will be well there.

Thanks,
Chetanji

As I write this I am removing KDE 4.x and installing KDE 3.x as per your “wisdom borne of deep experience”.

I do like gedit though as a terminal editor, just found out gedit is Gnome based.
I will have to get used to different tools from what I have used through the years.
I like Amarok much better than Banshee.

Oh, I almost forgot to mention. The sound worked as soon as I edited the /etc/modprobe.d/sound file and added “model=3stack”.

Unfortunately, Amarok is not set up to play mp3 files yet so cannot celibrate with a song.

Thanks, and look forward to more correspondence in the future.

Blessings,
Chetanji;)