Laptop running hot

I have a HP Compaq 8510p laptop that I just installed OpenSuse 11.2. Since I had it running, the laptop runs noticebly hotter than when in windows - even under very little load, basically web surfin. It gets so hot it makes my hands sweat! The fan also runs a bit louder and it always spitting out hot air. Ive done a little research and haven’t come up with much. I also noticed my battery life is ~45-60 min less than a full charge in windows.

Any help is appreciated!!

~> cat /proc/acpi/thermal_zone/TZ*/temperature
temperature: 60 C
temperature: 54 C
temperature: 52 C
temperature: 50 C
temperature: 35 C
temperature: 60 C

top - 20:17:43 up 55 min, 2 users, load average: 0.02, 0.10, 0.09
Tasks: 170 total, 1 running, 169 sleeping, 0 stopped, 0 zombie
Cpu(s): 8.6%us, 1.8%sy, 0.0%ni, 89.1%id, 0.5%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 2037548k total, 760100k used, 1277448k free, 42332k buffers
Swap: 2104472k total, 0k used, 2104472k free, 403632k cached

Can you check powertop?

su -c ‘zypper in powertop’

and then

su -c powertop

I ran powertop…didnt seem like anything out of the ordinary. id post the output, but am having problems copying it (read below).

My laptop has a ATI Mobility Radeon HD 2600 video card. I updated to the latest drivers. Not sure if that helped or not. The top of the laptop seems cooler, though its stil kinda warm. That command I ran above still shows temps 55-80C.

One problem after updating the drivers: my mouse cursor is missing. Its really weird becauase I can move the mouse around and click on things, but the cursor is totally missing. Kinda like an invisible mouse

Alright. I got my mouse back. Just had to uninstall the ATI drivers, install the kernel-dev pkgs from the repo and rerun the ATI install. Works fine now.

Okay, so back to the heat issues…this is what I have right now - surfing the internet with FF and Gnome Terminal open:

:~> cat /proc/acpi/thermal_zone/TZ*/temperature
temperature: 80 C
temperature: 73 C
temperature: 61 C
temperature: 56 C
temperature: 35 C
temperature: 75 C


 PowerTOP version 1.11      (C) 2007 Intel Corporation

Cn Avg residency P-states (frequencies)
C0 (cpu running) ( 0.4%) 2.21 Ghz 0.1%
polling 0.0ms ( 0.0%) 2.21 Ghz 0.0%
C1 mwait 0.0ms ( 0.0%) 1.60 Ghz 0.0%
C3 mwait 12.4ms (99.6%) 1200 Mhz 0.0%
800 Mhz 99.8%

Wakeups-from-idle per second : 80.5 interval: 10.0s
no ACPI power usage estimate available

Top causes for wakeups:
22.3% ( 22.7) <kernel core> : hrtimer_start_range_ns (tick_sched_timer)
15.1% ( 15.4) <interrupt> : ata_piix
13.1% ( 13.3) <kernel IPI> : Rescheduling interrupts
10.3% ( 10.5) <interrupt> : iwlagn
10.1% ( 10.3) <interrupt> : PS/2 keyboard/mouse/touchpad

Powertop does give me some suggestions, but they dont seem to do anything. They also dont seem to stick after a reboot.

Though, it does seem that installing the vid drivers helped. Ive only been on the laptop for about 1/2 hr now, but it seems to be running quieter and the batter shows ~3hrs of life now. Keyboard and stuff still seem warm, but that could be from using it previous to the driver updates.

Thanks for the help so far…Any other suggestions?

All the outputs seems normal so far. Even powertop shows that your processor mainly idle in C3 sleep state, and rarely shoots up to 2.21GHz…

If you have the proprietary ATI driver, powerplay should be working to throttle down your graphic chip as well.

80C looks a bit too hot. Might be sensor misread or something. Weird.
Can you try reading the temperature using sensors?

su -c 'zypper in sensors'

Here is the output:

~> sensors
Adapter: Virtual device
temp1: +44.0°C (crit = +105.0°C)
temp2: +44.0°C (crit = +105.0°C)
temp3: +29.6°C (crit = +105.0°C)
temp4: +60.0°C (crit = +110.0°C)
temp5: +55.0°C (crit = +256.0°C)
temp6: +47.0°C (crit = +105.0°C)

and just to compare:

~> sudo sensors
Adapter: Virtual device
temp1: +44.0°C (crit = +105.0°C)
temp2: +44.0°C (crit = +105.0°C)
temp3: +29.6°C (crit = +105.0°C)
temp4: +60.0°C (crit = +110.0°C)
temp5: +55.0°C (crit = +256.0°C)
temp6: +47.0°C (crit = +105.0°C)

That looks much better. how does that compares to

cat /proc/acpi/thermal_zone/TZ*/temperature


I wouldn’t worry too much if the temperature is indeed around 50C~ :slight_smile:

Oops… when I wrote “and just to compare” I meant to paste the output of cat /proc/acpi/thermal_zone/TZ*/temperature. IIRC, it was around 50-55C. I dont have my laptop with me right now. Ill use it more this weekend and see how it plays. But, I think its much better now and the driver update helped.

Ive been using my laptop now for a while over the weekend. Its working much cooler. Not as loud with the fan either. Battery life is over 3 hrs now as well. Looks like installing the proprietary ATI driver did the trick.

Thanks for your help!!

You’re most welcomed! Enjoy :slight_smile:


I don’t know if it’s ok, but instead of opening another thread, I post on this thread. Tell me if you prefer I open a new one.

I noticed that I have the same problem with my laptop. It seems to run hotter than in Mandriva or Windows.

Laptop : Acer Aspire 8930, with oS 11.2

Here’s the reading :

daax@linux-q26h:~> sensors
Adapter: Virtual device
temp1:       +40.0°C  (crit = +106.0°C)
temp2:       +62.0°C  (crit = +106.0°C)
temp3:       +63.0°C  (crit = +106.0°C)
temp4:       +42.0°C  (crit = +106.0°C)
Cn                Résidence moy.      P-states (fréquences)
C0 (CPU en activité)   (10,0%)          2,00 GHz     3,6%
polling           0,0ms ( 0,0%)         1,60 GHz     0,3%
C1 mwait          0,1ms ( 0,1%)         1200 MHz     0,5%
C4 mwait          1,9ms (89,9%)          800 MHz    95,7%

Réveils depuis l'état de repos par seconde :  486,8     intervalle : 10,0s
Pas d'estimation ACPI disponible pour la consommation électrique

Principales causes de réveils :
  40,2% (344,3)   <cœur du noyau> : hrtimer_start_range_ns (tick_sched_timer)
  16,1% (137,8)      npviewer.bin : hrtimer_start_range_ns (hrtimer_wakeup)
  11,9% (102,1)      <IPI noyau> : Rescheduling interrupts
   7,1% ( 60,7)    <interruption> : uhci_hcd:usb3, uhci_hcd:usb7, nvidia
   6,8% ( 57,9)   Périphérique USB  6-2 : Microsoft® Nano Transceiver v1.0 (Microsoft)
   4,7% ( 40,1)    <interruption> : ehci_hcd:usb1, uhci_hcd:usb6
   3,3% ( 28,7)    <interruption> : iwlagn
   2,2% ( 18,9)            chrome : ep_poll (process_timeout)
   1,7% ( 14,6)            chrome : hrtimer_start_range_ns (hrtimer_wakeup)

It seems for me that I have 2 temp that are running somewhat very hot. Wath is it doc?