Laptop overheating

Hi everyone, I have a HP 425 laptop and im using 12.2 with KDE 4.8.4 (I use 12.2 cause i need the ati drivers and with 12.3 I couldn’t install it, but that not the point), the normal temperature is 65° C or 150°F, I use a conservative mode with cpufreq with this lines:

linux-yu6p:/home/mauricio # cpufreq-set -g conservative
linux-yu6p:/home/mauricio # cpufreq-set --cpu 1 -g conservative

I realized that the fans are always at constant speeds, so I try install fancontrol, and I think thats maybe one problem because my laptop get overheating, now, check this:

sensors:

linux-yu6p:/home/mauricio # sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +65.5°C (crit = +108.0°C)
temp2: +30.0°C (crit = +108.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +65.5°C (high = +70.0°C)
(crit = +100.0°C, hyst = +95.0°C)

sensors-detect:

linux-yu6p:/home/mauricio # sensors-detect

sensors-detect revision 6031 (2012-03-07 17:14:01 +0100)

System: Hewlett-Packard HP 425 (laptop)

Board: Hewlett-Packard 1475

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you’re doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): y
Module cpuid loaded successfully.
Silicon Integrated Systems SIS5595… No
VIA VT82C686 Integrated Sensors… No
VIA VT8231 Integrated Sensors… No
AMD K8 thermal sensors… No
AMD Family 10h thermal sensors… Success!
(driver `k10temp’)
AMD Family 11h thermal sensors… No
AMD Family 12h and 14h thermal sensors… No
AMD Family 15h thermal sensors… No
AMD Family 15h power sensors… No
Intel digital thermal sensor… No
Intel AMB FB-DIMM thermal sensor… No
VIA C7 thermal sensor… No
VIA Nano thermal sensor… No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): y
Probing for Super-I/O at 0x2e/0x2f
Trying family National Semiconductor/ITE'... No Trying family SMSC’… Yes
Found SMSC FDC37B72x Super IO' (no hardware monitoring capabilities) Probing for Super-I/O at 0x4e/0x4f Trying family National Semiconductor/ITE’… No
Trying family SMSC'... No Trying family VIA/Winbond/Nuvoton/Fintek’… No
Trying family `ITE’… No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no): y
Probing for National Semiconductor LM78' at 0x290... No Probing for National Semiconductor LM79’ at 0x290… No
Probing for Winbond W83781D' at 0x290... No Probing for Winbond W83782D’ at 0x290… No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): y
Using driver `i2c-piix4’ for device 0000:00:14.0: ATI Technologies Inc SB600/SB700/SB800 SMBus
Module i2c-dev loaded successfully.

Next adapter: Radeon i2c bit bus 0x90 (i2c-0)
Do you want to scan it? (YES/no/selectively): y

Next adapter: Radeon i2c bit bus 0x91 (i2c-1)
Do you want to scan it? (YES/no/selectively): y
Client found at address 0x50
Probing for Analog Devices ADM1033'... No Probing for Analog Devices ADM1034’… No
Probing for SPD EEPROM'... No Probing for EDID EEPROM’… Yes
(confidence 8, not a hardware monitoring chip)

Next adapter: Radeon i2c bit bus 0x92 (i2c-2)
Do you want to scan it? (YES/no/selectively): y

Next adapter: Radeon i2c bit bus 0x93 (i2c-3)
Do you want to scan it? (YES/no/selectively): y
y
Next adapter: Radeon i2c bit bus 0x14 (i2c-4)
Do you want to scan it? (YES/no/selectively): y

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `k10temp’ (autoloaded):

  • Chip `AMD Family 10h thermal sensors’ (confidence: 9)

No modules to load, skipping modules configuration.

Unloading i2c-dev… OK
Unloading cpuid… OK

pwmconfig:

linux-yu6p:/home/mauricio # pwmconfig --help

pwmconfig revision 5857 (2010-08-22)

This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

fancontrol:

linux-yu6p:/home/mauricio # fancontrol
Loading configuration from /etc/fancontrol …
Error: Can’t read configuration file

so my friends what i can do to make fancontrol works or get more speed for my fans?

Thank you for read.

Mauricio.

On 03/28/2013 09:26 PM, Mauriciog87 wrote:
>
>> linux-yu6p:/home/mauricio # cpufreq-set -g conservative
>> linux-yu6p:/home/mauricio # cpufreq-set --cpu 1 -g conservative

see my sig caveat, first!

i suggest you have a look at this script:
http://forums.opensuse.org/blogs/jdmcdaniel3/c-f-u-cpu-frequency-utilitiy-version-1-10-use-cpufrequtils-package-40/

it may help you set a still useful but lower power using setting…

plus: if you have not cleaned out all the dust and stuff in while you
should consider doing that. NOTE: if you don’t know how to do that
correctly, wait until you find the instructions on the HP site!

and, i have no idea how old that machine is but if it is more than
two or three years old it may need the thermal grease removed and
replaced…


dd
http://tinyurl.com/DD-Caveat

On 03/28/2013 09:26 PM, Mauriciog87 wrote:
> the normal temperature is 65°

by the way (i forgot to mention): there is nothing wrong with 65!! it
is WELL below the max for that chip…so ???

so:

If it ain’t broke, don’t fix it!


dd

Hi everyone,

I have similar problem with overheating: after max 30 min of Internet video my laptop shuts down.
I have installed yast2 power-manager and set it for “powersave”, I have c.f.u. set “ondemand” and I have a laptop cooling pad. One week ago I have had Win 7 running on this laptop and there was no problem with overheating so probably the fan is ok (I mean dust).

Can someone advise me what is wrong with my laptop? Below is my lsmod

roman@linux-zf5d:~> lsmodModule Size Used by
fuse 80536 3
michael_mic 12541 8
arc4 12544 4
ecb 12712 0
af_packet 30862 4
bnep 18957 2
bluetooth 303274 7 bnep
cpufreq_conservative 13526 0
cpufreq_userspace 12974 0
cpufreq_powersave 12555 0
snd_hda_codec_hdmi 36052 1
snd_hda_codec_realtek 71841 1
uvcvideo 75337 0
videobuf2_core 34625 1 uvcvideo
videodev 108056 2 uvcvideo,videobuf2_core
videobuf2_vmalloc 12885 1 uvcvideo
videobuf2_memops 13405 1 videobuf2_vmalloc
snd_hda_intel 32794 3
snd_hda_codec 128773 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13273 1 snd_hda_codec
snd_pcm 97617 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq 63595 0
snd_timer 24319 2 snd_pcm,snd_seq
snd_seq_device 14138 1 snd_seq
snd 70562 15 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
lib80211_crypt_tkip 17457 0
acpi_cpufreq 18940 1
wl 2446944 0
mperf 12604 1 acpi_cpufreq
coretemp 13162 0
ideapad_laptop 18019 0
acer_wmi 27657 0
sparse_keymap 13659 2 ideapad_laptop,acer_wmi
pcspkr 12631 0
sr_mod 21873 0
joydev 17098 0
i2c_i801 21997 0
cdrom 41399 1 sr_mod
ac 12957 0
microcode 22863 0
battery 18329 0
iTCO_wdt 13257 0
iTCO_vendor_support 13503 1 iTCO_wdt
rfkill 25445 5 bluetooth,ideapad_laptop,acer_wmi
soundcore 14600 1 snd
lpc_ich 16926 0
snd_page_alloc 14231 2 snd_hda_intel,snd_pcm
mfd_core 13236 1 lpc_ich
intel_ips 18022 0
atl1c 40850 0
mei 72655 0
sg 35712 0
autofs4 37366 2
thermal 18248 0
nouveau 893245 1
i915 549121 3
ttm 74171 1 nouveau
drm_kms_helper 45273 2 nouveau,i915
processor 43522 1 acpi_cpufreq
drm 247868 7 nouveau,i915,ttm,drm_kms_helper
mxm_wmi 12894 1 nouveau
i2c_algo_bit 13198 2 nouveau,i915
wmi 18591 3 acer_wmi,nouveau,mxm_wmi
video 18889 3 acer_wmi,nouveau,i915
button 13665 2 nouveau,i915
thermal_sys 24245 3 thermal,processor,video
scsi_dh_alua 16973 0
scsi_dh_hp_sw 12746 0
scsi_dh_rdac 17172 0
scsi_dh_emc 17062 0
scsi_dh 14428 4 scsi_dh_alua,scsi_dh_hp_sw,scsi_dh_rdac,scsi_dh_emc

On 03/29/2013 07:36 PM, rhinka wrote:
> One week ago I
> have had Win 7 running on this laptop and there was no problem

you could help us help you by making it so we have to guess less, i
wonder:

-what operating system and version you are using?

-if you are using a desktop environment, which is it and what version?

before you try anything below, please read my sig caveat

-you selected “powersave” in YaST > Power Management, does anything
change if you select “Default” or any of the other settings (i do not
know, changing there may require a reboot)

-have you used YaST Software Management to install ‘sensors’? and if
you have or do, can you then monitor CPU temperature with a desktop
widget? i’d you to do that (just so you can see the temp) before you
add any of the following (at the first green screen) during boot add
ONE of the following to the “Boot Options” line:


acpi_osi=Linux
acpi=force
acpi_os_name=="Microsoft Windows"
apm=on
pcie_aspm=force

NOTE: only add -one- of those during the boot–test it and see if the
temperature is better controlled, if not then next boot try the next
option…try them in the order given

please show us the terminal output and input, as well as the
beginning prompt and exit prompt, from


acpi -tci
uname -a
lsb_release -sircd

copy/paste the in/output back to this thread using the instructions
here: http://goo.gl/i3wnr


dd
http://tinyurl.com/DD-Caveat

Hi,

here is the output of the command

linux-zf5d:/home/roman # acpi -tciIf 'acpi' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf acpi
linux-zf5d:/home/roman # uname -a
Linux linux-zf5d.site 3.7.10-1.1-desktop #1 SMP PREEMPT Thu Feb 28 15:06:29 UTC 2013 (82d3f21) i686 i686 i386 GNU/Linux
linux-zf5d:/home/roman # lsb_release -sircd
openSUSE project "openSUSE 12.3 (i586)" 12.3 Dartmouth

I have KDE 4.10.00 release 1.

I have also installed lm-sensors

linux-zf5d:/home/roman # sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +47.0°C  (crit = +86.0°C)
temp2:        +45.0°C  (crit = +85.0°C)


nouveau-pci-0200
Adapter: PCI adapter
temp1:        +55.0°C  (high = +95.0°C, crit = +105.0°C)


coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +48.0°C  (high = +80.0°C, crit = +90.0°C)
Core 2:       +42.0°C  (high = +80.0°C, crit = +90.0°C)



this is very strange!

Five things:

  1. did you try using any of the boot options? if not, why not? did
    none make it better?

  2. please on next boot from power off:
    -log into kde
    -open a user konsole, xterm, etc
    -run the following commands


/usr/bin/acpi -tic
cat /proc/cpuinfo | grep -i 'model name'
cat /proc/cpuinfo | grep -i 'cpu mhz'

-return the input/output to here inside code tags

  1. please tell us more about your laptop:
    -maker and model number?
    -did you buy the machine new, or used/refurbished?
    -how long ago did you purchase the machine?
    -do you live in a high dust or high polution environment?
    -one (or more?) smokers in the house
    -fry food without a venting steam to the outside?
    -heat with open flame (soot accumulation on (say) surfaces is rapid)

i am a little surprised by the rather low reported critical
temperature in your


temp1:        +47.0°C  (crit = +86.0°C)
temp2:        +45.0°C  (crit = +85.0°C)

  1. do the high temp shutdowns stop if you turn off all desktop
    effects [go Personal Settings - Configure Desktop > Workspace
    Appearance and Behavior > Desktop Effects > General (tab), single
    left click the box just to the left of “Enable desktop effects” then
    click the “Apply” button]

  2. is the laptop sitting on a hard surface so that no air vents on
    the bottom or sides are blocked in any way?


dd
http://tinyurl.com/DD-Caveat

Hi,

  1. I tried the first boot option acpi_isi=Linux (i needed to google aroud a bit how to do it), configured power management for default, set CFU at Conservative, cleaned the fans with vacuum cleaner (I did not risk to remove back cover of my Lenovo b560), and my laptop even managed to back up and run video without cooling pad and without overheating. However internet video without cooling pad is still a problem. Oo you think I should experiment with other boot options? How can i make the boot option permanent?

  2. here the output of the commands:

linux-zf5d:/home/roman # /usr/bin/acpi -tic
bash: /usr/bin/acpi: No such file or directory
linux-zf5d:/home/roman # cat /proc/cpuinfo | grep -i 'model name'
model name      : Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz
model name      : Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz
linux-zf5d:/home/roman # cat /proc/cpuinfo | grep -i 'cpu mhz'
cpu MHz         : 1999.000
cpu MHz         : 1999.000

  1. I use Lenovo B560 since April 2011. It has Nvidia and Intel shared video card. Windows used primarily Intel.
    Environement is a bit dusty.
  2. I will test the performance without desktop effects.
  3. Now I put my laptop on cooling pad so that fan are in now way blocked.

> model name : Intel(R) Pentium(R) CPU P6100 @ 2.00GHz
> linux-zf5d:/home/roman # cat /proc/cpuinfo | grep -i ‘cpu mhz’
> cpu MHz : 1999.000

i see your CPU is running at full speed…there is a kde widget
(named “CpuFreqDisplay” on my version) which will run on your KDE
desktop and allow you to easily see if your CPU is scaling back when
full speed is not required…

if yours is not shifting to a lower speed i’d say you have something
set wrongly… maybe start by resetting that YaST power management
back to “powersave”

additionally there is a program which can be installed with YaST
named powertop <i’ll leave it to you to figure out how to use
it–there are instructions somewhere>, and if you search on “laptop”
you might find two patterns:
patterns-openSUSE-kde4_laptop
patterns-openSUSE-laptop

btw, you are smart to not remove the back of your laptop…


dd
http://tinyurl.com/DD-Caveat

On 2013-03-30 16:25, dd wrote:

> 5. is the laptop sitting on a hard surface so that no air vents on the
> bottom or sides are blocked in any way?

I put my laptop on small woodblocks or something to raise it up a bit
and increase ventilation. It works.

I would like to get one of those cooling platforms (my cpu is cool
enough, but the hard disks and memory banks are not), but I don’t like
that they are all powered directly from the USB bus. I have thought of
tinkering with wood and tools to make my own platform, but I’m lazy with
the saw and glue.

Now that I think! I can buy any platform and make an independent power
supply. 5 volts is not as easy to find ready made and cheap as 6 volts,
but I can do it myself.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Do you have an ATI/radeon video chipset? I have had this problem for a long time with a number of laptops (Dell, Samsung) with Radeon HD video. I think I even fried a hard disk with the temp running so high. My previous fix was to install the proprietary driver: https://en.opensuse.org/SDB:AMD_fglrx

I recently installed opensuse 13.1 and could not get the above to work - kept getting either a black screen or X just wouldn’t load. Finally stumbled on a fix - add: radeon.dpm=1 to the grub bootline. That completely fixed the issue. Try it at boot first:

hit e when you see the grub boot selection screen come up.

find the line starting with linux (usually has splash=silent quiet ) Go to the end and add the radeon.dpm=1, then CTRL-X to boot with that.

If that works, edit that same line in /etc/defaults/grub (be sure to run grub2-mkconfig -o /boot/grub2/grub.cfg afterwards)

This may reduce performance: Kernel 3.11 + radeon.dpm=1 results in extremely slow performance

This doesn’t worry me as I don’t do graphics intensive stuff…