laptop not waking up after lifting lid

Hi,
I guess this is the place to ask. I just made a fresh install of tumbleweed on this laptop about a week ago. I configured it to “Sleep” when I close the lid, but whenever I lift the lid the screen remains dark without pointer and the system is unresponsive. To use back the machine I have to hard-shutdown it by pressing the on-off button. I do not know how to fix this. I’m using a del 5575:

Operating System: openSUSE Tumbleweed 20191128
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.1
Kernel Version: 5.3.12-1-default
OS Type: 64-bit
Processors: 8 × AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Memory: 7,4 GiB

Can you help me? Thanks

What does the following report?

cat /proc/acpi/wakeup

Also check the power management settings in the UEFI BIOS perhaps.

Hi, and thanks for your reply
I get this:

$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
GPP0      S4    *disabled
GPP1      S4    *disabled
GPP2      S4    *disabled
GPP3      S4    *disabled
GPP4      S4    *disabled
GPP5      S4    *enabled   pci:0000:00:01.6
GPP6      S4    *enabled   pci:0000:00:01.7
GP17      S4    *enabled   pci:0000:00:08.1
XHC0      S4    *enabled   pci:0000:03:00.3
XHC1      S4    *enabled   pci:0000:03:00.4
GP18      S4    *enabled   pci:0000:00:08.2

Does this help?
Thanks

Hi, thank you for your reply

Could you, please, tell me what I should look for? Is there a command that “reads” these settings without entering the BIOS?
Thanks

I would expect to see LID, LID0, or a similar device designator. As well as this, the S4 sleep state represents ‘suspend to disk’ (or hibernate). This state is the lowest power sleep state supported by ACPI. Suspend to RAM corresponds to the ACPI S3 state.

Are you not able to check the UEFI BIOS configuration?

FWIW, I did find a Dell discussion descrbing the lack of an S3 state with modern Dell BIOS ‘affecting’ some models…

I’m not sure if this is what is impacting your situation.

Here’s a MS artcle describing Modern Standby vs S3…

Hopefully, others can chime in to clarify further here.

More anecdotal discussion around this…

This is short on details. So here are some more: since S0 ( active suspend) became more popular with windows 10, most manufacturers have decided to REMOVE THE CODE from the bios that allows S3 (suspend to ram).Worst case is they left the stubs pretending S3 is supported, so the computer goes to sleep - but never wakes up! Dell, I’m looking at you!!
Workarounds come from redoing the S3 code, mostly in ACPI tables with triggers - for all peripherals.
It is a shame, as in S3 most laptops eat less that 1% of the battery per hour, while in S0 such good results require heavy configuration to prevent the “active” part of active sleep, and make sure the laptop never wakes up until you actually press on the power button. But I guess it is the road to progress, as S0 is more flexible.

A Question: Does pressing the power button wake your Dell Inspiron up from a sleep state?
https://www.dell.com/community/Inspiron/Not-waking-from-sleep/td-p/6244831

Hi,
No, pressing the button does nothing.

Ok, all I can recommend is checking/updating BIOS…

Dell BIOS and Power_Options_Settings

Hi, it looks like sleep is broken on ryzens. You can put it to sleep, but it never wakes up. I experience this on my desktop pc with ryzen 2400g too and I have bios few months old. So I don’t sleep it, I turn it on or off, with nvme disk it boots quite quickly. Have you tried hibernate?

Hi, Thanks for your reply.
In this machine I dual boot W10 and Tumbleweed. In W10 closing the lid and sleep works as expected. Nontheless, I updated the BIOS as you suggested, and these two days I’ve been “testing”. I put “secure-boot” in the BIOS, and changed to hibernate when closing the lid. I get the same result: the machine doesnot wake up. I also checked the machine following Dell’s technical support and everything is ok. I mean, the machine is one month old…
Am I missing something? Thanks

Hi, thank you very much for your reply.
The strange point is that the machine sleeps and wakes up, as expected, when I use W10. So I think I’m missing something here in Tumbleweed. Any idea will be more then welcome.
Thanks

It may be that a bug report is required, but FWIW I did find the following threads which discuss possible workarounds that may be worth investigating further…

https://forum.manjaro.org/t/dell-inspiron-15-5585-not-waking-from-suspend/105191/3

In order to fix the issue, I added these kernel parameters to my bootloader:
acpi_rev_override=1 acpi_osi=Linux mem_sleep_default=deep

https://forum.manjaro.org/t/lenovo-laptop-wont-resume-after-sleep/105233/10
*Disabling the KDE compositor apparently has led to a working suspend/resume, although it’s not clear to me why that might be. In any case, easy enough to test on the fly with

qdbus org.kde.KWin /Compositor suspend

or Shift+Alt+F12 (toggles on/off)
then try suspending again.

s

Hi,
I’ve been testing the sleep and hibernate modes and my lap continues without waking up. I wonder if this is a kernel issue. In one of these tests I used CTRL + ALT + F2 and got the command line. I wrote: ‘startx’
and appeared the message:


xinit failed.  /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust  /etc/permissions.local and run  "chkstat  --system  --set" afterwards

Can you help me on this?

Hi,
In case it helps somebody I found a solution in Dell’s community forum. The recommendation is to install:

laptop-mode-tools 1.72.2-4

You download this package in this link:

https://aur.archlinux.org/packages/laptop-mode-tools/

You find all the information in these two links:

https://wiki.archlinux.org/index.php/Power_management

https://wiki.archlinux.org/index.php/Laptop_Mode_Tools

The package also contains information on how to configure the tools.

Best wishes from México!