laptop not connected to network all the time Tumbleweeds latest greatest.

This may be a unique problem but it is my problem.

My laptop is rarely connected to a internet connection and the software updates is throwing a connection error quite often.

How can i make the software updater only active when connected so i don’t get the errors constantly?

I only use the updater to see theres updates when the internet connection is active but use zypper in a konsole to do the actuall updateing.

Your post includes your probable issue: as per documentation you should not use the updater or YaST, but only ‘zypper dup’ to update Tumbleweed. This due to Tw’s nature, it gets released over and over again. Running anything but ‘zypper dup’ will definitely bork your system one way or another.
So, first run ‘zypper dup’ and disable the updater.

If you are using gnome:
Disables notifications
gsettings set org.gnome.software download-updates false
Disables the use of package updater
gsettings set org.gnome.software allow-updates false

I agree zypper dup is the best way to update and is how i do so.

Just how can i disable the updater that gets placed in the sys tray? There is no obvious way to do so.

Right click on the system tray (bottom right of your screen) and remove it (software update).

Doh, it’s as simple as that lol and here i was searching for a box to check and turn it off!

Thanks now to mark this as solved :slight_smile: