Laptop keys on Inspiron 6400


Just installed OpenSuSE 11.0 over my old 10.3 distribution on an inspiron 6400 and found a pretty annoying problem straight away.

The function keys, as well as the face keys for controlling audio volume and whatnot, are now now longer working.

Previously, pressing the mute key on the front of the laptop would result in a naff looking popup telling me that the audio was muted. Now it does nothing :frowning:

Any suggestions?


Install Keytouch and setup.

Thanks, I will try that this evening.

The only concern I have is that my laptops function key, which is used to change screen brightness, enable/disable the wifi killswitch/eject the dvd etc, is not being picked up when pressed.

I ran xev and found that all the laptops media buttons fire the correct signal, but the function key doesn’t see to be captured at all.

This is a big issue as without the use of the function button, my laptop is pretty much tied to ethernet for net connection and has brightness set to maximum.

There are sevelar kernel modules, like omnibook-kmp or acerhk-kmp that enable special laptop keys for several models.
Maybe one of those might help you.

Right, this is getting beyond a joke.

I have installed and configured keytouch and when starting the daemon manually can finally use the media keys on the Inspiron 6400. However, when I restart X the keytouch daemon fails to start properly and I am back to not having the use of media keys.

Also, I have installed kmilo for kde but cannot work out how to get the thing to run :frowning:

To compound these problems, my function keys for enabling/disabling the wireless killswitch are still not working. I couldn’t get them to work using keytouch at all.

This last issue is really annoying me as I really need to use wireless on the commute to/from work.

Any suggestions would be greatly appreciated.