Laptop has no sound

Hello, I am running SUSE 11 on a Toshiba Satellite M45-S625. I recently did a fresh install and everything else appears to working fine expect for the sound. I have checked all the sound mixers that I know of and made sure that they were not muted. I used YaST to view the sound options,and it appears as though I have an Intel AC’97 audio card. from what I understand I do believe that that is a generic card. Any help would be appreciated thanks in advance. :smiley:

Right click the volume applet in the task bar and select Preferences. Select PCM and close. Left click the volume applet and check to see if the volume is all the way up. Repeat for Master as well.

If acron1’s suggestion does not work for you, then try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

In particular, pay attention to the YaST > Hardware > Sound recommendation.

Thanks for the advice however I have done both suggestions previously. Here is the strange thing sometimes my sound works and sometimes it does not. I know that it works because it came on once. It even went as far as to play a test sound in Yast. I know the hardware is fine. :confused:

There is typically a cause and effect. In order to understand a problem, and fix it, at least in my case, I need to understand the relationship between cause, and affect. I find it a waste of time to try and deal with generalities without quantifying what is happening.

I don’t know if I can help, but I am willing to try, but to do so, you will need to provide more information, so I can try and setup a “cause and affect” assessment.

Can you start by copying and pasting into a gnome-terminal or konsole (while your laptop is connected to the internet) the following script:

wget && su -c 'bash ./tsalsa' 

and when prompted for a password, enter your root password. That script will create a URL and pass it to you when complete. Please post that URL here.

Please also copy into a gnome-terminal or konsole, one line at a time and post the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

are you using KDE-3.5.x ? KDE-4.x.x ? or Gnome?

You are absolutely right its hard to troubleshoot with out information. Here is the contents of the alsa url:

wget && su -c 'bash ./tsalsa'

The following are the out outputs of the requested commands:

rpm -qa | grep alsa


rpm -qa | grep pulse


rpm -q lisound2

package lisound2 is not installed

uname -alinux-od7x:~ # 

Linux linux-od7x #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

I am using KDE 3.5

Ahh … can you try that again? You just parroted back what I posted. :slight_smile:

Please, can you try this again? You made a syntax error. The command is:
rpm -q libasound2

Sorry here is the correct outputs:
rpm -q libasound2

Thanks! That script output for “alsa-utils” does not appear to match what you provided earlier, which was:

rpm -qa | grep alsa


Still, that may (or may not) be important.

First, I recommend you install alsa-firmware and alsa-tools (from a gnome-terminal / konsole) with your pc connected to the internet:
su -c 'zypper install alsa-firmware alsa-tools’
and then reboot your PC. Check your sound then. Any luck?

If that doesn’t work, then in case your alsa packages are mixed, I think the easiest way to proceed is for you to update all of your alsa to the latest 1.0.17 by opening a gnome-terminal / konsole, type “su” to get root permissions, and then copy and paste the following six lines and execute them in order, one after another (while your pc is connected to the internet):

zypper ar multimedia
zypper install alsa alsa-utils alsa-oss alsa-tools alsa-devel alsa-firmware alsa-plugins libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

then restart your PC and test your sound. If that does not work, then please run the script again and paste here the new output URL.

wget && su -c 'bash ./tsalsa' 

and also in this case, if sound does not work, in addition to runnng the diagnostic script, immediately after booting open a gnome-terminal / konsole and run:
dmesg > dmesg.txt
then open dmesg.txt with a text editor and paste the output to general pastebin - simplified internet collaboration and post the URL here.

For the: su -c ‘zypper install alsa-firmware alsa-tools’
I get the following error:

Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000003: No medium found (mount: No medium found)

Abort, retry, ignore? [A/r/i]:

Should I proceed to your second suggestion or do I need to resolve this first?

Perhaps you could try the zypper install again after putting your install DVD into the drive and waiting for it to mount.

thanks for pointing out my stupidity.:frowning:

No worries - we tend to start overlooking to obvious when frustration hits a certain point. Especially when we are trying to deal with something a bit outside of our usual experience.

Just the other night it took me a half hour and three goes through the sax2 commands needed to get the radeon drivers going to realize that sax2 wasn’t correctly picking my monitor when I turned on 3d acceleration and got a choppy, messed up display. Not like the monitor selection wasn’t in large font right below the video card selection (that I verified was correct each time) or anything. :doh:

The difference between command line and gui admin is that the command line assumes you know what you’re doing and only very, very rarely tells you otherwise. The gui assumes you’re a complete moron and isn’t afraid to tell you about it. :slight_smile:

I agree, sadly still no sound. I know that it is something do with the drivers I just can seem to get the right ones.

Here is the pasebin url:

Thanks. Your Toshiba M45-265 has an AD1981B at irq 10.

Could you please confirm you now have alsa-firmware installed?

The tsalsa script notes you have an “external amp” switched ON. Sometimes that can block a laptop’s sound. How about switching that OFF? Then try your sound. If not luck, then with the external amp OFF, then in a gnome-terminal / konsole restart alsa with “rcalsasound restart

Reference your dmesg, I note this:

# handlers:
# <e05f0fd1>] (usb_hcd_irq+0x0/0x7d [usbcore])
# <e05f0fd1>] (usb_hcd_irq+0x0/0x7d [usbcore])
# <e0866c50>] (snd_intel8x0_interrupt+0x0/0x1e6 [snd_intel8x0])
# Disabling IRQ #10
# intel8x0_measure_ac97_clock: measured 54988 usecs
# intel8x0: clocking to 48000 

I find that strange. It notes it is disabling IRQ 10, but thats the IRQ that your sound driver is located on? It makes me even more curious if the “rcalsasound restart” will work.

Also, you could try a custom model assignment in your /etc/modprobe.d/sound file. I could not find a listing for the AD1981B, but I did find this for the AD1981 in the ALSA-Configuration.txt file:

	  basic		3-jack (default)
	  hp		HP nx6320
	  thinkpad	Lenovo Thinkpad T60/X60/Z60
	  toshiba	Toshiba U205 

Hence if the above fails, you could change your /etc/modprobe.d/sound file to be:

**alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0 enable=1 model=toshiba
alias sound-slot-0 snd-intel8x0 **

save the change and restart your alsa with root permissions with rcalsasound restart

and if that does not work, try basic, thinkpad, and hp in place of toshiba (one at a time, restarting alsa for each attempt).

and if that fails go back into YAST > Hardware > Sound and try again. If that fails, post your /etc/modprobe.d/sound file again before you try anything else (note YaST > Hardware > Sound will change the /etc/modprobe.d/sound file to a custom configuration).

The only problem is that I dont think that I have any external sound devices. The only thing that I can see that is physically on is the wireless. I will try the things suggested.

The External Amp is an internal mixer setting. Please go look for it.

Ok so I did find the external amp and muted it tried sound with it off. Then rebooted alsa and still no sound. I am going to edit the sound file now. I am assuming that I can clear whats in there. When you say do a custom model config where do I do that. Is that done in the sound file as well ?

As I asked previous, could you please confirm you now have alsa-firmware installed? Simply type:
rpm -q alsa-firmware

If you compare your original /etc/modprobe.d/sound file:

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0  

to the one I proposed based on ALSA-Configuration.txt:

alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0 enable=1 model=toshiba
alias sound-slot-0 snd-intel8x0  

you will see all that I did was add a line into the middle of the file.

Note the line I added has “model=toshiba” at the end. Don’t forget you MUST restart alsa after saving a change to that file. You could try different configurations of that file, replacing “toshiba” with “thinkpad” … restart alsa, etc … (ie remainder of the file remains the same).

Note also, when testing you sound, use a simple test. Don’t try to play an mp3 file. Do the sound test recommended in the audio troubleshooting guide (copy and paste this):
** speaker-test -Dplug:front -c2 -l5 -twav**

The “-l5” will command 5 iterations of a female voice saying “left/right”. “-l2” would command two iterations instead.