Laptop hangs with opensuse 11.3

Hi… I’m not very familiar to linux … I recently installed openSUSE 11.3 on my dell vostro 1500 laptop and the system gets hung every now and then… and most often when I launch a new application. I have no other option other than switching the power off manually but interestingly the mouse will respond all the while despite any response form the screen. Earlier I’ve tried opensuse 11.0 and things were fine then. Do you have any solutions to offer plzzz

Does your Dell Vostro 1500 have NVIDIA Geforce 8400M graphics ? If so, do you have a 32-bit openSUSE-11.3 KDE4 with the proprietary nVidia driver installed? If so, that could be your problem as there is an incompatibility with the proprietary nVidia (and 270.xx.xx.xx) driver and a 32-bit openSUSE-11.3 with KDE. You may need to roll back to the older nVidia 253.56.xx proprietary graphic driver. Take a look at post # 298 here: NVIDIA 260.19 Issues

No… it has an Intel HD adapter and I update the system almost daily thinking that there would be patch available.

I have Intel too but no issues from a default install
Check Lee’s thread here: openSUSE Graphic Card Practical Theory Guide for Users

You might want to switch to the intellegacy driver

Its very difficult to provide any specific recommendations with no specific graphic hardware details. Intel have more than just one graphic HD adapter. General information unfortunately gets general responses.

Perhaps you could provide more detail as to the hardware? What is the output of:

/sbin/lspci -nnk 

and post here only (and all) the lines associated with the VGA/graphic hardware

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
Subsystem: Dell Device [1028:0228]
Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
Subsystem: Dell Device [1028:0228]

I hope this is what you asked for… the rest of the output I think is not related to the display.

Well I found out that sometimes I can do Alt+Ctrl+F3 and killall application_name but then again it would hang as soon as I open another application. This is possible only if the keyboard responds.

I hope its not a lack of memory as I have 2GB RAM and I’ve also assigned 2GB of swap. The memory monitor available in kde 4 has shown me only less than 900MB of memory usage uptill now.

Your memory is fine. 2GB is loads.
I’m not sure about the Intel chipset you have. It may be different to mine on my R61 laptop, but that works flawlessly.

It seems to me I recall reading that the GM965 works better with the older Intel-2.9.1 video driver, which is what one gets if they use the ‘intellegacy’ driver as noted by caf4926.

Did you try that suggestion? Do you need advice on how to select the intellegacy (2.9.1) video driver?

The “intellegacy” driver is provided by the package xorg-x11-driver-video-intel-legacy. That maybe already installed on your system, so make sure that it is.

To load “intellegacy” driver at startup, you should edit (as root) the file /etc/X11/xorg.conf.d/50-device.conf to add this line:

 Driver "intellegacy"

For example:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  Driver "intellegacy"


Save, and restart/reboot to load the new driver.

You can verify the change of driver to “intellegacy” in /var/log/Xorg.0.log

I just tried out the code “consused” has posted above. It looks as though “intellegacy” is in use as i can see a lot of entries starting with intellegacy in /var/log/Xorg.0.log.

But that haven’t solved the problem. Should I try the exact driver oldcpu suggested and if so please tell me how to do it.

How about instead copying the content of /var/log/Xorg.0.log to SUSE Paste and press create, and post here the URL it provides so that we can look at it and hopefully have a better chance of making a knowledgeable recommendation as opposed to simple speculation?

Hi I’ve upgraded to KDE 4.5 and my desktop froze a couple of times when I tried to apply some Desktop Configurations. The old problem still remains…

Done… its at SUSE Paste >:)

I note this error (which does not look good):

  1699.272] [mi] EQ overflowing. The server is probably stuck in an infinite loop. 

IMHO you need to write a bug report on this. There is guidance here: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE forum username and password when logging on to bugzilla.

Yes, and IMO you should also obtain the /var/log/Xorg.0.log from running the standard “intel” driver and see if similar error message occurs. A bug raised against that driver should carry more weight and you will need to attach a copy of that log anyway. It’s also very likely that the “intellegacy” driver wouldn’t get fixed, as it is back level and probably not maintained.

To go back to the “intel” driver, you can either change the name in the Driver statement I gave you, or comment out the Driver statement with # character as shown here:

#Driver "intellegacy"

Save, and restart/reboot to load the new driver.

You can verify the change of driver to “intel” in /var/log/Xorg.0.log

I had problems with freezing on an HP-200-5220a computer under Ubuntu 10.10 and SuSE 11.3.

Try this thread - [ubuntu] New computer hangs on shutdown/reboot, how to troubleshoot? - Ubuntu Forums](

I used the code by “timgood” in the thread - my problem seems fixed now.



Hi Alan, I guess your’s was problem with a spooky wireless driver. I’m not using my wireless at all and my system freezes almost in the middle of anything not just when shutdown.

Anyways thanks for the suggestion !!!

Hi. Alan has suggested I blacklist a wrong wireless driver which solved his problem with ubuntu. Do you think I need to try it?

It probabily does not hurt to blacklist a wireless device, which is what is recommended by Alan in the Ubuntu link via

echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf 

but having stated that, I doubt that it will make any difference. The blacklisting can be easily removed later.

Hi melvin and others

I have used the computer extensively under Ubuntu and openSuSE and have had no further sporadic freezing since making the changes above. Nor does Ubuntu freeze when shutting down or rebooting.

I have never used the wireless on my computer but the driver would have been loaded by default and it was still freezing for no apparent reason several times each day under both Ubuntu and openSuSE.

As far as I can tell all problems are now solved on my computer through the suggestions made by “timgood” in the link I gave above.

Hope this can help others with similar freezing problems.