Laptop does not boot on battery

Hi there,

I am a new convert to openSUSE 11,1 from ubuntu 8.10 land, and on the whole I am enjoying suse and liking it a lot.

So far the only down side that I have found is that my laptop (hp G6000) refuses to boot properly when running on the battery.

Whenever it boots, either on mains or battery, early on in the boot process it hangs until I press the power button. It used to do this in ubuntu also and I think it has something to do with the snaptics touchpad… I would like to cure this but it aint no biggie.

However when running on battery the boot process repeatedly stalls. I have found if I keep pressing the power button everytime it stalls eventually it will boot into a terminal. I have also found it I hold in the return (enter) button then it will boot into KDE desktop, and then will run fine.

I searched the forums and the like, and found a tip about adding nohz=off into boot options in menu.1st

I did the following, I launched YaST, and selected the bootloader option, and edited the main bootloader, adding nohz=off to the end of it. However this has not made any difference, and the boot on battery still requires then return key to be held in.

Sorry if this problem is known, and my n00bish searching skills have not uncovered the answer…

Thanks for your Help

jonny

I wonder if your CMOS clock battery (button cell) is running low.

I had the same exact problem on a brand-new HP laptop running Suse 10.2. I solved it by just ensuring that I always booted on AC power instead of battery.

When I upgraded to 10.3, the problem mysteriously disappeared. I could boot on battery just fine. I’ve since upgraded to 11.1 (with KDE 3.59), and it still boots fine.

Weird. It acts like it’s some kind of strange, hard-to-trace critical race between startup scripts that only occurs when you’re on battery. My laptop (and I expect the original poster’s does, too) runs at a lower CPU clock when on battery.

I don’t think so… This was not an issue only a couple of days ago when running ubuntu, so it seems to me to be OS specific…

I had the same exact problem on a brand-new HP laptop running Suse 10.2. I solved it by just ensuring that I always booted on AC power instead of battery.

When I upgraded to 10.3, the problem mysteriously disappeared. I could boot on battery just fine. I’ve since upgraded to 11.1 (with KDE 3.59), and it still boots fine.

Weird. It acts like it’s some kind of strange, hard-to-trace critical race between startup scripts that only occurs when you’re on battery. My laptop (and I expect the original poster’s does, too) runs at a lower CPU clock when on battery.

So you are saying basically prayer is probably the best chance of fixing this? :stuck_out_tongue:
Joking aside, it must be possible to modify the boot process to not check to see if the laptop is running on battery or on mains… I hoped disabling the power management features may of done this, but made no difference, and as the battery monitor is still present then clearly there is more that can be disabled.

Thanks for your help, so far,

jonny

It’s maybe because of an unsupported ACPI System.
Try ACPI Kernel Parameters or a 32-Bit Version, if
you are using a 64-Bit once.

For more info check this thread

Cheers Zenny,

I am using 32bit (even tho I have 64bit processors), only because I have found over time that this is normally the safest bet in linux (well with ubuntu anyway)

I have read the info you linked, and have created a third boot option in menu.lst. adding the parameter acpi=off means the machine boots properly on battery, but obviously I loose the power management features…

Is there any way of finding exactly what is causing the issue, and resolve this, other than the complete disable option?

Other than power management issues is there any other issues that may arise when running with acpi=off for long periods?

In your opinion is it “better” to have to hold in the return key during boot and have power management, or have a properly booting system without power management?

Thanks again

Jonny

Of course, with “acpi=off” you’re deaktivating the whole ACPI in the kernel.

So try other options, that only deactivate parts of it like “pci=noapci” or “acpi=noirq”.
You have to try some or a combination.

I don’t know that exactly, but i think ACPI is just for Power Management.

Hi Zenny, you are a star…

I looked at all the options, and settled down to a long session of editing menu.lst, and trying each in turn and then combinations to see if I could zero in on my issue.

I tried “pci=noapci” and “acpi=noirq” (not being sure if I needed one or both to turn off acip on IRQ) and this was the very thing that has been a problem.

Machine booted without issue on battery (and shutdown again), and I have power management options, and battery monitoring functioning too! I would love to solve this by having the laptop work perfectly with acip, and clearly the issue lies in irq, but I do not know how to proceed (other than trying an bios upgrade).

If you can help further that would be great, but for now this is working fine.

What i meant by other issues with acip being off, was more me thinking about overheating and things like that…

Thanks again for all your help.

Jonny

Try adding:


acpi_osi=“Linux”***

…to the end of the boot line at the grub screen.

I have a HP dv6000 series and that helps with thermal limits and stuff, plus a few other interesting things that I’ve forgotten now :sarcastic:.

Type it exactly as seen with the quotes.

It’s a HP specific thing I think :).

BTW, if you want to experiment with kernel options, there’s no need to go through the cycle of editing menu.lst, reboot, etc. You can modify the options at the GRUB option box, deleting old options and entering new ones just for that boot. That way you only need to reboot, not edit menu.lst.

Cheers for that Growbag, I tried adding it to options in menu.lst, but on it’s own it did not cure the boot issue. I combined it with the other acpi/irc disabled options and it seems to boot ok, but no differently to with just acpi/irc disabled… although it may of made differences “under the hood” that are not apparent.

Thanks anyway mate

BTW, if you want to experiment with kernel options, there’s no need to go through the cycle of editing menu.lst, reboot, etc. You can modify the options at the GRUB option box, deleting old options and entering new ones just for that boot. That way you only need to reboot, not edit menu.lst.

I am aware of that, but I prefer (irrationally) to edit menu.lst, in the main coz the changes are persistently. I know it don’t make much sense but there you go.:stuck_out_tongue:

Thanks again Ken

It’s just more quickly, not to boot the whole system, to check if the params work.
You can add the options in GRUB, when it’s menu is shown at system boot up.
I think this is what Growbag has been trying to explain to you.

But each to his own :wink:

Yeah I get that totally…

exactly… just my quirky preference.

Thanks all for your help.

jonny

try using this option in boot options

noapci acpi=off