laptop built-in keyboard doesn't work

Hello, openSUSE forum comunity,

I seem to have stumbled into a bump today. I just bought me a A4Tech KL-5 usb keyboard and when I first plugged it in all worked well. Namely both - the usb one and the built in one - at the same time. That until a reboot. After the reboot neither the built in keyboard nor the touchpad seem to function and the caps lock and scroll lock LED’s are lightened up.

Out of pure coincidence the reboot after having plugged in my new keyboard was the reboot required after the kernel update from… the version that came with openSUSE 11.0 to Right, usually I’d be rolling back kernels to the previous one, but apparently opsnSUSE’s YaST deleted the old kernel after the update so I can’t check that. Shame…

My laptop is a Fujitsu(-Siemens) Amilo L1310G notebook with a 1,5GHz Celeron, 512 RAM, Ati Radeon x200M (with shared memory), internet access and runs openSUSE 11.0 .

Anyway, this isn’t really a problem for now since I have both functional keyboard and mouse, but I am interested if this is a hidden feature of yer current day linux kernel (the disabling of the internal keyboard in favour of the external one, I mean) or if anyone else suffered from this predicament ooooor if it’s a… what was it again? Oh yes, a bug.

But I am puzzled by the touchpad not working and the caps and scroll LED’s lighting up o_O’ .

I’ll be up with updates on whether the internal keyboard works if the usb one is not plugged in at boot time, but not right now, because I try to keep my reboots at a minimum.

(P.S. what’s with YaST deleting the previous version of the kernel on update? Sheesh, what if it wouldn’t have boot’d anymore?)


What an interesting situation, after a second consecutive hibernation (suspend to disk) everything works alright now. No reboot inbetween, no tinkering with anything. Weird…

Well, anyway, thank you forum comunity :slight_smile: I hope the rest of you get your problems solved so easily too just like I had myne, peace!