laptop Asus V1J with no sound under Open Suse 11.3

Dear Suse gurus,

I am newbie in Linux. I decided to start my Linux experience with Suse.
So here I am with my laptop Asus V1J and no sound.
I tried all the steps from:
SDB:Audio troubleshooting - openSUSE
and
SDB:Intel-HDA sound problems - openSUSE
and no success


Codecs:
==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices AD1986A

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

I could not paste here my whole alsa-info.txt. due to characters count limitations. In case it is really needed, please let me know.

Please, help!

greetings,
Ivo

Try to install alsamixer through yast. Then go to terminal and write alsamixer and increase the sound bars. I will try to find these drivers. Your sound card is…
And read this http://maketecheasier.com/setup-hdmi-digital-playback-in-linux/2011/01/05?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+MakeTechEasier+(Make+Tech+Easier)

With out that script output I can do no more than wildly speculate which is possibly a waste of your time and mine. Simply paste the script content on a paste site, such as SUSE Paste and press create and post here the URL.

Please also provide the other information requested to be provided from our multimedia stickie: Welcome to multimedia sub-area

Hi Stamostolias,

As I understand the description from the Sound (Hardware Information):
Device: 82801G (ICH7 Family) High Definition Audio Controller

and if I do in the root -> cat /proc/asound/cards, then I get the following:
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfebfc000 irq 32

greetings,
Ivo

???

what drivers ? openSUSE comes with ‘alsa’ as a kernel module which should be all the drivers that are needed. Suggesting using other drivers is IMHO misleading and very confusing to new users, and most likely not accurate.

May I suggest reading the following to become more acquainted with sound and Linux : SDB:Sound concepts - openSUSE in order to have a better understanding of Linux and sound.

Hi ivovin,

I invite you to follow what olcpu suggests. He is the sound guru here, follow his advice. :wink:

the required info can be found in:

http://www.alsa-project.org/db/?f=f9eeb67843ce208b91a20ebb9f03009bc756a3b1

rpm -qa ‘alsa
alsamixergui-0.9.0rc1-746.1.i586
alsa-firmware-1.0.23-1.2.noarch
alsa-plugins-1.0.23-1.9.i586
alsa-1.0.23-2.12.i586
alsa-oss-1.0.17-29.2.i586
alsa-utils-1.0.23-1.8.i586

rpm -qa ‘pulse
libxine1-pulse-1.1.18.1-1.37.i586
libpulse0-0.9.21-9.2.i586
libpulse-mainloop-glib0-0.9.21-9.2.i586

rpm -q libasound2
libasound2-1.0.23-2.12.i586

uname -a
Linux linux-yfre.site 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-hda-intel

u1Nb.Igk_bJzDER9:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

oldcpu, thanks for pointing me to the right places in the forum.

greetings,
Ivo

Thanks, looking at the script, and looking at the rpms, and the 50-sound.conf, it appears to me that your sound should be working (ie I checked the mixer settings). I note a 32-bit openSUSE-11.3 with the 2.6.34-12 kernel (ie not updated yet) with the stock 1.0.23 version of alsa and the AD1986a hardware audio codec (which you also noted in your initial post).

First, some basic questions … (sorry but I have to ask). What is your criteria for stating sound does not work? Try each of the following in a terminal, first as a regular user and then with root permissions and try it with headphones and with out headphones:

  • first:
 speaker-test -Dplug:front -c2 -l5 -twav
  • second, try again:
speaker-test -c2 -l5 -twav
  • third:
speaker-test -c2 -D hw:0,0 -t wav -l3
  • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
aplay -vv /usr/share/sounds/alsa/Front_*
  • fifth: and also:
aplay -vv /usr/share/sounds/alsa/test.wav

Do any of those give an indication of sound ?

If ANY of those give sound, then the problem is likely with codecs and desktop setup. IF you get NO sound from any of those, then the problem is likely with the alsa sound driver configuration.

That will help us focus our recommendations.

You could also try toggling the PC’s mixer’s external amp OFF and ON (which in the script has this):

'Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback **[on]**

My guess is “ON” is the correct setting, but I have read of cases where for some users it had to be “OFF” to work.

Sorry for that but I was thinking maybe sound card was not recognized.

speakers: all 5: no sound

headphones:
1: there is short burst of sound immediately after toggling Front Left , Fron Right and so on
2: same as 1
3: same as 1
4: the numbers are changing and I can hear from time to time sound coming through
5: very distorted sound is coming

all of the above happens when I am logged in as root and as a regular user

What is this ‘short burst of sound’ ? Is it a person saying FRONT LEFT ? FRONT RIGHT?

If so, then I’m thinking the problem you are encountering is a codec problem, and possibly a desktop configuration problem. In which case, we can provide guidance there. And in which case, are you a KDE or a GNOME user?

If it is just ‘noise’ then your problem is different.

it is noise

I am KDE user

wrt one of your previous suggestions to toggle off the external amplifier… I had the same sound problem in Ubuntu and turning this external amp off solved the problem there.

Would you please tell me where is the location/file where I can toggle the external amp?

Thanks and greetings, Ivo

In kde you can do that under kmixer.

Kmixer is the small speaker icon in the bottom right corner of your desktop. Left click on that and select ‘mixer’. That will bring up a ‘mixer window’. Now it is possible you may or may not yet see the external-amp control in your mixer window. If you do NOT see it, then in that mixer window go to Settings > Configure Channels and in the "Configure-Kmix’ window that you get, drag the external-amp control from left (available channels) to right (visible channels) and that will add the ‘external-amp’ control to your mixer.

YEEESSS, that did it… turning the External amplifier off (muted)

Thanks man for the great support and the patience.

greetings,
Ivo

Excellent !! Well done for your determination and patience.