Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

This started today, and I have done every thing I can to resolve it on my own.
NM hasn’t changed that I can tell.
Once when I tried to open NM, it opened a browser web page that said ‘you’ve succeeded your monthly limit, CLOSE this page’. I thought it was going to open my router page, but there was nothing in the URL box.
That only happened once, subsequently NM panel opened up along with a root PWD pop up. But as I said above NM settings appear to be as they were 2 days ago.

At a loss AGAIN. Any help and/or suggestions?
TIA
Bill_L

Strange. Have you tried restarting your router?

I very occasionally see the “Failed to Get Secrets” message on this laptop, never did find the cause. Always connects OK on second try: NetworkManager -> (choose connection) -> Connect. Very random, put it down to some race condition maybe.

Don’t know if this is related, but yesterday (18 Nov 2020) from around 14:00 UTC the entire openSUSE infrastructure appeared to be offline for a few hours. NetworkManager, unless you’ve disabled the feature, makes a “Connectivity Check” to http://conncheck.opensuse.org
if that fails it assumes you are behind some sort of captive portal with limited connectivity.

yeah, I experienced opensuse infrastructure being not available, 8AM CST to about 5PM CST. I didn’t know about the conncheck NM tries to do on start up.

Reboot router got me a ‘solid’ connection.
Oddly both laptops had/have this problem. None of the small devices exhibited connectivity problems.

However, both laptops are still getting the ‘failed to get secrets’ message, but a connection is made and that seems to come up after the WiFi connection has completed.

The thing about NM open a browser window with the message ‘ you have exceeded your monthly data usage CLOSE THIS WINDOW’ came up on one of the laptops again this morning.
I check my usage every couple of days with my provider, and I am no where near my limit.

perplexed I am!

Routers store some information in nonvolatile memory. This information will survive reboot. Disable the services in preferences and enable them again.

This is a screenshot of what happens on every PC we have, desktop, and laptops after a popup telling up We NEED to login in to Network Management.
When we click the ‘login’ button that comes up in the NM area, it brings up this browser window.
https://susepaste.org/22150223

I have rebooted the router a couple of times, yet this keeps happening!
AND I know I am nowhere near my providers monthly limit!
https://susepaste.org/82018721

Odd thing is, this comes AFTER the connections are made, and they work very well!

So? is there a problem with latest kernel on kernel firmware updates that have happened in the past few days?
Or is there another route I need to take to stop this from happening?

Edit>> The desktop is connected to the router with Ethernet cable. The laptops are both WIFi

This is specific to your router somehow, and not NetworkManager related.

Odd thing is, this comes AFTER the connections are made, and they work very well!

This doesn’t surprise me.

Perhaps check the Netgear Community website. For example…

https://community.netgear.com/t5/General-WiFi-Routers-Non/WNDR4000-Traffic-Meter-Counter-Warning-Webpage/td-p/1054455

There is no issue with openSUSE. Contact your provider. They are different. Mine is very terse and sends no messages for months once the connection has been set up:

08.11.20	07:58:46	IPv6-Präfix wurde erfolgreich aktualisiert. Neues Präfix: 2001.................
08.11.20	07:28:46	Internetverbindung wurde erfolgreich hergestellt. IPv4 wird über DS-Lite genutzt. AFTR-Gateway: (aftr.prod.m-online.net), IPv4-MTU: (1492).
08.11.20	07:28:46	IPv6-Präfix wurde erfolgreich bezogen. Neues Präfix: 2001...........................
08.11.20	07:28:46	Internetverbindung IPv6 wurde erfolgreich hergestellt. IP-Adresse: 2001...............
08.11.20	07:28:35	DSL ist verfügbar (DSL-Synchronisierung besteht mit 27496/5493 kbit/s).

I think this might be what @Bill_L is after:

This probably was something with the router causing all this.
The Internet panel light was constantly flashing amber , which if I read the manual right it was ‘using data’, even with every device in my house powered off. I couldn’t find any ‘leeching’ of my WiFi by devices other then what is in my house.

I did a full system reboot this morning with no devices powered on. Modem, router, and all devices off. Then modem on, next router on.
The internet light was STILL flashing amber.
I pushed the WiFi button on the panel, amber light went white, then I pushed the wifinlight button again, and the internet light is now solid white(like it’s been for years).

I won’t know until some more PC start up’s(desktop started w/o that router login prompt).

We’ll see…
thanks to all for your help and support AGAIN!

@tannington, I did that check several times yesterday, and didn’t find anything ‘out of place’ with data traffic.

Hello,

I also have a Netgear router (R6400).
Sometimes I have to push wi-fi button two or three times to work. Sometimes more. I never understand why it act like this.
To find what items are connected to my router I use nmap.

nmap -sn 192.168.1.0/24

.
AFAIK Netgear router ip should be 192.168.0.1 or 192.168.1.1.

Thanks for the tip! It will be a handy tool when in Leap15.2.

OK, I owe the forum users another big thanks for holding my hand!

Here is what I found looking at the Traffic Meter in the Netgear R7000 settings.
There is a setting to blink the internet light when traffic is within 51200 MB of the limit.(I’ll be changing that or turn it off?)
And checking status showed me in the red for usage, which from my provider information I knew was not possible.

BUT(A BIG BUT), the status was showing start and end dates in September! It too several refreshes to get it to November.
Also the start/end dates are not in sync with my provider(more to look up and set properly if possible).
NOTE TO SELF, CHECK THIS MORE OFTEN!!
Makes me wonder why this started causing problems in Leap 15.2 until just the past few days!

So, not knowing where the router gets its usage information from, right or wrong, I ‘spoofed’ the maximum limit and set it to a higher limit.

(apology to @tannington for not looking at the traffic meter more closely) another lesson learned.

You’re welcome!
(And thank you.)

No need to apologise, I’m normally the one that just makes the cursory glance… :slight_smile:

So, not knowing where the router gets its usage information from, right or wrong, I ‘spoofed’ the maximum limit and set it to a higher limit.

I don’t have that particular router, so this is just based upon the Netgear knowledge base article ( How do I monitor Internet traffic on my Nighthawk router? - NETGEAR Support ) I linked to. I guess it’s the total data passed through the router’s WAN port, either as download only or both directions dependant upon how you’ve set the router’s traffic meter.

If you’re confident that you’ll always be within your ISP’s limit I’d simply disable the traffic meter on the router. If on the other hand you’re going to be close to, or possibly exceed your limit, then a little while getting to grips with the traffic meter settings may be beneficial.

I think so.

Well done Bill!

Thanks! But if not for you and @tannigton, I would not have though to look at the router that deep.
I can only assume that it was building up its usage since early September because that was the start date. It did not kick over October then November as it should have.
I WILL be paranoid enough to be more diligent checking it.

AGAIN, THANKS TO EVERYONE THAT CONTRIBUTED TO THIS THREAD,

It can be hard to find out what causes a problem to emerge. Primarily you want to fix it, e.g. 737 MAX stab trim cut-out switches