Language of applications

Hi,

I’m using XFCE on oS 12.3.

If I start a KDE application, like konqueror or Dolphin I see it in
English locale, which is what I want. However, if I start “rosegarden”,
it is in Spanish.

Systemsettings says my locale is English, with Spanish as a second language.

How do I tell Rosegarden to speak English?

I’m Spanish, but I don’t quite understand the translation, it confuses me.

A hack I found is calling from the CLI like:


> LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 DICTIONARY=english KDE_LANG=en_US.UTF-8  rosegarden


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

You might try to add the localisation setting into the local Rosegarden config file: ~./config/rosegardenmusic/Rosegarden.conf; or try to modify the start command from the Xfce menu, to have it include the language preference.
I think this command should suffice:

 LANG=en_GB rosegarden
 LANG=en_US rosegarden

User - rosegarden language??
As I understood it from reading this thread there isn’t a straight forward option to change language for Rosegarden only, Mr McIntyre was responsible for porting Rosegarden to QT4/KDE4 so I expect he would have mentioned it if there was.

Systemsettings says my locale is English, with Spanish as a second language.

Strange that this happened though, does all QT4 apps use spanish by default?

On 2013-06-25 17:26, F Sauce wrote:
>
> You might try to add the localisation setting into the local Rosegarden
> config file: ~./config/rosegardenmusic/Rosegarden.conf;

I don’t see any setting for language in there. :-?

> or try to modify
> the start command from the Xfce menu, to have it include the language
> preference.

My locale is English. All software starts in English - with a few broken
exceptions, like rosegarden.


cer@Telcontar:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=es_ES@euro
LC_TIME=en_DK.UTF-8
LC_COLLATE=POSIX
LC_MONETARY=es_ES@euro
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=es_ES@euro
LC_NAME=es_ES@euro
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE=es_ES@euro
LC_MEASUREMENT=es_ES@euro
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
cer@Telcontar:~>

The settings are English, with a few exceptions like money and numbers.
Time is English from DK! The main one, LANG, is en_US.

> I think this command should suffice:
>
> Code:
> --------------------
> LANG=en_GB rosegarden
> LANG=en_US rosegarden
> --------------------

It doesn’t. That makes it start in Spanish.

> ‘User - rosegarden language??’ (http://tinyurl.com/p3wbahu)
> As I understood it from reading this thread there isn’t a straight
> forward option to change language for Rosegarden only, Mr McIntyre was
> responsible for porting Rosegarden to QT4/KDE4 so I expect he would have
> mentioned it if there was.

It appears that some software is acting “clever” and thinking it should
change the system settings and use a different language than that chosen
in my system preferences :-/

>> Systemsettings says my locale is English, with Spanish as a second
>> language.
>
> Strange that this happened though, does all QT4 apps use spanish by
> default?

All KDE apps use English, as they should. Only a few, like rosegarden
and qsynth use Spanish, I don’t know why. Those two I found so far.

QT, non KDE apps? No, qtconfig displays in English. Both kde3 and kde4
konqueror display in English.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

> You might try to add the localisation setting into the local Rosegarden
> config file: ~./config/rosegardenmusic/Rosegarden.conf;

I don’t see any setting for language in there. :-?

No, I didn’t either. I’m just guessing that it might be possible to overide the global setting here somewhere.

It appears that some software is acting “clever” and thinking it should
change the system settings and use a different language than that chosen
in my system preferences :-/

Yes it’s strange:|
I may add that it does not behave this way on my system, English/Norwegian.

All KDE apps use English, as they should. Only a few, like rosegarden
and qsynth use Spanish, I don’t know why. Those two I found so far.

QT, non KDE apps? No, qtconfig displays in English. Both kde3 and kde4
konqueror display in English.

All right.

There is a slightly different suggestion to a similar problem mentioned here: LinuxMusicians • View topic - language settings in Qt applications

On 2013-06-25 20:56, F Sauce wrote:

>> It appears that some software is acting “clever” and thinking it should
>> change the system settings and use a different language than that
>> chosen
>> in my system preferences :-/
>
> Yes it’s strange:|
> I may add that it does not behave this way on my system,
> English/Norwegian.

Weird.

> All right.
>
> There is a slightly different suggestion to a similar problem mentioned
> here: ‘LinuxMusicians • View topic - language settings in Qt
> applications’ (http://www.linuxmusicians.com/viewtopic.php?f=4&t=10275)

Well, the solution they use is similar to what I’m doing: call those
programs explicitly with a locale setting. They don’t explain why it
happens.

I have a script:


> cer@Telcontar:~> cat /usr/local/bin/ingles
> #!/bin/sh
> LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 DICTIONARY=english KDE_LANG=en_US.UTF-8   $*
> cer@Telcontar:~>

So I just call “ingles rosegarden” and I get it in English. It is weird,
but it works. Somehow those two applications ignore the KDE setting.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)