Language input method setup in OpenSUSE 11.4?

I just switched back from Mint 10, and while setting to work different input method apps like SCIM and Ibus, bumped into a problem(welcome back to SUSE). After installing Scim, my chinese input works only on one application (Goldendict), it doesn’t work in any other app. So I tried Ibus, same result. SO far nothing helped me to make them work.
What I 'm trying to find out. Is where I can setup language input method in SUSE, I haven’t found such an option anywhere in KDE, yast. WHile in Mint there is such an option, where you can change your inpud method either to scim, xim, scim-bridge or ibus. I tried qtconfig, there I found it, but that didn’t help me.

P.S. Warning rage words!:
I feel like I should say it. But my previous SUSE experience and overall usage history proves that there is no better distro than Ubuntu nowadays, this is sad indeed, cause I used to start from SUSE. But its true, SUSE is a real pain in the ***, when it comes to getting things done. It seems like whenever u try to setup something there is always a bad feeling of failure. Don’t know, but again I’m been consecutively annoyed but its numbness. I’m sorry, cause I feel like I disregard ppl’s hard work and support.

System Settings>Regional>Keyboard layout used to offer a way to set up the keyboard layout - but I understand System Settings has been redesigned in 4.6.

Yes. I was looking for this option everywhere, but to no avail. I think it would be nice to have it under the hood right there.

Don’t feel bad – it’s normal human nature to be frustrated occasionally.

I like Ubuntu too. But I like openSUSE better. Years ago, when I was not so familiar with openSUSE, I would spend a lot of time hunting for ways to get new configurations to work. And I would sometimes become frustrated like you do. But I nearly always (eventually) found a way. Then I would feel the sweet satisfaction of success.

Keep trying, it’s a worthy battle, and good ppl are here to help you.

))) Thank you

Having now installed 11.4 from a CD, I can tell that you the CD version only comes with the four default languages; you have to install KDE additional languages yourself. So that may be the cause of the problem. Having done that, everything appears fine but I haven’t yet found the keyboard layout module in the new setup in order to add/change layouts.

yes, I think that was the reason, after I added Chinese language via “languages” option and rebooted, ibus started work on all apps.
The only posible way to change a layout input method in KDE, i think, is to open in console “qtconfig” and under a tab “interface” choose a desired option for input method, but it is not available from “personal preferences”.

SuSEconfig drop gtk2 module in 11.4
after install inputmethod as ibus, you have to run
gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules for x86
gtk-query-immodules-2.0-64 > /etc/gtk-2.0/gtk64.immodules for x86_64
that will enable gtk-immodule support

thanks, but the issue got resolved somehow by himself after reboot I guess.

I could find a solution to this problem using a tricky method. read the full article on How to enable Keyboard Layout on OpenSuSE 11.4

That is the long way round; if you type ‘Keyb’ in search, you will find the redesigned keyboard layout module; it is just that there isn’t a link from it to system settings - a bug which I presume will be fixed in KDE in due course.

Not too difficult :

  1. Start Yast → Language -->Choose additional Languages

It will install additional languages requirement

  1. search → Region → Languages

  2. Transfer all languages you want and click Apply.

There… done :D.

Thanks a lot for the tip ! But actually there is a link, I dont know why they put it this way, but here is where I found the layouts :
Configure Desktop → Input Devices → Tadaaa ! you can add the layout from here and choose the key combination too.

Hope that helps someone.